Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Internal Server Error

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] Internal Server Error
 Login/Join
 
Member
posted
Facing 'Internal Servver Error" Recently migrated to WF8.1.04
When running a report of large data getting this error!!!
but when check in backend(in server the requested job running)

OS:Linux
Tomcat
WF8.1.04

Do any one find similar issue? Appreciate if any one can me help in this issue



~Sanravi

This message has been edited. Last edited by: <Kathryn Henning>,
 
Posts: 8 | Registered: November 05, 2014Report This Post
Expert
posted Hide Post
Could it be, something has hit a timeout ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Guru
posted Hide Post
If it's a really large data set being returned it is possible that you have ran into a java memory issue in Tomcat.

Generally if you are seeing the "internal server error" or HTTP 500 error then you need to look at the Tomcat log files to find out what the real issue is.

Stu


WebFOCUS 8.2.03 (8.2.06 in testing)
 
Posts: 253 | Location: Melbourne, Australia | Registered: February 07, 2007Report This Post
Master
posted Hide Post
We have an issue with running large Excel 2010 reports with multiple worksheets with an embedded auto-open macro. "Large" report is kind of subjective but with our error it is 2 or more worksheets and the total rows exceeds 10K. However, without the macro, it runs fine.

What we see is the with Excel 2003, the program will run and workbook will generate in about 20 seconds. It may take 20 minutes with Excel 2010.

IBI has confirmed the issue and it may be fixed in 8.2.

I think IBI needs to rethink how they zip files for Excel 2007 and higher because in general, even though the file is much smaller than Excel 2003, it takes 2-3 or more times as long to generate Excel 2007 format.


In FOCUS since 1985. Prod WF 8.0.08 (z90/Suse Linux) DB (Oracle 11g), Self Serv, Report Caster, WebServer Intel/Linux.
 
Posts: 975 | Location: Oklahoma City | Registered: October 27, 2006Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Internal Server Error

Copyright © 1996-2020 Information Builders