Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SHARING CASE] &WFDESCRIBE and Run Deferred
Go
New
Search
Notify
Tools
Reply
  
[SHARING CASE] &WFDESCRIBE and Run Deferred
 Login/Join
 
Expert
posted
I opened a case for this and will post the findings. Thanks for all the inputs.

I have an issue where a report (fex) can 'run directly' but will not 'Run Deferred' and thinking that it has to do with the value assigned to &WFDESCRIBE, which has a standard is not 'OFF', it's default of 'XMLRUN' (or something other than 'OFF').

The following is the result of the “-? &WFDESCRIBE” command.
-? &WFDESCRIBE
Produces:
CURRENTLY DEFINED & VARIABLES STARTING WITH 'WFDESCRIBE':
&WFDESCRIBE   = XMLRUN
&WFDESCRIBE   = OFF

My question is: Why is it there twice? The second one, OFF, negates the first one, XMLRUN, or the last one that it’s set to using the ‘-SET &WFDESCRIBE='Whatever';’ command.

My thought is that this is preventing procedures to run successfully as ‘Run Deferred’.

Your Thoughts and Input are greatly appreciated.

~Doug

This message has been edited. Last edited by: Doug,




   In FOCUS Since 1983 ~ from FOCUS to WebFOCUS.
   Current: WebFOCUS Administrator at FIS Worldpay | 8204, 8206
 
Posts: 3106 | Location: Tennessee, Nashville area | Registered: February 23, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Could it be possible that it is two distinct variable's name but only first 10 digits of the name is displayed so we thought that it's the same variable ?

But I can have up to 12 digits displayed from other variables...so I doubt that it's the case...

Maybe your best shot will be to contact TechSupport


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2347 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Doug

You might try to put -SET &ECHO=ALL; at the top of the fex and have the output of HTML. After the report runs deferred right mouse click on the output and view source and see if you can see that variable get set.. Not sure if it will display anything...


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 1952 | Location: Customer Support | Registered: April 12, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
Thanks MartinY,

The "-? Variable" command will display all variables with the specified variable as a prefix, similar to a search for a file as 'FILE*' which displays all files that start with 'FILE'. You can see this as follows:
-? &D
Which returns any variable starting with the letter 'D':
 CURRENTLY DEFINED & VARIABLES STARTING WITH 'D':
 &DATE         = 04/08/20
 &DBMSERR      =        0
 &DELTD        =        0
 &DMY          = 080420
 &DMYY         = 08042020
 &DUPLS        =        0
 
Posts: 3106 | Location: Tennessee, Nashville area | Registered: February 23, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
Thanks Chuck,

The issue is that 'Run Deferred' runs differently (AKA: Fails to run at all) the 'Run Direct'. Thus, I can't view the source of it when it's deferred.
 
Posts: 3106 | Location: Tennessee, Nashville area | Registered: February 23, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
@Doug

Reason why I mentioned that I am able to see variables with a 12 digits name and that I doubt it's the case...

But I also remember that there were an old bug where variable's name get "confused" when first x number of digits were the same.
And if I remember well it was something around the tenth digits.
But this bug seems to be now resolved because I have many variable's name that have similar digits without any issues.

Good luck


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2347 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Expert
posted Hide Post
Thanks again Martin, I hope you didn't take it as an insult to your experience as I didn't mean it that way at all.

I think that bug was fixed when we moved away from the 8.3 scenario.
 
Posts: 3106 | Location: Tennessee, Nashville area | Registered: February 23, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
REFERENCE/Just FYI: TONY A's Post from Jun 18 2013 12:52

As for autoprompting, you can also check the value for the variable &WFDESCRIBE by issuing -? & SAVEPRINT (ala Francis Mariani!) and if the value is anything other than OFF you have autoprompting turned on. The usual setting is XMLPROMPT.

This message has been edited. Last edited by: Doug,
 
Posts: 3106 | Location: Tennessee, Nashville area | Registered: February 23, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
There was a PCHOLD instead of a HOLD in the procedure. There was no PC to HOLD it to when running DEFERRED so it failed.

This message has been edited. Last edited by: Doug,
 
Posts: 3106 | Location: Tennessee, Nashville area | Registered: February 23, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
... And it get deeper. So I opened a case with IBI.




   In FOCUS Since 1983 ~ from FOCUS to WebFOCUS.
   Current: WebFOCUS Administrator at FIS Worldpay | 8204, 8206
 
Posts: 3106 | Location: Tennessee, Nashville area | Registered: February 23, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SHARING CASE] &WFDESCRIBE and Run Deferred

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.