Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] webfocus/reportcaster distribution service start up problem

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] webfocus/reportcaster distribution service start up problem
 Login/Join
 
Member
posted
Hi,

I installed Webfocus 7.1.7(with report caster) on windows 2008 R2 64bit server. when i tried to start report caster service .. it is not working. I am getting this msg.

"
Unable to communicate with the Distribution Server to obtain configuration information Please confirm that the Distribution Server is started and that the values of the ‘Distribution Server’ server host and port are correct.
"

When i checked report caster log it shows the fllowing

any one faced the same error ?. any suggestions please. I listed the webfocus environment at the bottom of this msg.. thanks for your help

About to call CreateSemaphore
Back from CreateSemaphore
next line is jrepath
java.exe
next line is buffer
-cp "E:\ibi\ReportCaster71\lib\SCHScheduler.jar;E:\Program Files\mysql-connector-java-5.1.16\mysql-connector-java-5.1.16-bin.jar;" -Xrs ibi.broker.SCHScheduler E:\ibi\ReportCaster71\
next line is temp
Starting service: -cp "E:\ibi\ReportCaster71\lib\SCHScheduler.jar;E:\Program Files\mysql-connector-java-5.1.16\mysql-connector-java-5.1.16-bin.jar;" -Xrs ibi.broker.SCHScheduler E:\ibi\ReportCaster71\
About to call CreateProcess
Time: 23:06:24

Back from CreateProcess
Time: 23:06:24

pi.dwProcessId=0
Entering GetLastErrorText
Cannot create a file when that file already exists. (0xb7)
Exiting GetLastErrorText
Error found is on next line
Cannot create a file when that file already exists. (0xb7)
Entered service_reportstatus
Returning with no error from service_reportstatus
Cannot create a file when that file already exists. (0xb7)
Exiting service_main

Windows 2008 R2 64bit
JAVA 1.6.0_25
MYSQL 4.1
TOMCAT 7
IIS 7.5

This message has been edited. Last edited by: Kerry,
 
Posts: 8 | Registered: April 15, 2008Report This Post
Master
posted Hide Post
Make sure reportcaster is running as a full function server.



- ABT


------------------------------------
WF Environment:
------------------------------------
Server/Client, ReportCaster, Dev Studio: 7.6.11
Resource Analyzer, Resource Governor, Library, Maintain, InfoAssist
OS: Windows Server 2003
Application/Web Server: Tomcat 5.5.25
Java: JDK 1.6.0_03
Authentication: LDAP, MRREALM Driver
Output: PDF, EXL2K, HTM

------------------------------------
Databases:
------------------------------------
Oracle 10g
DB2 (AS/400)
MSSQL Server 2005
Access/FoxPro
 
Posts: 561 | Registered: February 03, 2010Report This Post
Member
posted Hide Post
how to validate that.. whether it is full functional server or not.. sorry for the trouble
 
Posts: 8 | Registered: April 15, 2008Report This Post
Gold member
posted Hide Post
Does 7.1.7 support 2008 64-bit servers? That's a very old version. Look in the installation requirements section of the manual. Also, the Java version must be 64-bit also. Why wouldn't you upgrade to a more current version?


WebFOCUS 7.7.05M, gen 144, Windows 2008 Server R2 64-bit, Tomcat 6.0.33, IIS 7.0, SQL Server, Excel 2013, PDF, HTML, FOCUS files.
 
Posts: 88 | Location: Seattle | Registered: March 29, 2007Report This Post
Gold member
posted Hide Post
I don't think 2008 is supported for 7.1.7 per documentation. See http://techsupport.information...ase_information.html.
This is what's approved for 7.1.7:
Windows 2000 (requires Service Pack 2 or higher)
Windows 2003
Windows XP can be used in development environments only. (NTFS considerations for Windows 2003 apply to Windows XP)


WebFOCUS 7.7.05M, gen 144, Windows 2008 Server R2 64-bit, Tomcat 6.0.33, IIS 7.0, SQL Server, Excel 2013, PDF, HTML, FOCUS files.
 
Posts: 88 | Location: Seattle | Registered: March 29, 2007Report This Post
Member
posted Hide Post
I installed java 64bit version.

I agree it is very old version. we are trying to run it on windows 2008 R2 64bit.

Wefocus server/client/report caster installed. i did ran Diagnostics verification and everything validated ok except the report caster. error mgr 'unable to attach to the distribution server' error.

I am able to login to business inteligence dashboard/MR administration too. report caster console login is the issue. i am able to start the distribution server from command line.

seems the report caster services is the only not working.
 
Posts: 8 | Registered: April 15, 2008Report This Post
Silver Member
posted Hide Post
We had the same problem recently.
If I remeber right, it has to do with CLASS_PATH setting somewhere or some other environment variable. Apparantly, I can not remember where to set it.

Regards,
Markus


WF 7.6.6 (MRE,BID, DevStudio, partly RC) on Windows 2003 /Apache/Tomcat
Output: HTML,Excel,PDF,PPT
Adapters: SQL Server, DB2, Oracle
 
Posts: 38 | Location: Austria, Linz | Registered: June 19, 2009Report This Post
Member
posted Hide Post
I would appreciate if you can provide me the details. it would be big help.. please give it a min?


webfocus 7.1.7,
Windows 2003
HTML
 
Posts: 8 | Registered: April 15, 2008Report This Post
Platinum Member
posted Hide Post
One classpath is set in ibi\reportcaster\bin\classpath.bat

This has the classpath information for your repository and the reportcaster.jar


Webfocus 8.0.7 on Windows
 
Posts: 176 | Location: Ohio | Registered: October 26, 2006Report This Post
Member
posted Hide Post
The jre installed needs to be installed as public.


Production: WebFOCUS 7.6.1
Test: WebFOCUS 7.6.9
Windows 2003, Unix AIX
All
 
Posts: 6 | Location: Dallas TX | Registered: July 16, 2009Report This Post
Master
posted Hide Post
Is schbkr actually running?

You can find the schbkr startup command in:
/home/iadmin/ibi/WebFOCUS77/ReportCaster/bin (in a Linux installation).

I believe the command under Windoze is just schbkr.com. However it will stop when you quit the session - at least under Linux (I'm not familiar with installations under M$). So you should look to the boot-up file for WF and find the lines there that relate to ReportCaster and the distribution server and make sure they point where they should.

This message has been edited. Last edited by: George Patton,


WebFOCUS 7.7.05 Windows, Linux, DB2, IBM Lotus Notes, Firebird, Lotus Symphony/OpenOffice. Outputs PDF, Excel 2007 (for OpenOffice integration), WP
 
Posts: 674 | Location: Guelph, Ontario, Canada ... In Focus since 1985 | Registered: September 28, 2010Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] webfocus/reportcaster distribution service start up problem

Copyright © 1996-2020 Information Builders