Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at community@tibco.com for further assistance. Reference the community FAQ to learn more about the community.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Embed a WF Report into a HTML iframe created outside of WF

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] Embed a WF Report into a HTML iframe created outside of WF
 Login/Join
 
Platinum Member
posted
Hi All,

I have created a basic report like before and placed the FEX file in Public domain and published the report.
TABLE FILE CAR
PRINT
SALES
BY COUNTRY
BY CAR
ON TABLE PCHOLD FORMAT HTML
END

Now, I have created a sample html out side of WebFOCUS with one iframe in that HTML. I tried to call the FEX file using a rest service call and load it in to iframe. But, in IE it says 'The content can not be displayed in frame' when i click the link it opens in a new tab. In Chrome it shows a blank page and when looked at F12 it shows "Refused to display 'http://localhost:8080/ibi_apps/rs/ibfs/WFC/Repository/Public/Sample_Report.fex' in a frame because it set 'X-Frame-Options' to 'sameorigin'."

I searched this in tech support and found the below link to set the IBI_XFRAMEOPTIONS in Filters section in Admin Console>Configuration>Filters. I am using 8201M and that option doesn't exist.

Appreciate any help on embedding a basic report into a HTML frame which is created outside of WebFOCUS

Here is the sample HTML code used
 <!DOCTYPE html>
<html>

  <head>
    
  </head>

  <body >
    <iframe src="http://localhost:8080/ibi_apps/rs/ibfs/WFC/Repository/Public/Sample_Report.fex" style="width:1000px;height:650px;overflow:scroll;" id="MyFrame"></iframe>
   

  </body>

</html> 


Thanks,
Rao.

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS - ver8201
[ReportingServers: Windows 64bit;
Client: tomcat and IIS on windows 2012
AppStudio

 
Posts: 104 | Location: Indianapolis | Registered: November 08, 2007Report This Post
Virtuoso
posted Hide Post
Rao

Just a thought but I think you should replace localhost with the real server name.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Master
posted Hide Post
Judging from the URL you show, it looks like your requirement is to call a report from the WebFOCUS Managed Reporting repository, using the WF RESTful web service request.

The URL looks OK, and you would want to add the IBIRS_action parm, to tell WF/RS you want to EXecute a report.

So, in your case something like:
http://localhost:8080/ibi_apps/rs/ibfs/WFC/Repository/Public/Sample_Report.fex?IBIRS_action=run 

I usually try to render the URL directly in the browser first, and then call from an iframe src. (Baby steps is my mantra. :-))
 
Posts: 822 | Registered: April 23, 2003Report This Post
Expert
posted Hide Post
Would that work with "localhost"? Or, as FP Mod Chuck thinks, you should replace localhost with the real server name.
 
Posts: 3132 | Location: Tennessee, Nashville area | Registered: February 23, 2005Report This Post
Master
posted Hide Post
Well, I guess I could have said to try something like this...:
http://host:port/ibi_apps/rs/ibfs/WFC/Repository/Public/Sample_Report.fex?IBIRS_action=run
where:
 host
  Is the name of the system where WebFOCUS is installed.
 port
  Is the port number used by WebFOCUS.

Most, if not all of the examples, in the WebFOCUS RESTful Web Services Developer's Guide show 'localhost' as the host name, with the understanding that if the host isn't localhost, you would want to change the host name.

Sounds like we need to hear back from the poster.

:-)

This message has been edited. Last edited by: David Briars,
 
Posts: 822 | Registered: April 23, 2003Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Embed a WF Report into a HTML iframe created outside of WF

Copyright © 1996-2020 Information Builders