Focal Point
[SOLVED] Populate listbox with .fex

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/7111003742

September 17, 2007, 01:48 PM
Shirley
[SOLVED] Populate listbox with .fex
Hi,

Recently we've converted from version 5.33 to 7.62. I have an html launch page that contains a listbox which populates by another .fex. This .fex takes &MREID and runs through some validation before populating the listbox. If I hard coded the &MREID in the .fex by SET command, listbox would be populated properly. If I run it through dashboard using &MREID from the MRE, I get "Error retrieving data."

Has anyone encountered similar issue? Please help!!!

This message has been edited. Last edited by: Kerry,


Shirley Huang
WF 7.7.04M MRE BID DevStudio
WIN2003, SQL Server 2000/DB2
HTML/PDF/EXL2k/AHTML
iSM 6.16
September 17, 2007, 03:36 PM
Shirley
IBI support came back with the following solution:

http://techsupport.informationbuilders.com/tech/wbf/wbf_dia_177.html


Shirley Huang
WF 7.7.04M MRE BID DevStudio
WIN2003, SQL Server 2000/DB2
HTML/PDF/EXL2k/AHTML
iSM 6.16
September 17, 2007, 03:41 PM
Francis Mariani
I love the last line to this solution:
quote:
The current workaround to this issue is to use FireFox as your browser.


And, why the magical numbers 49 and 135?


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
September 17, 2007, 03:59 PM
Shirley
Thankfully I didn't have to deal with those magical numbers.

It sounds like you know the answer.


Shirley Huang
WF 7.7.04M MRE BID DevStudio
WIN2003, SQL Server 2000/DB2
HTML/PDF/EXL2k/AHTML
iSM 6.16
October 01, 2008, 03:39 PM
MacLonghorn
Francis, is there a link to the latest hotfix for 7.6.2? Is it something that can be downloaded? Or do I need to have the customer request it specifically?


Thanks.

Mark
WF 7.6 Windows
October 01, 2008, 03:43 PM
GinnyJakes
Hot fixes can be downloaded from the download page for the site code that you are interested in.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
October 01, 2008, 03:48 PM
MacLonghorn
Thanks GJ


Thanks.

Mark
WF 7.6 Windows
October 02, 2008, 05:12 AM
GamP
Shirley,

It would ever so much surprise me, if this hotfix solves your problem. This fix deals with caching data, and that does not seem to be the case from your description.
To me it sounds more like a problem with retreiving the mre id from the webserver/browser. What happens if you run the child .fex that should collect the data for your list box separately, meaning outside of the parent fex? My geuss is that the MREID is not populated correctly leading to some error situation.
Be sure to switch on the echo when you run the procedure.

Hope this helps ...


GamP

- Using AS 8.2.01 on Windows 7 - IE11.
in Focus since 1988
October 02, 2008, 06:19 AM
Tony A
Gamp,

This is a reopened topic by MacLonghorn.

Check the date of Shirley's posts and you will see that they are over a year old. It's something we should all look to do when replying Smiler

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.06 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
October 02, 2008, 07:17 AM
GamP
Thanks Tony for pointing me. I never did notice the date(s).
Although, it would be nice to know if she has found a solution for her original problem.

I'll try to take better notice in the future ....


GamP

- Using AS 8.2.01 on Windows 7 - IE11.
in Focus since 1988