Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Populate listbox with .fex
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] Populate listbox with .fex
 Login/Join
 
Gold member
posted
Hi,

Recently we've converted from version 5.33 to 7.62. I have an html launch page that contains a listbox which populates by another .fex. This .fex takes &MREID and runs through some validation before populating the listbox. If I hard coded the &MREID in the .fex by SET command, listbox would be populated properly. If I run it through dashboard using &MREID from the MRE, I get "Error retrieving data."

Has anyone encountered similar issue? Please help!!!

This message has been edited. Last edited by: Kerry,


Shirley Huang
WF 7.7.04M MRE BID DevStudio
WIN2003, SQL Server 2000/DB2
HTML/PDF/EXL2k/AHTML
iSM 6.16
 
Posts: 55 | Registered: May 05, 2006Reply With QuoteReport This Post
Gold member
posted Hide Post
IBI support came back with the following solution:

http://techsupport.informationbuilders.com/tech/wbf/wbf_dia_177.html


Shirley Huang
WF 7.7.04M MRE BID DevStudio
WIN2003, SQL Server 2000/DB2
HTML/PDF/EXL2k/AHTML
iSM 6.16
 
Posts: 55 | Registered: May 05, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
I love the last line to this solution:
quote:
The current workaround to this issue is to use FireFox as your browser.


And, why the magical numbers 49 and 135?


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Gold member
posted Hide Post
Thankfully I didn't have to deal with those magical numbers.

It sounds like you know the answer.


Shirley Huang
WF 7.7.04M MRE BID DevStudio
WIN2003, SQL Server 2000/DB2
HTML/PDF/EXL2k/AHTML
iSM 6.16
 
Posts: 55 | Registered: May 05, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Francis, is there a link to the latest hotfix for 7.6.2? Is it something that can be downloaded? Or do I need to have the customer request it specifically?


Thanks.

Mark
WF 7.6 Windows
 
Posts: 150 | Registered: July 26, 2007Reply With QuoteReport This Post
Expert
posted Hide Post
Hot fixes can be downloaded from the download page for the site code that you are interested in.


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
 
Posts: 2723 | Location: Ann Arbor, MI | Registered: April 05, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Thanks GJ


Thanks.

Mark
WF 7.6 Windows
 
Posts: 150 | Registered: July 26, 2007Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Shirley,

It would ever so much surprise me, if this hotfix solves your problem. This fix deals with caching data, and that does not seem to be the case from your description.
To me it sounds more like a problem with retreiving the mre id from the webserver/browser. What happens if you run the child .fex that should collect the data for your list box separately, meaning outside of the parent fex? My geuss is that the MREID is not populated correctly leading to some error situation.
Be sure to switch on the echo when you run the procedure.

Hope this helps ...


GamP

- Using AS 8.2.01 on Windows 7 - IE11.
in Focus since 1988
 
Posts: 1960 | Location: Netherlands | Registered: September 25, 2007Reply With QuoteReport This Post
Expert
posted Hide Post
Gamp,

This is a reopened topic by MacLonghorn.

Check the date of Shirley's posts and you will see that they are over a year old. It's something we should all look to do when replying Smiler

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.06 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5604 | Location: United Kingdom | Registered: April 08, 2004Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Thanks Tony for pointing me. I never did notice the date(s).
Although, it would be nice to know if she has found a solution for her original problem.

I'll try to take better notice in the future ....


GamP

- Using AS 8.2.01 on Windows 7 - IE11.
in Focus since 1988
 
Posts: 1960 | Location: Netherlands | Registered: September 25, 2007Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Populate listbox with .fex

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.