Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Maintain for 7.7.01 Not Recognizing Compound Where in For All Next

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] Maintain for 7.7.01 Not Recognizing Compound Where in For All Next
 Login/Join
 
Gold member
posted
I have a maintain program which works in my 7.6.8 environment, but when I deploy it to 7.7.01 it has a problem.
It has the following code:

For All Next
mhmes.ROOT_SEG.CLIENT_ID
mhmes.ID_SEG.BSU_ID
mhmes.FAC_SEG.FACILITY_NO
mhmes.MON_SEG.YEAR
mhmes.PAC_SEG.PAC
mhmes.TYPE_SEG.SERV_TYPE
Into stkMHMESList
Where
FACILITY_NO EQ entryFacilCode AND
MONTH EQ searchMonth AND
YEAR EQ searchYear AND
PAC EQ entryPAC AND
SERV_TYPE EQ displayServiceType AND
THER_TYPE EQ displayTherapyType AND
FUNDING EQ displayFundingSource AND
RECORD_TYPE IN ('2','6') AND
GROUP EQ groupCode;

It does not work. It won't pull any values unless I remove all but one of the comparisons.
They work individually but don't work together.

Is this a known issue or am I doing something wrong?

This message has been edited. Last edited by: RichardA,


Sandbox Version: 8.1.04
Sandbox Platform: Windows 2008 R2
Testing Version: 7.7.02M
Testing Platform: Windows Server 2008 R2
WF Production Version: 7.7.02M
Production Platform: Windows Server 2008
 
Posts: 57 | Location: Philadelphia, PA | Registered: June 19, 2007Report This Post
Master
posted Hide Post
Richard
There is no known issue with compound where clauses. I will set up a test here, but it would be great if you could send me your Master file. Zip it and send it to Mark_Derwin@ibi.com. You have to zip it otherwise outlook will strip it.

Thanks
Mark
 
Posts: 663 | Location: New York | Registered: May 08, 2003Report This Post
Platinum Member
posted Hide Post
Richard,

Have you tried fully qualifying the field names in the Where clause ?


Regards,
Dave

http://www.daveayers.com

WebFocus/Maintain 7.6.4-8
on Win2000 and 2003 Server
 
Posts: 165 | Location: Detroit Metro | Registered: September 17, 2003Report This Post
Gold member
posted Hide Post
I opened a case about this problem. Developer's Studio works with the maintain but the server does not. Thanks for your help.


Sandbox Version: 8.1.04
Sandbox Platform: Windows 2008 R2
Testing Version: 7.7.02M
Testing Platform: Windows Server 2008 R2
WF Production Version: 7.7.02M
Production Platform: Windows Server 2008
 
Posts: 57 | Location: Philadelphia, PA | Registered: June 19, 2007Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Maintain for 7.7.01 Not Recognizing Compound Where in For All Next

Copyright © 1996-2020 Information Builders