Focal Point
[CLOSED] Cluster Master file Ignoring Join

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/7247015496

October 01, 2020, 10:10 AM
srajeevan
[CLOSED] Cluster Master file Ignoring Join
Hi All,

I have this cluster master file where i have few tables joined. I understand that WF ignores the join , if a field from a table is not used in the ouput.If i don't have that join established the output value from WF request doesn't match the sql output. What is the recommended way to overcome this.?
  • Should i give the join condition in the where clause ?
  • Should i manually join individual table for the WF request?

    This message has been edited. Last edited by: FP Mod Chuck,


  • WF8206,Windows 7,8,10
    HTM,PDF,EXCEL
    October 01, 2020, 10:20 AM
    FP Mod Chuck
    srajeevan

    Please post the cluster master file so we can see how it is joined.


    Thank you for using Focal Point!

    Chuck Wolff - Focal Point Moderator
    WebFOCUS 7x and 8x, Windows, Linux All output Formats
    October 02, 2020, 12:17 AM
    Rajesh Singh Negi
    Hi Srajeevan,

    Can you give more details on the tables and your cluster master files?
    Also, the join condition you want to have on the cluster.
    It would be good if you can also post the SQL query as well.

    Thanks


    Webfocus 8.x
    Windows
    PDF,HTML,XLSX
    October 02, 2020, 07:23 AM
    Mike in DeLand
    I've had this happen too. We use a lot of cluster MFDs here. I noticed that our summing operations didn't work unless I included certain fields, so I go ahead and put those fields on my report and then just make it a hold file. Then a second step to actually create the report.


    Webfocus 8
    Windows, Linux