Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] combining focus tables
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] combining focus tables
 Login/Join
 
Silver Member
posted
Here's some sample code of a report (encumbrances6320.fex) I'm trying to run:

USE
Encumbrances2017 AS EncumbrancesAll
Encumbrances2018 AS EncumbrancesAll
END

TABLE FILE EncumbrancesAll
IF RECORDLIMIT EQ 10
PRINT *
ON TABLE HOLD AS Encumbrances_82 FORMAT FOCUS
END

But I get the following with SET ECHO:

USE
Encumbrances2017 AS EncumbrancesAll
Encumbrances2018 AS EncumbrancesAll
END
TABLE FILE EncumbrancesAll
IF RECORDLIMIT EQ 10
PRINT *
ON TABLE HOLD AS Encumbrances_82 FORMAT FOCUS
END
-EXIT
ERROR AT OR NEAR LINE 56 IN PROCEDURE encumbrances6320
(FOC036) NO DATA FOUND FOR THE FOCUS FILE NAMED: encumbrances2017.foc

ERROR AT OR NEAR LINE 57 IN PROCEDURE encumbrances6320
(FOC036) NO DATA FOUND FOR THE FOCUS FILE NAMED: encumbrances2018.foc

ERROR AT OR NEAR LINE 68 IN PROCEDURE encumbrances6320
(FOC036) NO DATA FOUND FOR THE FOCUS FILE NAMED: ENCUMBRANCESALL

This is what FOC036 is:

(FOC036) NO DATA FOUND FOR THE FOCUS FILE NAMED: %1
Either data cannot be located for the FOCUS file, or access is not
allowed. If data cannot be located, a USE command may be needed.

The above code works with WebFocus version 77. However, we're migrating to version 82 and that's where I'm getting the FOC036 error. But if I do a TABLE FILE against one of those 2 focus tables in version 82, I get data.

I don't understand why the USE statement can't get to the data in those 2 focus tables.

Thanks,
Mark

This message has been edited. Last edited by: folkie,


WF 8.2.02
App Studio
DataMigrator
ReportCaster
Windows Server 2016
 
Posts: 32 | Registered: September 08, 2003Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Mark

Make sure the .foc files are in a app folder in the APP PATH or add an APP PATH command to the app folder at the beginning of the fex.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 1569 | Location: Customer Support | Registered: April 12, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
quote:

Encumbrances2017
Encumbrances2018

What file type are they ?
Do you have a MFD (.mas) defined for them ?


WF versions : Prod 8.2.0.1M gen 240, Dev 8.2.04 gen 48, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2165 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Virtuoso
posted Hide Post
USE only works with .FOC files.

https://webfocusinfocenter.inf...ng/source/use108.htm


WebFOCUS 8206, Unix, Windows
 
Posts: 1660 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Silver Member
posted Hide Post
The 2 tables in the USE are focus tables. In the real code I use APP PATH. Like I say, the same code works in version 77.

But minutes ago, I looked at a focexec my co-worker has with a USE and it works fine. She's using different focus tables. I'm trying to figure out what other differences there are between hers and mine.

Thanks,
Mark


WF 8.2.02
App Studio
DataMigrator
ReportCaster
Windows Server 2016
 
Posts: 32 | Registered: September 08, 2003Reply With QuoteReport This Post
Guru
posted Hide Post
There is A LOT of code tightening between v77 and v82. You might need a fully qualified path to the hold file.

Try the following and see if WF can give you the full path to the hold files
  
WHENCE Encumbrances2017 MASTER
WHENCE Encumbrances2018 MASTER


Hallway
WF(Prod):8202M
WF(Test):8202M
OS/Platform:Win 10
Outputs:All
 
Posts: 431 | Location: Salt Lake City, UT, USA | Registered: November 18, 2015Reply With QuoteReport This Post
Silver Member
posted Hide Post
Hallway,

I thought your suggestion was one of the many things I tried. However, when I just tried it, it worked!

Apparently, I used the path for the focus tables, but I left off the ".foc" filename extension. Using .foc along with the path is what did the trick.

Thanks,
Mark


WF 8.2.02
App Studio
DataMigrator
ReportCaster
Windows Server 2016
 
Posts: 32 | Registered: September 08, 2003Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] combining focus tables

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.