Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED / NFR] Hide "Your request did not return any output to display."?
Go
New
Search
Notify
Tools
Reply
  
[SOLVED / NFR] Hide "Your request did not return any output to display."?
 Login/Join
 
Expert
posted
Is there a way to prevent this message, (top portion of the HTML page when there's nothing but the results of a desired -TYPE statements?

Example, I have a fex with a bunch of comments, -SETs, -DEFAULT(S)s for some variables, then the following before the actual TABLE FILE requests, etc. For testing, All I want to see if the display of the -TYPE statements, without wasting / seeing the above message.

NOTES:
1) I don't want to use the -HTMLFORM BEGIN / END as these -TYPE statements will remain in my fex for production.
2) I turn ECHO off prior to the -TYPEs.
3) This is in all versions of WebFOCUS, although, I'm currently;y interested in 82.
-TYPE *** ---------------------------------------
-TYPE *** &|Variable1............. &Variable1
-TYPE *** &|Variable2............. &Variable2
-TYPE *** &|Variable3 ............ &Variable3
-TYPE *** &|Variable4 ............ &Variable4
-TYPE *** ---------------------------------------

Thanks, Doug

This message has been edited. Last edited by: Doug,




   In FOCUS Since 1983 ~ from FOCUS to WebFOCUS.
   Current: WebFOCUS Administrator at FIS Worldpay | 8204, 8206
 
Posts: 3103 | Location: Middle Tennessee | Registered: February 23, 2005Reply With QuoteReport This Post
Guru
posted Hide Post
You have several choices. the easiest is type in
-SET &ECHO=ALL; at the top of your FEX and then
-EXIT before the TABLE FILE. Another is to type
SET XRETRIEVAL = ON at the top of your FEX.


WF 7.6.11
Oracle
WebSphere
Windows NT-5.2 x86 32bit
 
Posts: 398 | Registered: February 04, 2008Reply With QuoteReport This Post
Expert
posted Hide Post
If you really want to turn all off except the -TYPE's, then try SET EMGSRV = OFF

This is pretty full on, as it will not even show errors


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6272 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
Waz: I still get the
Your request did not return any output to display.
Possible causes:
 - No data rows matched the specified selection criteria.
 - Output was directed to a destination such as a file or printer.
 - An error occurred during the parsing or running of the request. 
which is what I want to get rid of with "SET EMGSRV = OFF"

RSquared That echos the -TYPE statements as well which is not as clean as I want Frowner

Execute the following:
-TYPE *** This is the most basic of fexes.  Just this -TYPE statement and the following line is -EXIT ***
-EXIT
 
Posts: 3103 | Location: Middle Tennessee | Registered: February 23, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
I think that the only way to achieve that is to change a WebFOCUS file named ENtemplate.xml.

As with any change that you make to one of these files, I would suggest that you make a backup and not undertake the change lightly!

The one that you want is in the WFC folder.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5684 | Location: United Kingdom | Registered: April 08, 2004Reply With QuoteReport This Post
Virtuoso
posted Hide Post
NFR?


Daniel
In Focus since 1982
wf 8.202M/Win10/IIS/SSA - WrapApp Front End for WF

 
Posts: 1959 | Location: Tel Aviv, Israel | Registered: March 23, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
Sorry, forgot that you are returning the output of the run.

Would be easier to add in the -HTMLFORM instead of the -TYPE statements


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6272 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
quote:
Would be easier to add in the -HTMLFORM instead of the -TYPE statements

Totally agree!

Why is that not an option Doug?

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.07 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5684 | Location: United Kingdom | Registered: April 08, 2004Reply With QuoteReport This Post
Expert
posted Hide Post
Tony: Hey There Tony. Long time no see... Smiler
* I would suggest that you make a backup and not undertake the change lightly!
- Yeppers!

Tony / Waz:
* Why is that (add in the -HTMLFORM instead of the -TYPE statements) not an option Doug?
- I want to keep it simple, as in, the -TYPE statements are there for production and the HTMLFORM would prevent the display of the following report, etc.

Danny-SRL: Yep, probably a back burner NFR...

It's actually just a real-nice-to-have function. Did I just say "function"... I should look it up in my "User Written Subroutines Library" (and functions) red book, © 1984, by Information Builders... Shucks, it's in there. Frowner

This message has been edited. Last edited by: Doug,
 
Posts: 3103 | Location: Middle Tennessee | Registered: February 23, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED / NFR] Hide "Your request did not return any output to display."?

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.