Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] PNG Chart
 Login/Join
 
Gold member
posted
Can anyone tell me what is going on with 1. the Y2 title going off the chart and 2. the legend and title getting smashed together. I have only worked with JSCHART in the past so I'm not sure which properties I need to look at. Thanks!

 
GRAPH FILE IBISAMP/CAR
SUM
CNT.CAR		AS 'Count of Cars'
CNT.MODEL 	AS 'Count of Models'
BY COUNTRY 	AS 'Country'
ON GRAPH PCHOLD FORMAT PNG
ON GRAPH SET LOOKGRAPH VBAR2AX
ON GRAPH SET STYLE *
*GRAPH_SCRIPT
setTextRotation(getO1Label(),0);
setDisplay(getY1Title(),true);
setDisplay(getY2Title(),true);
setAxisAssignment(getSeries(0),0);
setAxisAssignment(getSeries(1),1);
setTextString(getY1Title(),"Total Cars");
setTextString(getY2Title(),"Total Models");
*END
END 

This message has been edited. Last edited by: FP Mod Chuck,


WF 8.0.08 (Prod); WF 8.2.04 (Dev)
 
Posts: 61 | Location: OK | Registered: November 19, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Hello,

Look at this once
 

-DEFAULTH &WF_STYLE_HEIGHT='700.0';
-DEFAULTH &WF_STYLE_WIDTH='300.0';

GRAPH FILE IBISAMP/CAR
SUM
CNT.CAR		AS 'Count of Cars'
CNT.MODEL 	AS 'Count of Models'
BY COUNTRY 	AS 'Country'
ON GRAPH SET VZERO OFF
ON GRAPH SET HTMLENCODE ON
ON GRAPH SET GRAPHDEFAULT OFF
ON GRAPH SET HAXIS '&WF_STYLE_HEIGHT'
ON GRAPH SET VAXIS '&WF_STYLE_WIDTH'
ON GRAPH SET GRMERGE ADVANCED
ON GRAPH SET GRMULTIGRAPH 0
ON GRAPH SET GRLEGEND 0
ON GRAPH SET GRXAXIS 1
ON GRAPH SET AUTOFIT ON
ON GRAPH PCHOLD FORMAT PNG
ON GRAPH SET LOOKGRAPH VBAR2AX
ON GRAPH SET STYLE *
*GRAPH_SCRIPT
-*setTextRotation(getO1Label(),0);
-*setDisplay(getY1Title(),true);
-*setDisplay(getY2Title(),true);
-*setAxisAssignment(getSeries(0),0);
-*setAxisAssignment(getSeries(1),1);
-*setTextString(getY1Title(),"Total Cars");
-*setTextString(getY2Title(),"Total Models");
-*setFontSizeAbsolute(getO1Label(),true);
-*setFontSize(getO1Label(),8);
-*setTextWrap(getO1Label(),true);
-*
-*setFontSizeAbsolute(getY1Label(),true);
-*setFontSize(getY1Label(),8);
-*setTextWrap(getY1Label(),true);
-*
-*setFontSizeAbsolute(getY1Title(),true);
-*setFontSize(getY1Title(),6);
-*
-*-*
-*setO1LabelAutofit(false);
-*setPieDepth(0);
-*setPieTilt(0);
-*setDepthRadius(0);
-*setCurveFitEquationDisplay(false);
-*setPlace(false);
-*setDisplay (getO1Title(),false);
*END
END 
-EXIT


 
 
Posts: 92 | Registered: February 02, 2016Reply With QuoteReport This Post
Gold member
posted Hide Post
I got an email notice with another post that is no longer on this thread, that fixed my issue. The issue was the follwing line of code:
 
setPlace(true);


Thanks to all who assisted.


WF 8.0.08 (Prod); WF 8.2.04 (Dev)
 
Posts: 61 | Location: OK | Registered: November 19, 2015Reply With QuoteReport This Post
  Powered by Social Strata  
 


Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.