Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Printing/displaying used parameters

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] Printing/displaying used parameters
 Login/Join
 
Member
posted
Hello WF family,

I'm here for an advice. I need to print/display used parameters in the report.

At this moment this moment I am using it like this (don't hate me for having it wrong or like this :-) )

  
-SET &PARA='Transaction Date From:' || &TD_DATTIM_FROM  || ', ' || 'Transaction Date To:' || &TD_DATTIM_TO  || ', ' ..... many more;


-SET &FARA = TRIM_(BOTH, ' ',STRREP(&PARA.LENGTH,&PARA,8,'FOC_NONE',1 ,'-',4096,'A4096V'));
-SET &LARA = TRIM_(BOTH, ' ',STRREP(&FARA.LENGTH,&FARA,9,'_FOC_NULL',1 ,'-',4096,'A4096V'));




and then printing/displayin in the file (Excel as an example)

 
ON TABLE SUBHEAD
"<NAME "
" FILE <NAME GENERATED ON: <CAS <+0> "
HEADING
" "
-*"USED PARAMETERS: &LARA "
 



Any better solution for this?

Thanks a lot!

but getting error from reporting server

 

Reporting Server Error
The value of an amper variable exceeds the maximum length

 


Thank you very much for any feedback!

This message has been edited. Last edited by: FP Mod Chuck,


WF 7.7.05M, 8.1.05M, Linux, HTML, Excel, Active Report
 
Posts: 8 | Registered: July 13, 2017Report This Post
Virtuoso
posted Hide Post
smOk

Put this line of code after your last -SET &LARA
-TYPE &LARA.LENGTH to see how big the parameter value is.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Expert
posted Hide Post
I would suggest not using A4096V.
Change it to A4096, but also do an RTRIM (Needs v8) around it to get rid of the trailing spaces.

Also you can put in the variable into the format and length of the STRREP. This will minimise the trailing spaces.

e.g.
-SET &LARA = TRIM_(BOTH, ' ',STRREP(&FARA.LENGTH,&FARA,9,'_FOC_NULL',1 ,'-',&FARA.LENGTH,'A&FARA.LENGTH|V'));


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Member
posted Hide Post
quote:
Originally posted by FP Mod Chuck:
smOk

Put this line of code after your last -SET &LARA
-TYPE &LARA.LENGTH to see how big the parameter value is.


Hello Chuck,

thank you for the input

Length is 555 and that should be fine. Ofc there can be more characters when we search for multiple parameters.

The thing is that this is not working on 8207 but on 8105 it works pretty fine. I've just discovered that on 8207 this might not be the issue but something else. I will have to dig deeper into it.

Any other ideas or ways how to do this will be appreciated.

Thank you Chuk!


WF 7.7.05M, 8.1.05M, Linux, HTML, Excel, Active Report
 
Posts: 8 | Registered: July 13, 2017Report This Post
Member
posted Hide Post
quote:
Originally posted by Waz:
I would suggest not using A4096V.
Change it to A4096, but also do an RTRIM (Needs v8) around it to get rid of the trailing spaces.

Also you can put in the variable into the format and length of the STRREP. This will minimise the trailing spaces.

e.g.
-SET &LARA = TRIM_(BOTH, ' ',STRREP(&FARA.LENGTH,&FARA,9,'_FOC_NULL',1 ,'-',&FARA.LENGTH,'A&FARA.LENGTH|V'));


Hello Waz,

thank you for the input. I will give it a try!

Thanks a lot Waz


WF 7.7.05M, 8.1.05M, Linux, HTML, Excel, Active Report
 
Posts: 8 | Registered: July 13, 2017Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Printing/displaying used parameters

Copyright © 1996-2020 Information Builders