Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED]Parameters not passing in drill down on IE but working on Edge and Chrome

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED]Parameters not passing in drill down on IE but working on Edge and Chrome
 Login/Join
 
Gold member
posted
  
 TYPE=DATA,
     COLUMN=N8,
     WHEN = N2 NE '&WORKTYPE',
     DRILLMENUITEM='Vector Detail',
     FOCEXEC=/WFC/Repository/OPERA/Market_Dashboard/DrillDowns/CCM_VectorReport.fex( \
     REGION=N3 \
     MARKET=N4 \
     WORKTYPE=&WORKTYPE.QUOTEDSTRING \
     LOCATION= N2 \
     BU = '&BU'\
     ),
     TARGET=_blank,

$



It builds the drillmenuitem on both IE and Chrome. However, it fails to pass the parameters to the hyperlink in IE11.

This is working fine on Chrome and Edge.

Chrome: http://***/ibi_apps/WFServlet?...&LOCATION=DEL&BU=CEN

IE: http://***/ibi_apps/WFServlet?...M_VectorReport.fex&0

This has been written on WF 8204.

This message has been edited. Last edited by: Kartik Katyal,


WebFOCUS 8010,8204
Windows
 
Posts: 59 | Registered: June 26, 2015Report This Post
Virtuoso
posted Hide Post
I also faced this problem
This is a Compatibility View Settings issue with IE11

Be sure to uncheck :
- Display intranet sites in Compatibility View
- Use Microsoft compatibility lists

The drilldown will work even with these options checked but not if you have a "DRILLMENUITEM=…"


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2410 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Report This Post
Master
posted Hide Post
Mark your calendars. The new Edge built on the Chromium Engine is set for GA release on January 15, 2020. I have downloaded and I am using the RC Beta now and loving it. It has an Internet Explorer mode that uses the compatability list as to when it is used inside Edge. That way you can get the best of both worlds, in one browser. A modern browser using modern specs that you can still use with Legacy applications that require the use of IE. More info here: https://www.microsoftedgeinsider.com/en-us/enterprise


Hallway

 
Prod: 8202M1
Test: 8202M4
Repository:
 
OS:
 
Outputs:
 
 
 
 
 
Posts: 608 | Location: Salt Lake City, UT, USA | Registered: November 18, 2015Report This Post
Virtuoso
posted Hide Post
Good One


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Gold member
posted Hide Post
quote:
Display intranet sites in Compatibility View

 
-HTMLFORM BEGIN
<meta http-equiv="X-UA-Compatible" content="IE=edge">
-HTMLFORM END
 


Added this piece to fex and it worked. Thanks MartinY for your help.


WebFOCUS 8010,8204
Windows
 
Posts: 59 | Registered: June 26, 2015Report This Post
Virtuoso
posted Hide Post
My pleasure

Please edit your first post then add [SOLVED] at the beginning of the subject


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2410 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED]Parameters not passing in drill down on IE but working on Edge and Chrome

Copyright © 1996-2020 Information Builders