Focal Point Banner

As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at and provide your corporate email address, company, and name.

Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     MODIFY command is not working on FOCUS/400.

Read-Only Read-Only Topic
MODIFY command is not working on FOCUS/400.
We are testing some file updating programs WHICH MODIFY AS/400 native data files and facing some serious problems. We are getting one error saying that "SQL Interface not installed”. We tried to test some programs which have MODIFY and ONMATCH command and found that none of them are working. We have reinstalled the FOCUS software; even then the problem is not resolved. Some programs are throwing the error "ACCESS FILE NOT FOUND ERROR”. Can someone please give some idea in this regard? Focus software which we are using is FOCUS/400 6.8.6.
Posts: 1 | Registered: December 23, 2005Report This Post
posted Hide Post
Hi Kanth,

Has this issue been resolved?

Here are some questions to be clarified. When receiving the "SQL Interface not installed" error, is there another error saying "(FOC1400) SQLCODE IS %1 (HEX: %2) %3%4"? From a quick search it looks like IBM's AS/400 has DB2 as the built-in database, is DB2 the database being connected, or is there another database connected (i.e. Oracle, SQL Server, etc.)? Are you using FOCUS 6.8.6 alone or is there an EDA/iWay Server? If yes, what release is the EDA/iWay Server?

I ran some search regarding the error messages provided and came across the following topics from Information Builders' online documents which may be of interest:

Resolving FOC1400, FOC1488 and FOC1479 Errors for the Oracle Adapter

IDMS:TABLE generates a FOC4346 0370/BRDLR

SQL Interface not installed when accessing DB2

DB2:FOC1400,FOC1367 when running any request against DB2

SQL CODE -1 when trying to connect to DB2 8.1 32 bit

You will need to have an InfoResponse userid/password to access these documents.

As always, another option for you would be to contact Information Builders' Customer Support Services or your local support office for assistance. It may be necessary to look at your configurations as well as the code. The phone number for Customer Support Services is 1-800-736-6130, or please use the online system InfoResponse to open a case. Please be ready to provide the following details when making a contact:

Hope this helps. Big Grin



Kerry Zhan
Focal Point Moderator
Information Builders, Inc.
Posts: 1948 | Location: New York | Registered: November 16, 2004Report This Post
Silver Member
posted Hide Post
On your EDA Console, look under Data Adapters, you will probably see that you do not have the DB2 interface installed. Just install it, it takes one or two clicks,and you should be all set.

Posts: 44 | Location: New York City | Registered: May 23, 2004Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     MODIFY command is not working on FOCUS/400.

Copyright © 1996-2020 Information Builders