Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Hold Files
 Login/Join
 
Member
posted
Hi all
I am very new to Webfocus, been a user for about two weeks.
My main assignment is to build reports, charts, and dashboard for a specific project.

I run into all kinds of issues. I tried to use the Help menu, User menu. did not work.

The question I have is:
Someone helped me put a Hold file out there.
But whenever I make update the Hold file, the filter function is messed up.
How do I update a hold file? I can do so in report writer easily.

Thank you!

------------------------------------------------
Thanks for everyone's help.
It turns out the original issue I had with filtering option in Hold file is our WF server update timing issue.

If I run report right after I save the changes, server is not done updating. when I run report simultaneously, filter option does not show me the expected data.
I did not know that I have to wait and wait Smiler

This message has been edited. Last edited by: FP Mod Chuck,


Production WF 8.1, Test WF 8.2
Windows
HTML 5
 
Posts: 28 | Registered: October 11, 2017Reply With QuoteReport This Post
Master
posted Hide Post
Siemens,

What do you mean by the Filter Function is messed up? Can you please provide more information? What changes did you make? what error message are you getting now? what is your current code? Are you using Developer Studio, App Studio, or Info Assist to edit your report.

Thanks!


Eric Woerle
8.1.05M Gen 913- Reporting Server Unix
8.1.05 Client Unix
Oracle 11.2.0.2
 
Posts: 750 | Location: Warrenville, IL | Registered: January 08, 2013Reply With QuoteReport This Post
Member
posted Hide Post
I used Info Assist to edit the report.

I updated the time frame from 4 years down to 3 years. Did not touch anything else.

But after I did it, I have a filter in place to help me select organization unit.
when I run the report after edit, the filter shows zzzzzzzzzzzz


Production WF 8.1, Test WF 8.2
Windows
HTML 5
 
Posts: 28 | Registered: October 11, 2017Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Hi,

What you have to know is that a HOLD file it's something that it's built on the fly (on execution) by WF and won't exist anymore once the result is displayed (except if the HOLD file has been saved physically somewhere).

When you say that your filter function is messed up, I'm a little confused.

So sharing your code and have more detailed explanation, may help us (me at least Smiler ) to understand

This message has been edited. Last edited by: MartinY,


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2282 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Virtuoso
posted Hide Post
My guess is that you have a permanent HOLD-file with the same name somewhere in your app path.

You can check that using the WHENCE statement:
WHENCE MYHOLDFILE MASTER
WHENCE MYHOLDFILE FOCUS
etc...


WebFOCUS 8.1.03, Windows 7-64/2008-64, IBM DB2/400, Oracle 11g & RDB, MS SQL-Server 2005, SAP, PostgreSQL 11, Output: HTML, PDF, Excel 2010
: Member of User Group Benelux :
 
Posts: 1654 | Location: Enschede, Netherlands | Registered: August 12, 2010Reply With QuoteReport This Post
Member
posted Hide Post
thank you both, MartinY and Wep5622!
The Hold file I use is saved physically in WF.

I don't know how to write codes. I get my results through front end drag/drop and edit.

Let me see how I can show you my screen. Still learning Frowner


Production WF 8.1, Test WF 8.2
Windows
HTML 5
 
Posts: 28 | Registered: October 11, 2017Reply With QuoteReport This Post
Member
posted Hide Post
Hi MartinY and Wep5622:
the issue with filter miraculously disappeared. I don't know how it happened.

Now I am able to use the filter and build charts. do any of you know how to display the data label in thousands with 2 decimals? It is not one of the options.

Thank you!


Production WF 8.1, Test WF 8.2
Windows
HTML 5
 
Posts: 28 | Registered: October 11, 2017Reply With QuoteReport This Post
Member
posted Hide Post
My hold file problem comes back again. I tried to read thru different documents, it seems like the problem resides with me adding new fields to Master Hold file.

So question is: can Master Hold file be modified? I don't know how to write codes. Is there a way to update Master Hold file without writing the IT professional like codes? I am so sorry about this stupid question. I am not a IT professional.

Thank you in advance!


Production WF 8.1, Test WF 8.2
Windows
HTML 5
 
Posts: 28 | Registered: October 11, 2017Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Well, the runtime hold files update on the fly, but if you got a saved hold, then either you need to recreate it with the new fields, or easier is to save the new version under a different name. I guess your best bet is to ask the person who assisted you the first time over.


Cheers,
H.

WebFOCUS 8.1.05M
Oracle 11g - DB2
RedHat
 
Posts: 114 | Location: Brighton UK | Registered: February 19, 2005Reply With QuoteReport This Post
Virtuoso
posted Hide Post
quote:

My hold file problem comes back again


Your issue is probably due to fact that your master file is physically hold on disk.

quote:

can Master Hold file be modified?


The answer is yes. Normally a hold file is parsed on each execution but because it has been hold on disk it may not be done immediately

quote:

Is there a way to update Master Hold file without writing the IT professional like codes?


Yes, but seems to be related to the way your hold file has been saved.
I suggest that you enter a call to Tech Support. It might be easier for them to help you with InfoAssist. It is difficult to provide help for a GUI tool using a forum.


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2282 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Virtuoso
posted Hide Post
quote:

do any of you know how to display the data label in thousands with 2 decimals ?


You have to go to the "Series / Data Labels / More Data Label Option Format Labels" and select "Thousands separator two decimals"


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2282 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Member
posted Hide Post
Thank you all for your help!
Let me play with it as suggested by you.

By the way, I can't reach IT Support due to stipulation of internal policy.
Forum is my only outlet getting help. I am so grateful for such a helpful community!

Have a wonderful day.


Production WF 8.1, Test WF 8.2
Windows
HTML 5
 
Posts: 28 | Registered: October 11, 2017Reply With QuoteReport This Post
Virtuoso
posted Hide Post
quote:
By the way, I can't reach IT Support due to stipulation of internal policy


I was not asking you to contact your IT support, but IBI Tech Support.
Normally it should be included (available) in your IBI support contract, so accessible to you. But I may be wrong since I don't know your contract with IBI (so many possible situations) and your internal policies.

Good Luck

Once resolved, please don't forget to update your first post header to add {SOLVED] at the beginning of the subject such as : [SOLVED] Hold Files.


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2282 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Member
posted Hide Post
Once resolved, I will mark Closed or Resolved.
I have a feeling that I might have more questions before that.

By the way, I know how to share the coding that everyone is talking about...
It might be easier for the community to help with that piece of information.


Production WF 8.1, Test WF 8.2
Windows
HTML 5
 
Posts: 28 | Registered: October 11, 2017Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Hi Meggie

First of all my recommendation for hold files is when you create the temporary file give it a unique name for each report as by default it uses file1 and as was mentioned there may be and existing file1 saved in the app folder somewhere and finding that one. However With InfoAssist these files are temporary and not saved to disk but in memory for the life of the task running.

I wanted to also expound upon what Martin suggested. In addition to the Focal Point forum there is a technical support site as well. https://techsupport.informationbuilders.com/toc.jsp

When you go there are many options including some technical videos and to our Education classes available. In addition you can use the Case Mangement to submit issues or questions to the IBI technical support group. You will need to create an account to use the case management which requires you know your IBI site code used for the software purchase. Send me a personal message if you need help getting started with this.

Hope this helps


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 1749 | Location: Customer Support | Registered: April 12, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 


Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.