Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] IE Connection Error after 60 min wait between client and server
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] IE Connection Error after 60 min wait between client and server
 Login/Join
 
Platinum Member
posted
Hi All,

I am working on WF7703, I have a report that that generates the data in excel format and than using CMD we transfers that file into a shared drives and than display an message on window that file has been generated.
If that files has low data (i.e. generated data within 60 min) it shows the notification but when we run the report for whole data then after 60 min connection between client and server breaks and browser shows Connection issue but file generates and transfers to the shared drive.

I check on server ideal_time_limit values is set to -1.

Please suggest if I am missing something to check . I will add the Keepalive time to browser to test more.

Regards,
Aman Kumar

This message has been edited. Last edited by: FP Mod Chuck,


WF Production :- WF:8.0.0.4, 8.1.05 App-studio/Developer Studio(8.1.x) ,
8.2.0.1M , 8.2.0.2 (App-Studio8.2.x),
InfoAssist/+, InfoDiscovery
Output format:-AHTML, PDF, Excel, HTML
Platform:-Windows 7, 8,10
 
Posts: 186 | Location: Infobuild India | Registered: August 28, 2015Reply With QuoteReport This Post
Virtuoso
posted Hide Post
If your report is taking so long to completed, why not using the Differed feature for execution ?
You won't have to bother with connection time out.
Could it be an option ?


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2341 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Hi Martin,

Client wants report to be shared on his shared drive directly . Even now report generates and transfer to shared drive but user does not get notification on his browser that report has been generated and browser says Connect error .They need to check manually again and again that file downloaded or not.


WF Production :- WF:8.0.0.4, 8.1.05 App-studio/Developer Studio(8.1.x) ,
8.2.0.1M , 8.2.0.2 (App-Studio8.2.x),
InfoAssist/+, InfoDiscovery
Output format:-AHTML, PDF, Excel, HTML
Platform:-Windows 7, 8,10
 
Posts: 186 | Location: Infobuild India | Registered: August 28, 2015Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Chaudhary

What is your session-timeout setting in the tomcat web.xml?


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 1915 | Location: Customer Support | Registered: April 12, 2005Reply With QuoteReport This Post
Gold member
posted Hide Post
It's either Tomcat or your browser that's dying.

To Chuck's point:
How to control the session timeout for the WebFOCUS Client

If it's IE 11:

How to change KeepAliveTimeout in IE11

There's always Report Caster out there to help with this. He could just get an email that the report ran okay.

Good luck!
Toby Mills
 
Posts: 62 | Registered: October 31, 2006Reply With QuoteReport This Post
Master
posted Hide Post
I agree with Toby. I NEVER have users run anything that take longer than 30 seconds in the browser and I try to keep the response time to under 10 seconds. If this were me, when the user does what he does, I'd start a report caster job that would deliver the report to the required folder and send an email to the user that it is done.


In FOCUS since 1985. Prod WF 8.0.08 (z90/Suse Linux) DB (Oracle 11g), Self Serv, Report Caster, WebServer Intel/Linux.
 
Posts: 956 | Location: Oklahoma City | Registered: October 27, 2006Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] IE Connection Error after 60 min wait between client and server

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.