Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] need to replace missing '.' with blank ' ' on all pages.
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] need to replace missing '.' with blank ' ' on all pages.
 Login/Join
 
Platinum Member
posted
Hi ALL,
I have a report with 12 pages i.e; pagination kind of report.i have a field name "DName" which is dispalying values '.',i want o change it to blank i,e; ' ',so all i am doing is SET NODATA =' ',bUT WHEN I RUN THE REPORT ONLY PAGE 1 IS DISPALYING CORRECTLY I.E; WITH ' ';
so please tell me how to do the same for all the pages os i get the blanks i.e; ' ' for that particular field in all the pages.

This message has been edited. Last edited by: Kerry,


7.6.7
windows
PDF,EXCEL.
 
Posts: 160 | Location: Atlanta,GA | Registered: July 16, 2009Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Number of pages has nothing to do with the NODATA character so there must be something else going on. Once the SET NODATA=' ' is set, it's valid for the entire report.

The concept of "pages" in HTML isn't really there. Are you using On-Demand paging and seeing this?


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Hi darin,
i used SET NODATA=' ',But some how its displaying correctly in the first page which gets after i run the report,once i navigate from the report output to page 2 or any other page i am getting the missing parameter '. ',which i want o get rid off.

i am using a report with pagination kind i.e; i have links for 1-12 pages in the report output.

i am surprised to see why the "Set Nodata" is being passed to the page which come after i run only,why not to other pages.?


7.6.7
windows
PDF,EXCEL.
 
Posts: 160 | Location: Atlanta,GA | Registered: July 16, 2009Reply With QuoteReport This Post
Virtuoso
posted Hide Post
When you say you have links to the pages, what are the links doing? Re-running the report and getting page two? Links to static pages? Still not quite sure what you are doing.


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
Master
posted Hide Post
Try ON TABLE SET NODATA '' instead of SET NODATA=''
I think, only for the first page, fex with SET NODATA command was included. For the consecutive calls that fex might be bypassed.

So try this way,
TABLE FILE CAR
SUM SALES BY COUNTRY ACROSS SEATS
ON TABLE SET NODATA ''
END
 
Posts: 542 | Location: Dearborn, MI | Registered: June 03, 2009Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] need to replace missing '.' with blank ' ' on all pages.

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.