Focal Point
[CLOSED] Legend Display

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/8197011916

April 17, 2012, 11:28 AM
Neenz
[CLOSED] Legend Display
I am having a VLINE graph and trying to change some of the lines to bars.
setSeriesType(getSeries(0),1);
setSeriesType(getSeries(1),1);
setSeriesType(getSeries(2),1);
setSeriesType(getSeries(3),1);
setSeriesType(getSeries(4),1);
setSeriesType(getSeries(5),2);
setSeriesType(getSeries(6),2);
setSeriesType(getSeries(7),2);

My legend is only showing the display as lines, am not able to display both lines and bar in the legend.

This message has been edited. Last edited by: Kerry,


WF: 7.6.8
OS/Platform: Windows, Unix
April 17, 2012, 12:42 PM
Tom Flynn
Don't know if this is what you are looking for:
  
GRAPH FILE CAR
-* Created by Advanced Graph Assistant
SUM CAR.BODY.DEALER_COST
CAR.BODY.RETAIL_COST
BY CAR.ORIGIN.COUNTRY
ON GRAPH PCHOLD FORMAT PNG
ON GRAPH SET GRAPHDEFAULT OFF
ON GRAPH SET VZERO ON
ON GRAPH SET HTMLENCODE ON
ON GRAPH SET HAXIS 770
ON GRAPH SET VAXIS 405
ON GRAPH SET UNITS PIXELS
ON GRAPH SET LOOKGRAPH VBAR2AX
ON GRAPH SET BARNUMB OFF
ON GRAPH SET 3D OFF
ON GRAPH SET GRID ON
ON GRAPH SET GRMERGE ADVANCED
ON GRAPH SET GRMULTIGRAPH 0
ON GRAPH SET GRLEGEND 0
ON GRAPH SET GRXAXIS 1
ON GRAPH SET GRAPHSTYLE *
setTemplateFile("/images/tdg/template/IBISouthWestern.txt");
setReportParsingErrors(false);
setSelectionEnableMove(false);
setDepthRadius(5);
setTransparentBorderColor(getSeries(0),true);
setTransparentBorderColor(getSeries(1),true);
setTransparentBorderColor(getSeries(2),true);
setTransparentBorderColor(getSeries(3),true);
setTransparentBorderColor(getSeries(4),true);
setTransparentBorderColor(getSeries(5),true);
setTransparentBorderColor(getSeries(6),true);
setTransparentBorderColor(getSeries(7),true);
setTransparentBorderColor(getSeries(8),true);
setTransparentBorderColor(getSeries(9),true);
setTransparentBorderColor(getSeries(10),true);
setMarkerDisplay(true);
setConnectLineMarkers(true);
setConnectScatterMarkers(true);
setO1LabelDisplay(true);
setO1AxisSide(0);
setO1MajorGridDisplay(true);
setO1MajorGridStyle(0);
setO1MinorGridDisplay(false);
setAxisAssignment(0,0);
setSeriesType(0,1);
setAxisAssignment(1,1);
setSeriesType(1,2);
setY1LabelDisplay(true);
setY1AxisSide(0);
setY1MajorGridDisplay(true);
setY1MajorGridStyle(0);
setY1MinorGridDisplay(false);
setTextFormatPreset(getY1Label(),-1);
setTextFormatPattern(getY1Label(),"#.##");
setY2LabelDisplay(true);
setY2AxisSide(1);
setY2MajorGridDisplay(true);
setY2MajorGridStyle(0);
setY2MinorGridDisplay(false);
setTextFormatPreset(getY2Label(),-1);
setTextFormatPattern(getY2Label(),"#.##");
setPieFeelerTextDisplay(1);
setPieLabelDisplay(0);
setTextFormatPreset(getPieSliceLabel(),1);
setRiserBorderMode(1);
setSeriesDefaultTransparentBorderColor(true);
setUseSeriesBorderDefaults(true);
setLegendDisplay(true);
setFontSizeAbsolute(getY1Title(),true);
setFontSizeAbsolute(getY1Label(),true);
setFontSizeAbsolute(getY2Title(),true);
setFontSizeAbsolute(getY2Label(),true);
setFontSizeAbsolute(getO1Title(),true);
setPlace(true);
setLabelStagger(getO1Label(),true);
setTextString(getO1Title()," ");
setDisplay(getO1Title(),true);
setFillColor(getSeries(1),new Color(255,0,0));
setFillColor(getChartBackground(),new Color(255,255,255));
setFillColor(getSeries(0),new Color(0,0,255));
setFillType(getChartBackground(), 2);
setFillColor(getLegendArea(),new Color(64,128,128));
setFillColor(getLegendText(),new Color(255,255,255));
setTransparentBorderColor(getChartBackground(),true);
setFillColor(getFrame(),new Color(255,255,255));
setBorderColor(getFrame(),new Color(32,0,32));
ENDSTYLE
END




Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
April 17, 2012, 12:48 PM
Neenz
quote:
setLegendDisplay(true);


Which part of the code handles the legend display.


WF: 7.6.8
OS/Platform: Windows, Unix
April 17, 2012, 12:50 PM
Tom Flynn
Post your code, between the code tags, upper-right </> Don't want to guess what you are looking for...


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
April 17, 2012, 12:59 PM
Neenz
 ON GRAPH SET HTMLENCODE ON
ON GRAPH SET GRAPHDEFAULT OFF
ON GRAPH SET VZERO OFF

-SET &HAXIS = IF &OUTPUT EQ 'HTML' THEN 990 ELSE 1000;
-SET &VAXIS = IF &OUTPUT EQ 'HTML' THEN 280 ELSE 500;

ON GRAPH SET HAXIS &HAXIS
ON GRAPH SET VAXIS &VAXIS
ON GRAPH SET UNITS PIXELS
ON GRAPH SET LOOKGRAPH VLINE
ON GRAPH SET PAGE NOPAGE
ON GRAPH SET HTMLCSS ON
ON GRAPH SET BARNUMB ON
ON GRAPH SET 3D OFF
ON GRAPH SET GRID ON
ON GRAPH SET GRMERGE ADVANCED
ON GRAPH SET GRMULTIGRAPH 0
ON GRAPH SET GRLEGEND 0
ON GRAPH SET GRXAXIS 2
ON GRAPH SET GRAPHSTYLE *
setTemplateFile("/images/tdg/template/IBISouthWestern.txt");
setLegendPosition(5);
setLegendReverse(true);

setReportParsingErrors(false);
setSelectionEnableMove(false);
setTransparentBorderColor(getSeries(0),true);
setTransparentBorderColor(getSeries(1),true);
setTransparentBorderColor(getSeries(2),true);
setTransparentBorderColor(getSeries(3),true);
setTransparentBorderColor(getSeries(4),true);
setTransparentBorderColor(getSeries(5),true);
setTransparentBorderColor(getSeries(6),true);
setTransparentBorderColor(getSeries(7),true);
setTransparentBorderColor(getSeries(8),true);
setTransparentBorderColor(getSeries(9),true);
setTransparentBorderColor(getSeries(10),true);
setPlace(true);
setSeriesType(getSeries(0),1);
setSeriesType(getSeries(1),1);
setSeriesType(getSeries(2),1);
setSeriesType(getSeries(3),1);
setSeriesType(getSeries(4),1);
setSeriesType(getSeries(5),2);
setSeriesType(getSeries(6),2);
setSeriesType(getSeries(7),2);

setFillColor(getSeries(0),new Color(173,216,230));
setFillColor(getSeries(1),new Color(200,200,200));
setFillColor(getSeries(2),new Color(128,128,128));
setFillColor(getSeries(3),new Color(128 200 128));
setFillColor(getSeries(4),new Color(0 128 0));
setFillColor(getSeries(5),new Color(0,0,0));
setFillColor(getSeries(6),new Color(255,0,0));
setFillColor(getSeries(7),new Color(0,0,100));

setTextRotation(getO1Label(),3);
setColorMode(1);
setFillColor(getDataText(),new Color(0,0,0));

setDisplay(getTitle(),true);
setFontSizeAbsolute(getTitle(),true);
setFontSizeInPoints(getTitle(),10);
setPlaceResize(getTitle(),0);
setDisplay(getSubtitle(),true);
setFontSizeAbsolute(getDataText(0),true);
setFontSizeInPoints(getDataText(0),12);
setFontSizeAbsolute(getDataText(0),12);
setCustomDataText(getDataText(0),true);
setFontStyle(getDataText(),0);
setZeroValueDataTextDisplay(false);
setDisplay(getO1Label(),true);
setFontSizeAbsolute(getO1Label(),true);
setFontSizeInPoints(getO1Label(),7);
setPlaceResize(getO1Label(),0);
setFontSizeAbsolute(getDataText(),true);
setFontSizeInPoints(getDataText(),10);
setPlaceResize(getDataText(),0);
setDisplay(getO1AxisLine(),true);
setPlaceResize(getY1Title(),0);
setPlaceAlign(getY1Title(),1);
setFontSizeAbsolute(getY1Label(),true);
setFontSizeInPoints(getY1Label(),7);
setPlaceResize(getY1Label(),0);
setTextFormatPattern(getY1Label(),"#,###");
setTextFormatPattern(getDataText(),"#,###");
setTextFormatPreset(getDataText(),1);
setExcludeMaxLabel(getO1Label(),false);
setExcludeMinLabel(getO1Label(),false);
setDisplay(getY1Title(),true);
setTextFormatPreset(getY1Label(),15);
setExcludeMaxLabel(getY1Label(),false);
setScaleMaxAuto(getY1Axis(),true);
setDisplay(getO1MajorGrid(),false);
setTextFormatPreset(getY1Label(),16);
setTextFormatPreset(getY1Label(),1);
setTransparentBorderColor(getChartBackground(),true);
setTextString(getTitle(),"Engineering Capacity Graph");
setTextString(getSubtitle(),"  ");
setTextString(getY1Title(),"Engineering hours");
setTextString(getO1Title(),"Fiscal year/period");
setDepthRadius(0);
setDepthAngle(0);
setShadowXOffset(getFrame(),5);
setDisplay(getDataText(),false);
setDisplay(getSubtitle(),true);
setSquareMarkers(false);
-*setUseSeriesShapes(false);
setDisplay(getO1Title(),true);
setDisplay(getReferenceLineY1(1),false);
setDisplay(getAnnotation(0),true);
setTextString(getAnnotation(0),"");
setMarkerDisplay(false);
ENDSTYLE 



This gives me the graph I need, but my legend is showing All lines insted of line and bar.


WF: 7.6.8
OS/Platform: Windows, Unix
April 17, 2012, 01:24 PM
Tom Flynn
Neenz,

Use CAR, GGSALES, or, another file from IBISAMP. You put 1/2 your code here. This puts a square in the Legend, and, a line for the 2nd Y axis.

 
APP PREPENDPATH IBISAMP
-RUN
-*INTERNAL_PROPERTIES$fieldDisplayMode=label;OBJECTID=GLOBAL
-*INTERNAL_PROPERTIES$enablePreview=true;OBJECTID=GLOBAL
-*INTERNAL_PROPERTIES$prefixDisplayMode=;OBJECTID=GLOBAL
-*INTERNAL_PROPERTIES$GlobalRecordLimit=500;OBJECTID=GLOBAL
-*INTERNAL_PROPERTIES$SampleData=false;OBJECTID=GLOBAL
GRAPH FILE CAR
-* Created by Advanced Graph Assistant
SUM CAR.BODY.DEALER_COST
CAR.BODY.RETAIL_COST
BY CAR.ORIGIN.COUNTRY
ON GRAPH PCHOLD FORMAT PNG
ON GRAPH SET GRAPHDEFAULT OFF
ON GRAPH SET VZERO ON
ON GRAPH SET HTMLENCODE ON
ON GRAPH SET HAXIS 770
ON GRAPH SET VAXIS 405
ON GRAPH SET UNITS PIXELS
ON GRAPH SET LOOKGRAPH VBAR2AX
ON GRAPH SET BARNUMB OFF
ON GRAPH SET 3D OFF
ON GRAPH SET GRID OFF
ON GRAPH SET GRMERGE ADVANCED
ON GRAPH SET GRMULTIGRAPH 0
ON GRAPH SET GRLEGEND 0
ON GRAPH SET GRXAXIS 1
ON GRAPH SET GRAPHSTYLE *
setTemplateFile("/images/tdg/template/IBISouthWestern.txt");
setReportParsingErrors(false);
setSelectionEnableMove(false);
setDepthRadius(5);
setTransparentBorderColor(getSeries(0),true);
setTransparentBorderColor(getSeries(1),true);
setTransparentBorderColor(getSeries(2),true);
setTransparentBorderColor(getSeries(3),true);
setTransparentBorderColor(getSeries(4),true);
setTransparentBorderColor(getSeries(5),true);
setTransparentBorderColor(getSeries(6),true);
setTransparentBorderColor(getSeries(7),true);
setTransparentBorderColor(getSeries(8),true);
setTransparentBorderColor(getSeries(9),true);
setTransparentBorderColor(getSeries(10),true);
setMarkerDisplay(true);
setConnectLineMarkers(true);
setConnectScatterMarkers(true);
setO1LabelDisplay(true);
setO1AxisSide(0);
setO1MajorGridDisplay(false);
setO1MajorGridStyle(0);
setO1MinorGridDisplay(false);
setAxisAssignment(0,0);
setSeriesType(0,1);
setAxisAssignment(1,1);
setSeriesType(1,2);
setY1LabelDisplay(true);
setY1AxisSide(0);
setY1MajorGridDisplay(false);
setY1MajorGridStyle(0);
setY1MinorGridDisplay(false);
setTextFormatPreset(getY1Label(),-1);
setY2LabelDisplay(true);
setY2AxisSide(1);
setY2MajorGridDisplay(false);
setY2MajorGridStyle(0);
setY2MinorGridDisplay(false);
setTextFormatPreset(getY2Label(),-1);
setPieFeelerTextDisplay(1);
setPieLabelDisplay(0);
setTextFormatPreset(getPieSliceLabel(),1);
setRiserBorderMode(1);
setSeriesDefaultTransparentBorderColor(true);
setUseSeriesBorderDefaults(true);
setLegendDisplay(true);
setFontSizeAbsolute(getY1Title(),true);
setFontSizeAbsolute(getY1Label(),true);
setFontSizeAbsolute(getY2Title(),true);
setFontSizeAbsolute(getY2Label(),true);
setFontSizeAbsolute(getO1Title(),true);
setPlace(true);
setLabelStagger(getO1Label(),true);
setTextString(getO1Title()," ");
setDisplay(getO1Title(),true);
setFillColor(getSeries(1),new Color(255,0,0));
setFillColor(getChartBackground(),new Color(255,255,255));
setFillColor(getSeries(0),new Color(0,0,255));
setFillType(getChartBackground(),2);
setFillColor(getLegendArea(),new Color(64,128,128));
setFillColor(getLegendText(),new Color(255,255,255));
setTransparentBorderColor(getChartBackground(),true);
setFillColor(getFrame(),new Color(255,255,255));
setBorderColor(getFrame(),new Color(32,0,32));
setMarkerShape(getLegendLabelMarker(0),17);
setDisplay(getBeveledLegendMarker(),true);
setSquareMarkers(false);
setLineStyleLegendMarkers(1);
setFillColor(getY2Label(),new Color(255,255,255));
setFontStyle(getY2Label(),2);
setTextFormatPattern(getY2Label(),"#,###.##");
setTextFormatPattern(getY1Label(),"#,###.##");
setFontStyle(getY1Label(),2);
setFontStyle(getO1Label(),2);
setScaleMaxAuto(getY1Axis(),false);
setScaleMax(getY1Axis(),70000.0);
ENDSTYLE
END

This message has been edited. Last edited by: Tom Flynn,


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe