Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Populate Active Chart using !IBI.FIL.

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CLOSED] Populate Active Chart using !IBI.FIL.
 Login/Join
 
Platinum Member
posted
Hi All,

Using !IBI.FIL. I am able to populate a chart into the HTML page created in the FEX. Below is a working version of the code. Also, found several in this forum.

I am trying to generate a AHTML chart on populate it using the !IBI.FIL. but it doesn't work. When searched in this forum and in the documentation I found that for AHTML TABULAR report we have to use '!IBI.OBJ.ACTIVEREPORTJS;' along with the !IBI.FIL. I tried by adding that as well but didn't work.

If anyone has a solution greatly appreciate your help.

GRAPH FILE car
SUM CAR.BODY.SALES
BY CAR.COMP.CAR
ON GRAPH HOLD AS TSTGRP FORMAT JSCHART
ON GRAPH SET VZERO OFF
ON GRAPH SET LOOKGRAPH PIE
ON GRAPH SET AUTOFIT ON
ON GRAPH SET STYLE *
*GRAPH_SCRIPT
setPieDepth(0);
setPieTilt(0);
setDepthRadius(0);
setCurveFitEquationDisplay(false);
setPlace(true);
setPieFeelerTextDisplay(1);
*END
INCLUDE=IBFS:/FILE/IBI_HTML_DIR/ibi_themes/Warm.sty,$
TYPE=REPORT, TITLETEXT='chart', ARGRAPHENGINE=JSCHART, $
TYPE=DATA, COLUMN=N1, BUCKET=color, $
TYPE=DATA, COLUMN=N2, BUCKET=measure, $
*GRAPH_SCRIPT
setReportParsingErrors(false);
setSelectionEnableMove(false);
*GRAPH_JS_FINAL
"pieProperties": {
"holeSize": "0%"
},
"agnosticSettings": {
"chartTypeFullName": "Pie"
}
*END
ENDSTYLE
END
-RUN

 -HTMLFORM BEGIN
<html>
<body>
<div>!IBI.FIL.TSTGRP;</div>
</body>
</html>
-HTMLFORM END
 

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS - ver8201
[ReportingServers: Windows 64bit;
Client: tomcat and IIS on windows 2012
AppStudio

 
Posts: 104 | Location: Indianapolis | Registered: November 08, 2007Report This Post
Platinum Member
posted Hide Post
quote:
ON GRAPH HOLD AS TSTGRP FORMAT JSCHART
Please change hold format JSCHART to AHTML . It works.
 

GRAPH FILE CAR
SUM CAR.BODY.SALES
BY CAR.COMP.CAR
ON GRAPH HOLD AS TSTGRP FORMAT AHTML
-*ON GRAPH HOLD AS TSTGRP FORMAT JSCHART
ON GRAPH SET VZERO OFF
ON GRAPH SET LOOKGRAPH PIE
ON GRAPH SET AUTOFIT ON
ON GRAPH SET STYLE *
*GRAPH_SCRIPT
setPieDepth(0);
setPieTilt(0);
setDepthRadius(0);
setCurveFitEquationDisplay(false);
setPlace(true);
setPieFeelerTextDisplay(1);
*END
INCLUDE=IBFS:/FILE/IBI_HTML_DIR/javaassist/intl/EN/combine_templates/ENWarm.sty,$
TYPE=REPORT, TITLETEXT='chart', ARGRAPHENGINE=JSCHART, $
TYPE=DATA, COLUMN=N1, BUCKET=color, $
TYPE=DATA, COLUMN=N2, BUCKET=measure, $
*GRAPH_SCRIPT
setReportParsingErrors(false);
setSelectionEnableMove(false);
*GRAPH_JS_FINAL
"pieProperties": {
"holeSize": "0%"
},
"agnosticSettings": {
"chartTypeFullName": "Pie"
}
*END
ENDSTYLE
END
-RUN

-HTMLFORM BEGIN
<html>
<body>
<div>!IBI.FIL.TSTGRP;</div>
</body>
</html>
-HTMLFORM END

 


WF Production :- WF:8.0.0.4, 8.1.05 App-studio/Developer Studio(8.1.x) ,
8.2.0.1M , 8.2.0.2 (App-Studio8.2.x),
InfoAssist/+, InfoDiscovery
Output format:-AHTML, PDF, Excel, HTML
Platform:-Windows 7, 8,10
 
Posts: 186 | Location: Infobuild India | Registered: August 28, 2015Report This Post
Platinum Member
posted Hide Post
Hi Chaudhary,

No it didn't work. That is just giving a blank page.


WebFOCUS - ver8201
[ReportingServers: Windows 64bit;
Client: tomcat and IIS on windows 2012
AppStudio

 
Posts: 104 | Location: Indianapolis | Registered: November 08, 2007Report This Post
Platinum Member
posted Hide Post
Hi Rao,

I tried this solution in below mentioned WF environments and it works for me ,

WF 8105
Client 8105 gen 119
Server 81M 858

WF 8201

Client 8201 gen 138
Server 82 gen 1067


WF Production :- WF:8.0.0.4, 8.1.05 App-studio/Developer Studio(8.1.x) ,
8.2.0.1M , 8.2.0.2 (App-Studio8.2.x),
InfoAssist/+, InfoDiscovery
Output format:-AHTML, PDF, Excel, HTML
Platform:-Windows 7, 8,10
 
Posts: 186 | Location: Infobuild India | Registered: August 28, 2015Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Populate Active Chart using !IBI.FIL.

Copyright © 1996-2020 Information Builders