Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSE] Unrecoverable Error in InfoAssist
Go
New
Search
Notify
Tools
Reply
  
[CLOSE] Unrecoverable Error in InfoAssist
 Login/Join
 
Member
posted
I have only created a handful of reports using InfoAssist. Whenever I need to make a change to the report, I get "Unrecoverable Error." Sometimes I can copy the report code to a new report. But, most of the time I have to completely recreate the report. There is at least one other person in our company that this happens to and his reports are more robust than mine.

Please advise.

This message has been edited. Last edited by: Tamra,


WebFOCUS 8
Windows, All Outputs
 
Posts: 3 | Registered: May 11, 2016Reply With QuoteReport This Post
Master
posted Hide Post
If you modify the report by text, there are some things that will disable the option to use InfoAssist. If they are graphs, you can still open them in Dev/App Studio and it interfaces with Info Assist. However, if they are reports, you can open them in Dev/App Studio, but not with the same UI as Info Assist.



- FOCUS Man, just FOCUS!
-----------------------------
Product: WebFOCUS
Version: 8.1.04
Server: Windows 2008 Server
 
Posts: 578 | Registered: October 01, 2014Reply With QuoteReport This Post
Guru
posted Hide Post
Hi Laura,

Welcome to Focal Point!

WebFOCUS now has a few versions of WebFOCUS 8 - can you please update your profile to indicate the version of WebFOCUS 8 ie. WebFOCUS 8009 or 8105.

Generally, it does not make a difference but there are additional features in the higher release of WebFOCUS 8105.

As to your error message "Unrecoverable Error."

Do you receive this message when you re-open a saved InfoAssist report? Are you seeing a message such as - Unrecoverable Error with code: 10005 Type: xFDMinit ? You should see a "OK" button - click this to get a bit more info on the error and post this text.

As GavinL points out you should not edit the code in a InfoAssist report or even copy the code. You can copy the report ( hopefully it is one that works!)

Thank you for participating in the Focal Point Forum.

Kind Regards,
Tamra Colangelo
IBI Focal Point Moderator


WebFOCUS 8x - BI Portal, Developer Studio, App Studio, Excel, PDF, Active Formats and HTML5
 
Posts: 487 | Location: Toronto | Registered: June 23, 2009Reply With QuoteReport This Post
Member
posted Hide Post
I appreciate the replies.

We are using InfoAssist product 8.1 with service pack .5.

The error says, "An unrecoverable error has occurred. We are sorry for the inconvenience." When I click for more information I get, "Code: 1024 Type xFDMinit. Unknown Error Message."

Thank you for your guidance.

Laura Richards
Brotherhood Mutual


WebFOCUS 8
Windows, All Outputs
 
Posts: 3 | Registered: May 11, 2016Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Is this a repeatable error or completely random? It might be a configuration issue you have to deal with. Have you opened a case with IBI Tech support? They'll have someone capture traces and let you know how to fix it.


WebFOCUS 8206, Unix, Windows
 
Posts: 1658 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Member
posted Hide Post
It's a repeatable error. In the case of the reports, we're thinking that it is due to the use of a slash in the parameter description. Technically this doesn't make sense as it is just a description, but when we took the slash out of the parameter description, the report has been stable.

We have a dashboard with similar problems that IBI is working on.

Thank you!


WebFOCUS 8
Windows, All Outputs
 
Posts: 3 | Registered: May 11, 2016Reply With QuoteReport This Post
Guru
posted Hide Post
Laura,

If you continue to have this "Unrecoverable Error" message a case should be opened. The InfoAssist Product Group is working on trying to ensure we have meaningful error messages to help with debugging. If these messages do crop up then they like hear about them and try to provide a resolution.

I hope that the one member's opinion has not given you a negative impression of all the users of this forum, who are overwhelmingly friendly and helpful. I encourage you to continue to use the forum as we all try our hardest to come up with the best assistance possible.


Thank you for participating in the Focal Point Forum

Kind Regards,
Tamra Colangelo
IBI Focal Point Moderator


WebFOCUS 8x - BI Portal, Developer Studio, App Studio, Excel, PDF, Active Formats and HTML5
 
Posts: 487 | Location: Toronto | Registered: June 23, 2009Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Thanks for the clarification.
 
Posts: 117 | Location: Denver | Registered: July 27, 2005Reply With QuoteReport This Post
Member
posted Hide Post
Hello,

Tamara was your issue ever resolved? I am having the same issue. I have opened a ticket, but am looking to see if I can resolve in the mean time.

We are also not able to use any report built entirely in InfoAssist as an existing report into any Dashboard, or any other application. Nor are we able to use any AppStudio report. I was told by IBI that this was because they were two different applications. However, I cannot see that this would be the case. Surely AppStudio reports can be used in Dashboards. Else, what is the purpose of AppStudio? Of course if I cannot use or edit InfoAssist reports, then there is absolutely no point in using either really.

Was just wondering if your issue was resolved, as it might help us.

Thank you!


WebFOCUS 8
Windows, All Outputs
 
Posts: 1 | Registered: August 22, 2016Reply With QuoteReport This Post
Guru
posted Hide Post
TBSeward,

Welcome to Focal Point!

Are you having the same issues as discussed in the previous topics by the members? "Unrecoverable Error" ?

I reviewed one of your cases (170310056) and it is related to reports being added to a Dashboard. That case was closed due to inactivity in the end. Did you ever get your InfoAssist reports to work with your Dashboard?

My question is are you creating a new Dashboard and creating InfoAssist reports to add to the Dashboard or did you have an older version of WebFOCUS ( v77 ) and this was a migrated Dashboard over to WebFOCUS 8105?

Migrated Dashboards from WebFOCUS 7x will be supported from a maintenance point of view but new Dashboards (BID) will no longer be supported as of WebFOCUS 8201. BI Portal is what should be developed going forward so that the modern technologies can be utilized.

InfoAssist created reports and AppStudio created reports are not always compatible. AppStudio (AS) is more for developers since other components can be used such as dialogue manager statements. AS is broken down into components where as InfoAssist (IA)is not.

Here are a few links related to Dashboards. There are 2 types. Older technology Dashboards ( first link) and Active Dashboards (second link) that support "offline" reporting and analysis.

Introducing Dashboard

Creating Active Technologies Components With InfoAssist
This topic describes how to create a report, chart, or dashboard that is enabled for Active Technologies using InfoAssist.

Active Technologies Report Overview

For the "unrecoverable error" - most have been cleaned up and reworded to help with debugging as of WebFOCUS 8201.

Hopefully, the above has helped. Please let us know if you have further questions.

Thank you for participating in the Focal Point Forum!
Tamra Colangelo
Focal Point Moderator
Information Builders


WebFOCUS 8x - BI Portal, Developer Studio, App Studio, Excel, PDF, Active Formats and HTML5
 
Posts: 487 | Location: Toronto | Registered: June 23, 2009Reply With QuoteReport This Post
Gold member
posted Hide Post
Hey Everyone, I know this says it is CLOSED, but when we first rolled out WebFOCUS, we did a lot of documentation at the metadata layer to enhance the hover over capabilities for our end users to make sure they knew exactly what fields they were using.
We found out the hard way that if we had any slashes for date samples eg: 10/12/2017 then in InfoAssist, we would get that unrecoverable error message if that specific field was used as a parameter, but it would work okay in App Studio. We had to go back into our metadata layer and remove ALL special characters from the description field that might throw a syntax error in the underlying code. Other special characters that we removed were; * / ; @ When those were removed, that seemed to solve our issue globally on InfoAssist.
Hope that helps some!
-Larissa


Version: 8.2.03M, OS/Platform: Windows 7 & 10, Output: Excel, pdf, html
 
Posts: 63 | Location: Liberty Lake, WA - USA | Registered: June 23, 2016Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSE] Unrecoverable Error in InfoAssist

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.