Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     COMPUTEd field not totaling
Go
New
Search
Notify
Tools
Reply
  
COMPUTEd field not totaling
 Login/Join
 
Silver Member
posted
A frustrating problem: I have a complex report in which I use DECODE to look up a value that needs to appear on the report and that needs to be summed at the subtotal levels. However, I can not get it to sum, instead it treats it like an ALPHA format, and shows the last value found. This is the offending line:

COMPUTE PDAY/D12CN = DECODE DIVISION_NAME(LKP ELSE 0); AS 'Actual, from,Prev. Day'

I tried multiplying it by a factor, which works in that the new value is shown, but it still will not total. (it did prove that it is not being treated as an alpha field though) Any suggestions?
 
Posts: 44 | Location: New York City | Registered: May 23, 2004Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Steve,

Are you trying to sum in the same table request as you are doing the compute. You didn't post your whole fex so I'm wondering. If you are then the compute only shows the last record processed in the sort (internal matrix issues). I get bit with this a lot in calculating gpa's for student data. You might try the decode in a define and see what happens.

Leah C.
 
Posts: 1317 | Location: Council Bluffs, IA | Registered: May 24, 2004Reply With QuoteReport This Post
Silver Member
posted Hide Post
Thanks. I did move it to a DEFINE and now it works as it should.
 
Posts: 44 | Location: New York City | Registered: May 23, 2004Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     COMPUTEd field not totaling

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.