Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     COMPUTEd field not totaling

Read-Only Read-Only Topic
Go
Search
Notify
Tools
COMPUTEd field not totaling
 Login/Join
 
Silver Member
posted
A frustrating problem: I have a complex report in which I use DECODE to look up a value that needs to appear on the report and that needs to be summed at the subtotal levels. However, I can not get it to sum, instead it treats it like an ALPHA format, and shows the last value found. This is the offending line:

COMPUTE PDAY/D12CN = DECODE DIVISION_NAME(LKP ELSE 0); AS 'Actual, from,Prev. Day'

I tried multiplying it by a factor, which works in that the new value is shown, but it still will not total. (it did prove that it is not being treated as an alpha field though) Any suggestions?
 
Posts: 44 | Location: New York City | Registered: May 23, 2004Report This Post
Virtuoso
posted Hide Post
Steve,

Are you trying to sum in the same table request as you are doing the compute. You didn't post your whole fex so I'm wondering. If you are then the compute only shows the last record processed in the sort (internal matrix issues). I get bit with this a lot in calculating gpa's for student data. You might try the decode in a define and see what happens.

Leah C.
 
Posts: 1317 | Location: Council Bluffs, IA | Registered: May 24, 2004Report This Post
Silver Member
posted Hide Post
Thanks. I did move it to a DEFINE and now it works as it should.
 
Posts: 44 | Location: New York City | Registered: May 23, 2004Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     COMPUTEd field not totaling

Copyright © 1996-2020 Information Builders