Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Report Caster -- "SET DISTRIBUTE=OFF" magically appearing

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SOLVED] Report Caster -- "SET DISTRIBUTE=OFF" magically appearing
 Login/Join
 
Virtuoso
posted
I have a report that runs perfectly on-demand. It's HTML. But when I deliver it via Report Caster I get

SET DISTRIBUTE=OFF

. . . inserted into the output. That text just appears at the top of the page. It's a very small report, so the line is pretty glaring.

I have searched my entire system for this phrase, and it doesn't appear to exist anywhere.

Anybody have an idea on how to banish this ghost?

This message has been edited. Last edited by: FP Mod Chuck,



 
Posts: 1012 | Location: At the Mast | Registered: May 17, 2007Report This Post
Virtuoso
posted Hide Post
John

is -SET &ECHO=ALL; in the fex by chance. I saw one case on techsupport where that was the case. But with html that would usually show up if you did a view source of the output not in the actual report.

Also when you create a schedule on the properties page there is a drop down for handling No report to distrubute and the default is on error I saw another case where if that was changed to warning that message went away.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Virtuoso
posted Hide Post
I don't have a -SET &ECHO=ALL and I explicitly set it to OFF and it didn't make a difference.

I set the default for no report to distribute to Warning and it didn't fix it either.

Now, it's an interesting report. I run four separate reports and then combine them in an HTMLFORM block at the bottom of the focexec. Gets my appearance just right. So maybe that is setting something off?



 
Posts: 1012 | Location: At the Mast | Registered: May 17, 2007Report This Post
Virtuoso
posted Hide Post
I got it! I was missing an HTMLFORM END at the end of the focexec. I had --
 
-HTMLFORM BEGIN
<html>
<body>
<table>
<tr><td>!IBI.FIL.DRIVER_TEST_APPOINTMENTS ;</td><td>!IBI.FIL.CDL_TEST ;</td></tr>
<tr><td height='50px'> </td></tr>
<tr><td>!IBI.FIL.OTHER_APPOINTMENTS ;</td><td>!IBI.FIL.VEHICLE_APPOINTMENTS ;</td></tr>
</body>
</html>

. . . and apparently that set off the alert, in spite of it sending the report. I put -HTMLFORM END at the bottom and the message went away.



 
Posts: 1012 | Location: At the Mast | Registered: May 17, 2007Report This Post
Virtuoso
posted Hide Post
Now, I'm going to make this mistake again in the future at some point, and I'm going to find this after I search. I'm going to find my own solution. I can't tell you the number of times I've searched for a problem in these forums, found exactly what I was looking for, only to discover that it was me that started the original thread back in 2006.



 
Posts: 1012 | Location: At the Mast | Registered: May 17, 2007Report This Post
Virtuoso
posted Hide Post
Smiler


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 2128 | Location: Customer Support | Registered: April 12, 2005Report This Post
Member
posted Hide Post
SET DISTRIBUTE=OFF
It is Reportcaster functionality. if it didn't find the output from the task it will set distribution off . and give error or warning. based on the schedule settings.
It may happen sometimes if it didn't recognize the output format or no report to distribute.
One of the user created report with multiple hold file and created final excel report.it was running on-demand but it failed in reportcaster with no report to distribute.
setting the overide the output format to .xls
in the tasks fixed the issue.


WebFOCUS 8.2.04
AIX/UNIX/Windows, All Outputs
 
Posts: 20 | Registered: November 17, 2015Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Report Caster -- "SET DISTRIBUTE=OFF" magically appearing

Copyright © 1996-2020 Information Builders