Focal Point
[CLOSED] Empty cells in Across

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/8747007495

December 03, 2010, 02:06 AM
ChristianP
[CLOSED] Empty cells in Across
I try to build an html report with webfocus. I build it by using the across
method in the empty cells appears a “.” (dot)
How can I format the empty cells. I also use a drilldown in the
Report by using the DRILLMENUITEM method. I want to have nothing in the empty cells
because the drilldown also works on the “.” And that makes not really sense.
thanks a lot

This message has been edited. Last edited by: Kerry,


WF Production Version: 7.7.02M
WF Test Version: 7.7.02M
Developer Studio: 7.7.02
HTML, EXL2K, FLEX, PDF,PPT
December 03, 2010, 03:13 AM
GamP
Controlling the '.' is done with the NODATA setting (SET NODATA='n/a' for instance will display n/a in stead of a dot).
And for across you need to use either the SUM verb, or use the new setting for compressing the across output, SET ACROSSPRT = COMPRESSED, although I don't know exactly when this setting was introduced. So it could be that it is not yet available in the release you're working with ...


GamP

- Using AS 8.2.01 on Windows 10 - IE11.
in Focus since 1988
December 03, 2010, 03:24 AM
GamP
For the drilldown it will make no difference if there is a dot or a really empty cell. You'll get the link anyway.
To control this use conditional styling. Consider the following example:
SET NODATA=''
SET ACROSSPRT = NORMAL
TABLE FILE CAR
PRINT 
     SEATS
BY 'CAR.COMP.CAR'
ACROSS 'CAR.ORIGIN.COUNTRY'
ON TABLE NOTOTAL
ON TABLE SET STYLE *
$
TYPE=REPORT,
     FONT='VERDANA',
     SIZE=9,
$
TYPE=DATA,
     ACROSSCOLUMN=N1,
     WHEN=N2 NE 0,
     FOCEXEC=TEST,
$
ENDSTYLE
END
Whether or not the link is shown depends on the WHEN clause in the styling.


GamP

- Using AS 8.2.01 on Windows 10 - IE11.
in Focus since 1988