Focal Point
[SOLVED] reportcaster database corruption

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/8771007503

November 06, 2008, 08:19 AM
Phillip
[SOLVED] reportcaster database corruption
Hi,

I had a problem where reports was scheduled in reportcaster. It did show up in the admin and schedule tool but they just did not want to run. I did do a check file on all the focus db's of reportcaster as well as a reorg and table file print *. Non of these reported errors.

After I created new reportcaster db's it was fine again. (lost al schedules jobs, again).

Is there a better way to check the focus db's?

Thank you
Phillip du Plooy

This message has been edited. Last edited by: Kerry,


WebFocus 7.1 On win2000 (webfocus admin)
Oracle 9i Aix (dba)
Oracle 10g RedHat (dba)
MsSql (dba)
Adabas 4 OpenVMS (dba + sysadmin)
November 06, 2008, 09:14 AM
GinnyJakes
Phillip,

The next time this happens, turn the RC traces on to see what is going on and/or open a case with IBI before you remove everything.

It may be that you are out of space or the data bases need rebuilding.

Don't use a sledge hammer to resolve the problem when a fly swatter might do. Sweating I feel very badly that you lost all of your work. Does this happen often?


Ginny
---------------------------------
Prod: WF 7.7.01 Dev: WF 7.6.9-11
Admin, MRE,self-service; adapters: Teradata, DB2, Oracle, SQL Server, Essbase, ESRI, FlexEnable, Google
November 06, 2008, 02:30 PM
<JG>
Phillip,

It's very unlikey that anything other than the log files are the issue.

Except as Ginny suggests space (but they may be the cause of that issue).

I would first backup the log databases and recreate just them and see if that resolves the problem.

As an ideal if you can switch from Focus DBs to SQL based that may well resolve the issue,
seeing your profile you have both Oracle and MSSQL available.