Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     ReportCaster/Library Questions

Read-Only Read-Only Topic
Go
Search
Notify
Tools
ReportCaster/Library Questions
 Login/Join
 
Member
posted
1) If a user has the Report Library privilege via MRE User Administration, shouldn't that user be able to access Report Library either by clicking on the Library icon in MRE or logging on via the Library logon page?

2) In dserver.ini, what should the values be or USER and PASS? Does this need to be a valid MRE userid and password? Does this have any effect on Report Library, because I'm finding that I can only log on to Library when I use the values specified in dserver.ini.

Thanks!
 
Posts: 16 | Location: Houston, Texas | Registered: May 13, 2003Report This Post
Member
posted Hide Post
1) Yes. If you are experiencing problems you should contact Customer Support. You have to be configured with WF Servlet as ReportCaster in 52x is only supported with Servlet, not CGI.

2) When the install creates dserver.ini for the Distribution Server install there is no parameters 'USER' and 'PASS'. There are 'ADMIN' and 'PASS' parameters which is the overall administrator for ReportCaster. This id/pas is not stored in the ReportCaster repository so that there is an id/pass that can administer ReportCaster in the event that the ReportCaster repository is unavailable. This id/pass can use all areas of the ReportCaster/Report Library so this leads me to believe that your overall issue is with creating users in MR with Library privilege and having ReportCaster recognize these users.

The most common issue with this is that the site is configured with CGI and not WF Servlet. Our Product Managers recently found out that the CGI creates users in MR repository when Caster privileges are specified but does not call ReportCaster (since only supports Servlet). Product Management plans on opening up a internal project to make a change to display an appropriate message if configured with CGI.

Hope that helps...
 
Posts: 28 | Registered: May 22, 2003Report This Post
Member
posted Hide Post
Hi Susan,

Regarding this issue, this is my workaround. Assume that I've migrated a 436 MRE Repository to 52.

1) For each Admin id, back up the corresponding .htm file, directory in basedir, and user.htm.

2) Delete the Admin id.

3) Recreate the Admin id and assign full ReportCaster privileges.

4) Edit user.htm and for each Admin id, replace the .htm reference with the one from the original user.htm. Copy back any references to assigned Domains.

Maybe this will help another customer in the future.
 
Posts: 16 | Location: Houston, Texas | Registered: May 13, 2003Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     ReportCaster/Library Questions

Copyright © 1996-2020 Information Builders