Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SHARING] SUBFOOT NOSPLIT
Go
New
Search
Notify
Tools
Reply
  
[SHARING] SUBFOOT NOSPLIT
 Login/Join
 
Platinum Member
posted
I recently was working with a compound report and one of the reports had ON fieldname SUBFOOT NOSPLIT. It worked fine running just that report, but when the compound report ran, I was getting errors. Turned out I needed to put them on separate lines:
ON fieldname NOSPLIT
ON fieldname SUBFOOT
" footer "

The errors were not helpful so I thought I would share this in case anyone else runs into it.

Actually, I had a blank footer (" ") and the first error I got was about having no text for the subfooter.


WebFOCUS 8.2.03 (production), 8.2.06 (testing)
AppStudio, InfoAssist
Windows, All Outputs
 
Posts: 156 | Location: Indiana | Registered: December 05, 2017Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Was the original syntax coded by hand or did App Studio create it? Also, how did you figure out that's the problem?


WebFOCUS 8206, Unix, Windows
 
Posts: 1781 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Guru
posted Hide Post
Actually I had the same problem and did the same thing. I did not think to post this. my bad.


WF 7.6.11
Oracle
WebSphere
Windows NT-5.2 x86 32bit
 
Posts: 398 | Registered: February 04, 2008Reply With QuoteReport This Post
Expert
posted Hide Post
Good One

Thanks


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.06OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6207 | Location: 33.8688° S, 151.2093° E | Registered: October 31, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
BabakNYC - the code pre-dates my start with the company but I suspect it was originally generated by DevStudio. I was adding a couple of reports but working in AppStudio text editor.
To figure it out I searched FocalPoint, looked at the technical documentation and did lots of trial-and-error.


WebFOCUS 8.2.03 (production), 8.2.06 (testing)
AppStudio, InfoAssist
Windows, All Outputs
 
Posts: 156 | Location: Indiana | Registered: December 05, 2017Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SHARING] SUBFOOT NOSPLIT

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.