Focal Point
[CLOSED] Spinner from HTML report

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/8957040786

June 22, 2017, 02:34 PM
Shingles
[CLOSED] Spinner from HTML report
Hi All,

Pretty new to WF. I'd appreciate your help.

I'm exploring what is possible with HTML documents in App Studio. When I try to run a document, I get the spinner that doesn't go away. I suspect it has something to do with a setting in IE.

I have tried creating some documents and I even tried to run one with nothing at all (I created an HTML document and I hit run). Each time I get just this spinner that doesn't go away.

I searched this forum for "IE spinner HTML" and variations, but I couldn't find a solution to this.

Anyone have this happen to them?

Thank you!

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS 8201, SP 0.1, Windows 7, HTML
June 22, 2017, 02:51 PM
MartinY
Welcome Shingles,

Your request is pretty vague.

The "spinner" could be there for multiple reasons such as a procedure that goes into a loop, or an error in your HTML (could be a js error) that prevents the page from loading...

May not be related to IE. Try with FireFox and/or Chrome.

What I do suggest is :

1- Be sure that each report/graph can be executed properly outside the HTML page
2- Include them one by one in a brand new HTML/Document by performing a test with each inclusion
3- Use the IE F12-Degugging key to find any issue


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
June 22, 2017, 03:44 PM
Shingles
So here are the steps I took...

App Studio > Environments Tree > I select a folder under Domain where I have successfully created reports > right click > New > HTML/Document > The HTML/Document Wizard shows up > click Next > click Finish > then from AppStudio I hit run > and I'm stuck with this spinner.

So you see... there is nothing special about the HTML document. That's why I think it has something to do with my environment (AppStudio or IE).

As for trying to run it in Chrome... I've tried to click the Chrome button under the Utilities ribbon > Preview group, and I get the following error message: "Error: Request processing failed. Warning: Failed to create instance of IBIWebBrowserDriverInterface needed for multi browser support"

I tried App Studio Options > Output Viewer Settings > Chrome > Test Browser Setup and I get the following error message: "Webdriver test status. Warning: Failed to create instance of IBIWebBrowserDriversInterface needed for multibrowser support"

I tried App Studio Options > Output Viewer Settings > Internal Viewer > Test Browser Setup and it comes back with SUCCESS (I also get SUCCESS with IE). But when I run the HTML document with IE or Internal Viewer I get this spinner that doesnt want to go away.

I tried F12 with IE and I don't see anything unusual.

So... does any of that help? What else can I try?


WebFOCUS 8201, SP 0.1, Windows 7, HTML
June 23, 2017, 07:00 AM
Thomas Raspberry
My University experienced "HTML spinner" on 8.105m version which was caused by insufficient Security settings. Questions:
1. Are you an Administrator in your WF environment? or a "developer" granted access to create reports under that 'folder' in Domain?
2. Were you able to run ANY HTML document/report in your WebFocus which does not belong to You? Do other members experience the same issue or just You?


WebFOCUS 8.201
June 23, 2017, 08:50 AM
Shingles
I am a developer who has created and run reports in this folder.

I've been able to run other HTML documents that are embedded in a portal (via WebFOCUS). But I haven't been able to get run one from AppStudio.

I hope that makes sense.

Thanks...


WebFOCUS 8201, SP 0.1, Windows 7, HTML
June 23, 2017, 09:06 AM
Thomas Raspberry
So if you created that HTML document in App Studio then what happens when:
1. Run preview via App Studio (spinner appears without output, right?)
2. Run it in actual WebFocus via browser (firefox/chrome), -> the same issue like above or it actually runs?

I found that those PREVIEWS options in App Studio are not very accurate. I am usually creating projects via App Studio but executing/previewing in actual WebFocus/Browser instead.

I hope I am not asking too many questions Wink


WebFOCUS 8.201
June 23, 2017, 09:35 AM
Shingles
That's a good test... wish I thought of it.

Unfortunately it yields the same results. Only that spinner appears.

From WebFOCUS I navigated to other HTML documents and tried running them, and all I get is that spinner. These HTML documents are part some portals. When I run the portals I have no trouble seeing the HTML contents.

Thanks...


WebFOCUS 8201, SP 0.1, Windows 7, HTML
June 26, 2017, 01:48 PM
FP Mod Chuck
Hi Shingles

I think you need to open a case with techsupport on this issue. Something is wrong on your system.

Thanks


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats