Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Backcolor Allignment Question
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] Backcolor Allignment Question
 Login/Join
 
Platinum Member
posted
The code below works for giving me a page header that has a background color inside the grid. When I run this independently (as its own query), the background color goes all the way to the edges of the grid. When I add the next section to the page, the background color no longer goes all the way to the edges of the grid.

I'm guessing it has something to do with the report/header width, but does anyone know what could be causing the backcolor to not fill the entire grid square?


SET ASNAMES = ON
SET DTSTANDARD = STANDARD
SET HTMLCSS=ON
SET SHOWBLANKS = ON

FILEDEF OUTPUT1 DISK REPORT1.DOC
SET COMPONENT = 'report1'

DEFINE FILE CAR
SECTIONDATA WITH COUNTRY/A1= '';
END

TABLE FILE CAR
BY COUNTRY NOPRINT

HEADING
"Attachment 2"
"Contract List"

ON TABLE SET PAGE NOLEAD
ON TABLE SET STYLE *
UNITS=IN, ORIENTATION=PORTRAIT, TOPMARGIN=0,LEFTMARGIN=0,RIGHTMARGIN=0,$
TYPE=REPORT,FONT='ARIAL', GRID=ON, WIDTH=6.6,$

TYPE=HEADING,LINE=1,JUSTIFY=CENTER,STYLE=BOLD,SIZE=12,BACKCOLOR=RGB(210 210 210), WIDTH=6.600,$
TYPE=HEADING,LINE=2,JUSTIFY=CENTER,STYLE=BOLD,SIZE=12,BACKCOLOR=RGB(210 210 210), WIDTH=6.600,$

ENDSTYLE

ON TABLE HOLD AS REPORT1 FORMAT HTMTABLE
END
-RUN

SET HTMLFORMTYPE=DOC
-HTMLFORM BEGIN
!IBI.FIL.REPORT1;
<P STYLE="PAGE-BREAK-BEFORE: NEVER">
-HTMLFORM END 

-EXIT

This message has been edited. Last edited by: Kerry,


Production - 7.6.4
Sandbox - 7.6.4
 
Posts: 241 | Location: Bethesda, MD | Registered: August 14, 2007Reply With QuoteReport This Post
Expert
posted Hide Post
Seems to work for me,

Could it be the version of Word ?

I was using Word 2003


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.05OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6105 | Location: Land of the Darug people, Terra Australis Incognita | Registered: October 31, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
It works for me too.

I think tha the problem is because in my acual code, there is a section immediately above this that has the GRID turned off, and then this section has the GRID on.


Production - 7.6.4
Sandbox - 7.6.4
 
Posts: 241 | Location: Bethesda, MD | Registered: August 14, 2007Reply With QuoteReport This Post
Expert
posted Hide Post
Are you able to add the extra section in the sample code ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.05OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Know The Code

 
Posts: 6105 | Location: Land of the Darug people, Terra Australis Incognita | Registered: October 31, 2006Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Backcolor Allignment Question

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.