Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Pdf not displaying in browser

Read-Only Read-Only Topic
Go
Search
Notify
Tools
Pdf not displaying in browser
 Login/Join
 
Member
posted
We recently upgraded to WF 7.6.11. When you do a drill down on a self-service report it normally opens as a pdf document in a browser window. Now, it is opening in adobe and when you drill down you receive the following error:
The document is tryng to connect to file:///ibi_apps/WFServlet?IBIF_webapp=/ibi_apps&IBIC_server=edaserve&IBIWF_msfviewer=OFF&&IBIMR_drill=X......

Adobe is set-up to Display PDF's in the browser & the redirection settings (Admin Console) are set to 'NO' for PDF.

This message has been edited. Last edited by: LAW,
 
Posts: 14 | Registered: November 05, 2008Report This Post
Expert
posted Hide Post
-**************************************
-* CHANGE TO YOUR SERVER IP ADDRESS *
-**************************************
-SET &SERVER = 'AAA.YYY.xx.XXX:8080';


SET GRAPHSERVURL = 'http://' || '&SERVER.EVAL' || '/ibi_apps/IBIGraphServlet'
SET FOCEXURL = 'http://' || '&SERVER.EVAL' || '/ibi_apps/WFServlet'
-RUN


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Member
posted Hide Post
Can this be set in the site.wfs or the edasprof.prf?
 
Posts: 14 | Registered: November 05, 2008Report This Post
Expert
posted Hide Post
Yes. I would suggest using site.wfs:
  
SERVER=123.456.78.111:8080
<set>SERVER(pass)

If on the reporting server, edasprof.prf:

-SET &SERVER = '123.456.78.111:8080';

Then, in a fex:

-? &SERVER

You should see the IP address.
Then do the SET FOCEXURL suggested above...

hth


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Member
posted Hide Post
quote:
SET FOCEXURL = 'http://' || '&SERVER.EVAL' || '/ibi_apps/WFServlet'



I am unable to get this to work for me. I have too many fexes to add the SET FOCEXURL in each one. Why in Version 7.6.11 did this change? Prior to the upgrade when I drill down in a report my output would automatically open in a browser window. With 7.6.11 it automatically opens in PDF which causes the error that I am getting. I think this is a bug with 7.6.11.
 
Posts: 14 | Registered: November 05, 2008Report This Post
Expert
posted Hide Post
Go into any FEX and do this at the very top:

-? &
-EXIT

You will see a bunch of ampere variables, this is what we have:
  
CURRENTLY DEFINED & VARIABLES:
 &ACCEPTS      =        0
 &APPROOT      = D:\ibi\64bit\apps
 &AUTOINDEX    = NO
 &BASEIO       =        0
 &CHNGD        =        0
 &DATE         = 07/28/10
 &DBMSERR      =        0
 &DELTD        =        0
 &DMY          = 280710
 &DMYY         = 28072010
 &DUPLS        =        0
 &ECHO         = OFF
 &EXITRC       =        0
 &FOCEXURL     = /ibi_apps/WFServlet?IBIF_webapp=/ibi_apps&IBIC_server=EDASERV
 &FOCFEXNAME   = car_rpt.fex
 &FOCFOCEXEC   = _car_rpt.fex
 &FOCGRAPHCNT  =        0
 &FOCHTMLURL   = /ibi_html
 &FOCINCLUDE   = car_rpt.fex
 &FOCNEXTPAGE  =        0
 &FORMAT       =        0
 &IBIC_pass    = xxxxxxxxxxxxxxx
 &IBIC_user    = xxxxxxxxxxxxxxx
 &IBIMR_domain =
 &IBIMR_user   =
 &INDEXIO      =        0
 &INPUT        =        0
 &INVALID      =        0
 &LINES        =        0
 &MDY          = 072810
 &MDYY         = 07282010
 &MR_FULL_FEXN>=
 &MR_ITEM_HAND>=
 &NOMATCH      =        0
 &READS        =        0
 &RECORDS      =        0
 &REJECTS      =        0
 &RETCODE      =        0
 &SETFILE      =
 &SORTIO       =        0
 &TOD          = 11.47.41
 &TRANS        =        0
 &WFDESCRIBE   = OFF
 &YMD          = 100728
 &YYMD         = 20100728


see if you have:

&FOCEXURL = /ibi_apps/WFServlet?IBIF_webapp=/ibi_apps&IBIC_server=EDASERV

ADOBE does not know where the program is to excute, which is exactly what your URL is using in your 1st post.
It is missing the HTTP://SERVER_IP/

WebFOCUS now uses the FOCEXURL for PDF drilling(7.6.7, I think) So, to rectify this, we did the following:

  
-**************************************
-* CHANGE TO YOUR SERVER IP ADDRESS *
-**************************************
-SET &SERVER     = 'AAA.YYY.xx.XXX:8080';
-SET &PDF_URL    = 'http://' || '&SERVER.EVAL' || &FOCEXURL;
SET FOCEXURL     = &PDF_URL
-RUN


So, here is an example of valid code; Create a focexec called CAR_RPT and copy the code below in and SAVE it:

  
APP PREPENDPATH IBISAMP
-RUN
-SET &ECHO=ALL;
-DEFAULTS &COUNTRY = 'FOC_NONE'
-**************************************
-* CHANGE TO YOUR SERVER IP ADDRESS *
-**************************************
-SET &FMT        = 'PDF';
-SET &SERVER     = 'ABC.ABC.11.123:8080';  <----- CHANGE THIS
-SET &PDF_URL    = 'http://' || '&SERVER.EVAL' || &FOCEXURL;
SET FOCEXURL     = &PDF_URL
-RUN
TABLE FILE CAR
PRINT 
    RETAIL_COST
	DEALER_COST
	  COMPUTE PROFIT/P13.2MC = RETAIL_COST - DEALER_COST;
BY COUNTRY
BY CAR
WHERE COUNTRY EQ '&COUNTRY';
ON TABLE PCHOLD FORMAT &FMT
ON TABLE SET STYLE *
-IF &COUNTRY NE 'FOC_NONE' GOTO END_STYLE;
TYPE=DATA,
     COLUMN = N1, TARGET='_blank',
     FOCEXEC=CAR_RPT(FMT='&FMT' COUNTRY=N1), $
-END_STYLE
ENDSTYLE
END
-RUN


CHANGE the "REPORTING SERVER" IP address to your sites server. This works, for me...

Tom

This message has been edited. Last edited by: Tom Flynn,


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Expert
posted Hide Post
BTW, After some thought, edasprof.prf is probably the best place to put the ampere variable, reason being, you probably have only 1 Client, but, in Dev Studio, you can access multiple environments/servers, PROD, DEV, QA, etc...

That is why &FOCEXURL does NOT contain the IP address or the HTTP/HTTPS...

So, adding this to edasprof:

-SET &SERVER = 'HTTP://AAA.YYY.xx.XXX:8080'; or
-SET &SERVER = 'HTTPS://AAA.YYY.xx.XXX:8080';

would work best, imo...

Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Member
posted Hide Post
O.K. That works if I put it in each drill down fex.

I tried adding: -SET &SERVER = AAA.YYY.xx.XXX
to the ibi\srv76\wfs\etc\edasprof.prf to see if that works but it doesn't.
 
Posts: 14 | Registered: November 05, 2008Report This Post
Expert
posted Hide Post
LAW,

That's a dummy IP address, I don't put actual addresses on-line...

On the server, you need quotes, as in what was suggested earlier:

-SET &SERVER = 'HTTP://AAA.YYY.xx.XXX:8080'; or
-SET &SERVER = 'HTTPS://AAA.YYY.xx.XXX:8080';

Of course, with YOUR SERVER IP address...

Glad it worked...


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Member
posted Hide Post
I entered
-SET &SERVER = 'HTTPS://alpha.web.address:8080'; in the edasprof and it does not work. If I enter the same thing in the fex it does???
 
Posts: 14 | Registered: November 05, 2008Report This Post
Expert
posted Hide Post
May have to change &SERVER to &&SERVER in edasprof. I'll check tomorrow...


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Expert
posted Hide Post
That worked. Before adding &&SERVER on the server:
  
CURRENTLY DEFINED & VARIABLES:
 &&APPLOCK     = APP_NOT_LOCKED
 &&APP_PERMIT  = ALL
 &&EDAAPP      = APP-ENABLED
 &&EDACONF     = D:\ibi\64bit\srv76\wfs
 &&OSTYPE      = WINNT
 &&SRVTYPE     = PTH
 &ACCEPTS      =        0
 &APPROOT      = D:\ibi\64bit\apps
 &AUTOINDEX    = NO
 &BASEIO       =        0
 &CHNGD        =        0
 &DATE         = 07/28/10
 &DBMSERR      =        0
 &DELTD        =        0
 &DMY          = 280710
 &DMYY         = 28072010
 &DUPLS        =        0
 &ECHO         = OFF
 &EXITRC       =        0
 &FOCEXURL     = /ibi_apps/WFServlet?IBIF_webapp=/ibi_apps&IBIC_server=EDASERV
 &FOCFEXNAME   = environment.fex
 &FOCFOCEXEC   = _environment.fex
 &FOCGRAPHCNT  =        0
 &FOCHTMLURL   = /ibi_html
 &FOCINCLUDE   = environment.fex
 &FOCNEXTPAGE  =        0
 &FORMAT       =        0
 &IBIC_pass    = XXXXXXXXXXXXXX
 &IBIC_user    = XXXXXXXXXXXXXX
 &IBIMR_domain =
 &IBIMR_user   =
 &INDEXIO      =        0
 &INPUT        =        0
 &INVALID      =        0
 &LINES        =        0
 &MDY          = 072810
 &MDYY         = 07282010
 &MR_FULL_FEXN>=
 &MR_ITEM_HAND>=
 &NOMATCH      =        0
 &READS        =        0
 &RECORDS      =        0
 &REJECTS      =        0
 &RETCODE      =        0
 &SETFILE      =
 &SORTIO       =        0
 &TOD          = 15.54.42
 &TRANS        =        0
 &WFDESCRIBE   = OFF
 &YMD          = 100728
 &YYMD         = 20100728


After adding &&SERVER:
  
CURRENTLY DEFINED & VARIABLES:
 &&APPLOCK     = APP_NOT_LOCKED
 &&APP_PERMIT  = ALL
 &&EDAAPP      = APP-ENABLED
 &&EDACONF     = D:\ibi\64bit\srv76\wfs
 &&OSTYPE      = WINNT
 &&SERVER      = http://ABC.DEF.GH.IJK:8080
 &&SRVTYPE     = PTH
 &ACCEPTS      =        0
 &APPROOT      = D:\ibi\64bit\apps
 &AUTOINDEX    = NO
 &BASEIO       =        0
 &CHNGD        =        0
 &DATE         = 07/29/10
 &DBMSERR      =        0
 &DELTD        =        0
 &DMY          = 290710
 &DMYY         = 29072010
 &DUPLS        =        0
 &ECHO         = OFF
 &EXITRC       =        0
 &FOCEXURL     = /ibi_apps/WFServlet?IBIF_webapp=/ibi_apps&IBIC_server=EDASERV
 &FOCFEXNAME   = audit_crslist.fex
 &FOCFOCEXEC   = _audit_crslist.fex
 &FOCGRAPHCNT  =        0
 &FOCHTMLURL   = /ibi_html
 &FOCINCLUDE   = audit_crslist.fex
 &FOCNEXTPAGE  =        0
 &FORMAT       =        0
 &IBIC_pass    = xxxxxxxxxxxxxx
 &IBIC_user    = xxxxxxxxxxxxxx
 &IBIMR_domain =
 &IBIMR_user   =
 &INDEXIO      =        0
 &INPUT        =        0
 &INVALID      =        0
 &LINES        =        0
 &MDY          = 072910
 &MDYY         = 07292010
 &MR_FULL_FEXN>=
 &MR_ITEM_HAND>=
 &NOMATCH      =        0
 &READS        =        0
 &RECORDS      =        0
 &REJECTS      =        0
 &RETCODE      =        0
 &SETFILE      =
 &SORTIO       =        0
 &TOD          = 09.21.44
 &TRANS        =        0
 &WFDESCRIBE   = OFF
 &YMD          = 100729
 &YYMD         = 20100729


Now, you will have to add code to ALL your programs:

SET FOCEXURL = &&SERVER || &FOCEXURL
-RUN

I feel your pain, but, that's the way it is, and, the way it works...

Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Pdf not displaying in browser

Copyright © 1996-2020 Information Builders