Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Excel ouput with ibfs extension
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] Excel ouput with ibfs extension
 Login/Join
 
Gold member
posted
I have written a report where the output goes to an excel document. When prompt to save, the document has an extension of .ibfs. This only occurs in Firefox, Chrome, and Opera. Internet Exploder saves with the correct extension of .xls. Here is sample code:

TABLE FILE CAR
PRINT 
     CAR.COMP.CAR
     CAR.CARREC.MODEL
     CAR.BODY.BODYTYPE
WHERE CAR.ORIGIN.COUNTRY EQ 'ENGLAND';
ON TABLE SET PAGE-NUM NOLEAD 
ON TABLE NOTOTAL
ON TABLE PCHOLD FORMAT EXL2K OPEN NOBREAK
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
     INCLUDE = endeflt,
$
ENDSTYLE
END


TABLE FILE CAR
PRINT 
     CAR.COMP.CAR
     CAR.CARREC.MODEL
     CAR.BODY.BODYTYPE
WHERE CAR.ORIGIN.COUNTRY EQ 'JAPAN';
ON TABLE SET PAGE-NUM NOLEAD 
ON TABLE NOTOTAL
ON TABLE PCHOLD FORMAT EXL2K CLOSE
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
     INCLUDE = endeflt,
$
ENDSTYLE
END


I have checked my redirecting settings on the server and they look to be correct. Any ideas why Firefox, Chrome, and Opera try to save with an .ibfs extension?

Thanks,

Daniel

This message has been edited. Last edited by: <Kathryn Henning>,


In Focus since 2012
WebFOCUS 8.0.07
Windows, All Outputs
 
Posts: 59 | Registered: November 15, 2012Reply With QuoteReport This Post
<Kathryn Henning>
posted
Hi Daniel,

What versions of Firefox, Chrome and Opera are you using? Please ensure that they are supported versions for your version of WebFOCUS.

Web Browser Support for WebFOCUS

Cheers!

Kathryn
 
Reply With QuoteReport This Post
Gold member
posted Hide Post
All three browsers are up to date to the latest versions.


In Focus since 2012
WebFOCUS 8.0.07
Windows, All Outputs
 
Posts: 59 | Registered: November 15, 2012Reply With QuoteReport This Post
<Kathryn Henning>
posted
Hi Daniel,

Thanks for updating your release of WebFOCUS in your signature. The most recent browser versions are often not supported since they are generally released after a particular version of WebFOCUS has gone production. We provide the support matrices by WebFOCUS release so that customers can see whether or not a particular version of their preferred browser is supported.

Cheers!

Kathryn
 
Reply With QuoteReport This Post
Expert
posted Hide Post
Has absolutely nothing to do with any browser.
And it is a real pain...


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1961 | Location: Centennial, CO | Registered: January 31, 2006Reply With QuoteReport This Post
<Kathryn Henning>
posted
Hi All,

Given that this worked in one browser but not others, it initially appeared to be a browser issue. However, as Tom points out, it isn't. Please reference the following steps:

1. Make a backup copy of the mime.wfs file at: \ibi\WebFOCUS80\client\wfc\etc

2. Open the file in a text editor.

3. Locate the mime.wfs file row: ".xmh"

4. Change it to have the last column specify: .xls instead of .xmh

5. Save the file.

6. Open the WebFOCUS Administration Console.

7. On the Configuration and Redirection Settings, verify the extension .xmh is .xls and set the "Save Report" drop down option to Yes.

8. Click Save and Clear Cache.

Cheers!

Kathryn
 
Reply With QuoteReport This Post
Expert
posted Hide Post
Hi Kathryn,
Unfortunately, it is not only Excel:


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1961 | Location: Centennial, CO | Registered: January 31, 2006Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi Kathryn,

I tried the 8 steps you mentioned and still no luck.

Daniel


In Focus since 2012
WebFOCUS 8.0.07
Windows, All Outputs
 
Posts: 59 | Registered: November 15, 2012Reply With QuoteReport This Post
<Kathryn Henning>
posted
Hi Tom and Daniel,

Please open cases on InfoResponse Online so that we can work with you to see what else may be causing this.

Thanks and regards,

Kathryn
 
Reply With QuoteReport This Post
Expert
posted Hide Post
Hi Kathryn,
My example is very simple, and, I won't be opening a case for something as generic as this...
IBI is generating the extension, never had before.
I'm sure they know about this and a myriad of other bugs, i.e., AutoPrompter, in WebFOCUS 8.0.07..
Not Fun anymore, IBI...
Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1961 | Location: Centennial, CO | Registered: January 31, 2006Reply With QuoteReport This Post
<Kathryn Henning>
posted
Hi All,

I tested both Daniel and Tom's code under WebFOCUS releases 8.0.07 and 8.0.08 under Content using Firefox but could not reproduce the issue. We've had a report of this behavior that the steps above resolved. Aside from that, there haven't been any reports of this behavior. This may be caused by something environmental, but in my tests, I couldn't determine what it might be as my test environment is vanilla. If my testing is different that what you're doing when you receive this message, please let me know.

Thanks and regards,

Kathryn
 
Reply With QuoteReport This Post
Guru
posted Hide Post
Hey all,

What client settings are you using for excel and autoprompt?
We had to erase the default IBIF_excelservurl and we had to set parameter prompting to XMLRUN in order for things to work smoothly. I download the excel files automatically without the save/open option and the invalid file format message appears but Excel will still open the file.


WebFOCUS 7.7.03/8.0.08
Dev Studio 7.7.03/8.0.08
App Studio 8.0.08
Windows 7
ALL Outputs
 
Posts: 402 | Location: Upland, IN | Registered: June 08, 2012Reply With QuoteReport This Post
Expert
posted Hide Post
Thought I would give an update for ON TABLE PCHOLD FORMAT ALPHA:

After meeting With Art Greenhaus and Michael Lewis of IBI, by clicking on the Save as
Type and selecting All files, then wiping out the default name and renaming the
file with double quotes around it, the file is saved as expected.
Example:
Test_IBFS_Extension_fex.ibfs will be renamed to "Tax File for NY State"
This saves the data as a "FILE" and is able to be fed to our other systems...


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1961 | Location: Centennial, CO | Registered: January 31, 2006Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi Tom,

I tried your work around but when the file saves my OS has no clue what it is or how to open the file. Plus my users will have a fit if I tell them that many steps just to save a Excel file.

Daniel


In Focus since 2012
WebFOCUS 8.0.07
Windows, All Outputs
 
Posts: 59 | Registered: November 15, 2012Reply With QuoteReport This Post
Master
posted Hide Post
Hi Dan,

We will review all of the information for your case and arrange for a quick call with you to resolve the issue. Kathryn Henning will compile the information needed. Thanks for your patience.

Sincerely,

Kathleen Butler
Information Builders
 
Posts: 429 | Location: New York | Registered: September 20, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
Hi Daniel,
Again, my issue was PCHOLD FORMAT ALPHA. For your issue, we are not getting the ibfs extension for Excel, we get xmh or xht. In the mime.wfs file, we changed those to xls and Save Report to yes. Now we get the file with extension .xls

You need to change the mime.wfs. Contact IBI, they will be able to assist...

Per IBI, this will be able to be done via Admin --> Redirection Setting in release 8.1
Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1961 | Location: Centennial, CO | Registered: January 31, 2006Reply With QuoteReport This Post
Gold member
posted Hide Post
Hi Tom,

I have looked at the redirection settings and all the excel extensions have been set to yes.

Daniel


In Focus since 2012
WebFOCUS 8.0.07
Windows, All Outputs
 
Posts: 59 | Registered: November 15, 2012Reply With QuoteReport This Post
Guru
posted Hide Post
I think Tom also directly changed the mime.wfs changing the xmh and xht directly to .xls

BTW XLSX (old syntax - EXL07) works great and now supports a lot of features (you will have to log in to see them)


WebFOCUS 7.7.03/8.0.08
Dev Studio 7.7.03/8.0.08
App Studio 8.0.08
Windows 7
ALL Outputs
 
Posts: 402 | Location: Upland, IN | Registered: June 08, 2012Reply With QuoteReport This Post
Expert
posted Hide Post
J,
THX, totally forgot about XLSX, will try that with the Mac user...

Daniel,
quote:
You need to change the mime.wfs. Contact IBI, they will be able to assist...

This is on the server, it's contents are "mostly" displayed in the Reconfig settings, BUT, you can't change them there until 8.1...


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1961 | Location: Centennial, CO | Registered: January 31, 2006Reply With QuoteReport This Post
Member
posted Hide Post
Tom, You misunderstood what I said.

In release 8.1, we (IBI) have changed the mime.wfs file, so that 'SAVE Report' defaults to 'YES', and for excel outputs, the default file extension is either XLS or XLSX. The file extension will NOT be changeable via the client console. You'd need to use an editor to change it, if desired. Our intent was to make it unnecessary to change the defaults.
 
Posts: 25 | Location: 2 Penn Plaza 28 fl | Registered: March 27, 2003Reply With QuoteReport This Post
Expert
posted Hide Post
Hi Art,
OK, My Bad!!!
Thank You for clarifying...
Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1961 | Location: Centennial, CO | Registered: January 31, 2006Reply With QuoteReport This Post
<Kathryn Henning>
posted
Hi All,

Daniel G and Art Greenhaus worked on this issue. Each browser handles sending an Excel file back differently. IE drops any file extension that may be there and appends .xls to the end. Chrome, Firefox, and Opera don't do this which results in the .ibfs file extension being returned.

Here is the resolution:

Using an editor such as WordPad, make the following changes. They must be done through an editor since the file extension can't be changed via the GUI:

1. edit ibi\webfocus80\client\wfc\etc\mime.wfs
2. for the .xmh extension, change Save Report from no to yes in the second to the last column, and change the file extension from .xmh to .xls in the last column
3. clear the Client cache

As Art mentions above, in release 8.1, changes have been made to the mime.wfs file so that 'Save Report' defaults to 'yes', and for Excel outputs, the default file extension is either .xls or .xlsx.

Cheers!

Kathryn
 
Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Thanks for this information.
The post was about WF 8.0, but I had a similar problem in WF 7.7
Excel 2000 output normally is created as .xls, but when I make compound reports the extension suddenly changes to .xmh and many clients had problems with this as it was not recognized as an excel extension.
With changing the mime.wfs I now also get the .xls extension.

Martin.


WebFocus 8203M, iWay DataMigrator, Windows, DB2 Windows V10.5, MS SQL Server, Azure SQL, Hyperstage, ReportCaster
 
Posts: 154 | Registered: March 29, 2013Reply With QuoteReport This Post
Member
posted Hide Post
Two points:

1. The extensions of '.ibfs' and '.bip' resulted from an enhancement to security, and only appear when 'save report' is set to NO. In that case, the name used is from the HTTP call, and, as mentioned, only appears with Firefox or CHROME, due to differences in how each handles HTTP protocols.

2. BY setting 'save report' to YES, we can use the 'AS' phrase specified in the request, as the filename for the attached file (an added bonus). Manually changing the extension in the mime.wfs file provides the desired extension.
 
Posts: 25 | Location: 2 Penn Plaza 28 fl | Registered: March 27, 2003Reply With QuoteReport This Post
Guru
posted Hide Post
quote:
Originally posted by J:
We had to erase the default IBIF_excelservurl.

Well this relates more to XLSX format but we found this in the WebFOCUS Security and Administration doc:

The IBIF_excelservurl setting cannot be used when web server security is enabled. This
includes Basic authentication, IWA, SSL, and third-party security products (such as
SiteMinder, Clear Trust, Oblix, WebSEAL). In these cases, the web server security settings
can prevent WebFOCUS from creating the Excel 2007 file. The IBIF_excelservurl setting
can be used with Basic authentication when the credentials are supplied as follows...


WebFOCUS 7.7.03/8.0.08
Dev Studio 7.7.03/8.0.08
App Studio 8.0.08
Windows 7
ALL Outputs
 
Posts: 402 | Location: Upland, IN | Registered: June 08, 2012Reply With QuoteReport This Post
Member
posted Hide Post
quote:
Originally posted by FocWizard:
Two points:

1. The extensions of '.ibfs' and '.bip' resulted from an enhancement to security, and only appear when 'save report' is set to NO. In that case, the name used is from the HTTP call, and, as mentioned, only appears with Firefox or CHROME, due to differences in how each handles HTTP protocols.

2. BY setting 'save report' to YES, we can use the 'AS' phrase specified in the request, as the filename for the attached file (an added bonus). Manually changing the extension in the mime.wfs file provides the desired extension.


Is there a solution to this for 8.0.07? We will be upgrading to 8.1.05 in a month or 2 but we need to have Excel output on Macs working now. Thanks. Bob


WebFOCUS 8.0.09 server, 8.0.07 Client, Windows 2012 R2 Server, InfoAssist, BI Portal, Graphs, Excel, PDF.
 
Posts: 13 | Location: Seattle, WA | Registered: April 07, 2015Reply With QuoteReport This Post
<Kathryn Henning>
posted
Hi Bob,

Thank you for opening a case for your question.

Regards,

Kathryn
 
Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Excel ouput with ibfs extension

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.