Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Scheduled Report Only Works When Logged Into App Studio
Go
New
Search
Notify
Tools
Reply
  
[CLOSED] Scheduled Report Only Works When Logged Into App Studio
 Login/Join
 
Member
posted
I have a report that is scheduled to run every morning at 9:00am. If I have App Studio up on my machine, the scheduled report works fine. If I do not have App Studio up on my machine, the schedule run but it gives incorrect output. The schedule consists of 27 tasks that use foccache hold files. Most of the reports are dependent on the previous report. Does anyone have any idea why this would only work when I'm logged in to App Studio. I am on 8206.

This message has been edited. Last edited by: FP Mod Chuck,
 
Posts: 14 | Registered: July 11, 2019Reply With QuoteReport This Post
Virtuoso
posted Hide Post
It could have several reasons that may or may not be applicable (and I may forget some...)

Since we don't know your code...

1- Does your schedule is "Published" ?
2- Does AS and RC schedule are running with the same user ID ?
3- Why using foccache ? Is it possible that the schedule reuse an already existing foccache file ? The goal of using foccache is to avoid extracting the data again if the same file already exist.
Personally, I would remove the foccache and just use the memory
4- ...

I suspect that point -3- may be the reason.
Using foccache could be a good idea for interactive reports but may not be a good one using RC


WF versions : Prod 8.2.04M gen 33, Dev 8.2.04M gen 33, OS : Windows, DB : MSSQL, Outputs : HTML, Excel, PDF
In Focus since 2007
 
Posts: 2286 | Location: Montreal Area, Qc, CA | Registered: September 25, 2013Reply With QuoteReport This Post
Member
posted Hide Post
The code is probably at least 80 pages so I am hesitant to post it here.

1. I see no option to publish the schedule. All of the reports and schedules are in the My Contents.
2. I believe so but I do not know how to check this. When I click on the tasks in the report, it shows my User ID for the task. Is that what you mean by the RC User ID?
3. I am using foccache for the first 26 reports and the final report goes to memory. I am using foccache because I want the files to delete after they are used since they are only for processing up to the task that generates the file that goes to memory. I would note that I had all of the tasks writing to in memory before and I had the same issue.
4. Many of the hold files contain about a million records.
 
Posts: 14 | Registered: July 11, 2019Reply With QuoteReport This Post
Member
posted Hide Post
I seem to have been able to fix this by implementing two changes:

1) scheduling the reports to write to foccache and not memory

2) Decreasing the size of the hold files by adding a rolling 3 month lookback timeframe, which decreases my dataset by 1/4
 
Posts: 14 | Registered: July 11, 2019Reply With QuoteReport This Post
Master
posted Hide Post
You can always look at the log files of the schedule and see if any errors/warnings are showing up to help you debug. Just right-click on the schedule name and 'View Logs'


Hallway
WF(Prod):8202M1
WF(Test):8202M4
OS/Platform:Win 10
Outputs:All
 
Posts: 549 | Location: Salt Lake City, UT, USA | Registered: November 18, 2015Reply With QuoteReport This Post
Member
posted Hide Post
I have checked the logs and they always show no errors. I am finding that it works sometimes and does not work other times. The schedule worked yesterday but the reports did not run correctly today.
 
Posts: 14 | Registered: July 11, 2019Reply With QuoteReport This Post
Master
posted Hide Post
Can you see the schedule in the Report Caster Explorer? /ibi_apps/rcex.rc

Also, I don't see what version of WebFOCUS you're on in your signature. It would help to know this since IBI is so fragmented.


Hallway
WF(Prod):8202M1
WF(Test):8202M4
OS/Platform:Win 10
Outputs:All
 
Posts: 549 | Location: Salt Lake City, UT, USA | Registered: November 18, 2015Reply With QuoteReport This Post
Gold member
posted Hide Post
This type of error usually calls for traces. If you can run the schedule manually, with the traces option on, and get a bad output, then review the traces for the clues. With your AppStudio turned off, login to browser based WebFocus and run the schedule with traces on. Then pick thru the traces and see what you can find. You could also add a -SET &ECHO='ALL' on your first procedure, and all the sysprint will be in the caster log. Those are two choices for debugging this. Normally you don't want -SET ECHO='ALL' in caster because of the log size, but if you are debugging and stuck, it's a way to get some details where your report is going off the rails.


WebFocus 7x, 8x, Win / Linux, any output format
 
Posts: 53 | Location: reading, pa | Registered: April 07, 2007Reply With QuoteReport This Post
Member
posted Hide Post
Is there a way to export the log text? Also, I noticed that I get the below error sometimes:

Task error: IBFSException 32012: WebFOCUS Message[32012]: EDC_SRV_CONNLIMIT

Could this be related? I don't receive this error when it provides the incorrect results. This error shows when it completely fails and gives no results.
 
Posts: 14 | Registered: July 11, 2019Reply With QuoteReport This Post
Member
posted Hide Post
Jnc - when you say I need to add -Set &ECHO='ALL' on my first procedure. Since I have 27 tasks that are different reports, are you saying I need to update all 27 reports to state &ECHO='ALL'? I added it to the first procedure and saw some new error messages but the other 26 looked the same. This is making me think that I need to add &ECHO='ALL' to every report.
 
Posts: 14 | Registered: July 11, 2019Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Sam

You can right mouse on the schedule and choose view log to see it.

That message means there were no available active server agents when the schedule attempted to run and so it couldn't. That can be corrected by turning on queing on the DEFAULT data service on the reporting server. This configuration change requires a restart of the reporting server so it will have to be timed when the server can be down for a few minutes. Queing allows extra agents to be available as an overflow so you will not receive that message again.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 1790 | Location: Customer Support | Registered: April 12, 2005Reply With QuoteReport This Post
Member
posted Hide Post
I also noticed that the scheduler works if I schedule it to repeat 3 times. I receive errors the first two times and then it works.
 
Posts: 14 | Registered: July 11, 2019Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Sam

You shouldn't have to do that. The message is clear that there weren't any agents available. Set up the queing and your problem will go away.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
 
Posts: 1790 | Location: Customer Support | Registered: April 12, 2005Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED] Scheduled Report Only Works When Logged Into App Studio

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.