Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Save a graph as image and then display.
Go
New
Search
Notify
Tools
Reply
  
Save a graph as image and then display.
 Login/Join
 
Platinum Member
posted
Hello friends,

When I save a graph as GIF/JPEG and then try to display the same in html/excel, its is not displaying the image.(Saving is working fine). When i type the url for the image, it is displayed but opening as an applet. I doubt this is why it is not displayed when i call the image through fex.

FILEDEF G2 DISK E:\wwwroot\test\G2.GIF

GRAPH FILE TEST
SUM CNT.PROJECT AS PROJECT
ACROSS REGION
ON GRAPH SET LOOKGRAPH PIE
ON GRAPH SAVE AS G2 FORMAT GIF
END

TABLE FILE TEST
PRINT PROJECT
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
TYPE=REPORT, IMAGE=http://<SERVERNAME>/test/G2.GIF, POSITION=(4 0), SIZE=(5 3), $
ENDSTYLE
ON TABLE PCHOLD FORMAT HTML
END

-EXIT

I want the image to be displayed in the Html/Excel.
Please anyone let me know what mistake I am doing.
 
Posts: 143 | Location: Rochester,NY. | Registered: August 20, 2004Reply With QuoteReport This Post
<WFUser>
posted
Should work. What release are your running? Make sure you delete the gif and the first part of your request is actually running sucessfully.
 
Reply With QuoteReport This Post
Expert
posted Hide Post
Cyril, there's a thread #1055 above yours that addresses the same thing. "Adding Image to HTML report". Your syntax, with type=report, works for pdf output.
For web output, you define a text field
that is a long character string containing the URL of the image. Then put that text element whereever you want it in your report, making sure that your webserver (e.g. IIS) can find the image file.
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Reply With QuoteReport This Post
<WFUser>
posted
Susannah,

I wan't sure either, but I tested this code in 5.3 and it works in HTML.
 
Reply With QuoteReport This Post
Expert
posted Hide Post
ah! good to know
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Reply With QuoteReport This Post
Platinum Member
posted Hide Post
I am using WebFOCUS 521 Server. The image can be displayed well as the report output if i use an existing gif/jpeg/jpg image. For example using the following command.

TYPE=REPORT, IMAGE=http://<SERVERNAME>/test/logo.GIF, POSITION=(4 0), SIZE=(5 3), $

The problem comes only if i first save a graph file as an image and then try to display that image. The no-image icon will be displayed as the output. But when I right click on the icon and see the properties, it is showing the correct path.(If I use this path in browser, image will be displayed but opened as a java applet even after saving as jpeg or gif)
 
Posts: 143 | Location: Rochester,NY. | Registered: August 20, 2004Reply With QuoteReport This Post
Expert
posted Hide Post
Cyril, are you running in MRE or in self-serv?
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Reply With QuoteReport This Post
Platinum Member
posted Hide Post
I am not running in MRE. I have the WebFOCUS 521 Server and running the fex files using it. To be frank, I just not used that product yet.
 
Posts: 143 | Location: Rochester,NY. | Registered: August 20, 2004Reply With QuoteReport This Post
<Kalyan>
posted
Cyril ,
I have not tried what you are doing exactly. But I did create graphical reports. I also faced the problem of the graph loading as applet. Found that using
SET GRAPHEDIT =SERVER

solved the problem.

Dont know if this would help you..

Kalyan.
 
Reply With QuoteReport This Post
Platinum Member
posted Hide Post
No kalyan, the image is not getting displayed. Also the image is still opening as an applet.Below is the code I am using.

FILEDEF G2 DISK E:\wwwroot\user\G2.GIF

SET SQLENGINE=SQLORA
SQL SQLORA
SELECT * FROM &USER.TEST_GRAPH&DSN
;
TABLE FILE SQLOUT
PRINT *
ON TABLE HOLD AS T_GTEST FORMAT ALPHA
END
-RUN

SET GRAPHEDIT =SERVER

GRAPH FILE T_GTEST
SUM CNT.PROJECT AS PROJECT
ACROSS REGION
ON GRAPH SET LOOKGRAPH PIE
ON GRAPH SAVE AS G2 FORMAT GIF
END

TABLE FILE T_GTEST
PRINT PROJECT
ON TABLE SET HTMLCSS ON
ON TABLE SET STYLE *
TYPE=REPORT, IMAGE=http://server/user/G2.GIF, POSITION=(4 0), SIZE=(5 3), $
ENDSTYLE
ON TABLE PCHOLD FORMAT HTML
END

-EXIT
 
Posts: 143 | Location: Rochester,NY. | Registered: August 20, 2004Reply With QuoteReport This Post
Virtuoso
posted Hide Post
Did this ever get resolved? I'm having the same problem...5.3.2 Developer Studio.
 
Posts: 1903 | Location: San Antonio | Registered: February 28, 2005Reply With QuoteReport This Post
<Thiru>
posted
Check with the access permissions on that folder in the server. The folder where you save the GIF files should have the RW access and should be in the application path.
 
Reply With QuoteReport This Post
<mbroxter>
posted
I experienced this same issue in 5.2.3 a few months ago with self-service reports. The problem ended up being that Java WebStart was locking up on the Reporting Server, thus the image was not being created nor was an error being returned. The HTML reports were also showing the correct path, but an empty image.

If you have access to the Reporting Server, start Java Webstart from the desktop to see if it starts OK. My problem ended up being that Java and the video card had a conflict.
 
Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Save a graph as image and then display.

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.