Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Problems with Report Caster API after migration from 7.1.x to 7.6.11
Go
New
Search
Notify
Tools
Reply
  
[SOLVED] Problems with Report Caster API after migration from 7.1.x to 7.6.11
 Login/Join
 
Member
posted
Hi Guys,

We recently migrated our servers from WF 7.1.4 to 7.6.11. However after migrations, our front end application using report caster API stopped working. application logger showed, it hung on connecting to report caster server.

I know there has been a change of report caster libraries from 7.1.x version, so I included the new libraries (all the 3) and re-compiled the application. After re-compilation, it no-longer hangs connection but throws the error unable to connect to distribution server, make sure its running.
The application is using CasterManagedConnectionFactory() and I've compared the documentation, there has been no change in the function definition or usage coming from 7.1.x

I checked RC configuration and ports and they are fine because when I do
telnet RCHOST RCPORT
I get the standard ¼φ so that means RC config is OK

Any ideas what might be causing the app not to connect, especially since its running fine on 714?

This message has been edited. Last edited by: Kerry,


Developer Studio 7.6.11
Windows
Output Format: HTML, Excel, PDF
 
Posts: 5 | Registered: May 02, 2008Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Can you log into ReportCaster outside of the API calls?

In 714, if ReportCaster couldn't connect to the database it wouldn't start at all.

In 7611, it will start in "Console Only Mode". As a result there will be a listener, but it won't fully be running.

If I remember correctly the API error codes for the distribution server being in console only mode are not very descriptive, and simply make it sound like the distribution server is down.

Assuming that ReportCaster is working properly outside of the API calls, I'd start by getting ReportCaster Servlet and Distribution Server traces and see if there is anything useful within them.


WF 71.x, 76.x, 7701, 8.0 Beta OS: Linux, Win2k3, Win2k, Win2k8, WinXP


 
Posts: 203 | Registered: November 19, 2007Reply With QuoteReport This Post
Member
posted Hide Post
^Thanks for the reply..
Well yes, I certainly can login reportcaster from Dashboard link.

I looked at ReportCaster logs and server traces found nothing useful there. There is some activity in console trace, but I couldn't relate it to any use.

However my local tomcat (on which the application is deployed) shows this error in tomcat window.
quote:

Unable to establish connection to ReportCaster repository. Contact your ReportCaster Administrator. WebFocus Server EDAUNIX Initialization Error (java.lang.ClassNotFoundException: ibi.jlink.EdaDriver)


I worked with RC admin, but he couldn't find any problems on server. Could it be the whats causing all this and where do it start fixing it?


Developer Studio 7.6.11
Windows
Output Format: HTML, Excel, PDF
 
Posts: 5 | Registered: May 02, 2008Reply With QuoteReport This Post
Platinum Member
posted Hide Post
That looks like its missing the jlink.jar file in the classpath. Can you add:

\ibi\WebFOCUS76\webapps\webfocus76\WEB-INF\lib\jlink.jar

To the classpath of your API program?


WF 71.x, 76.x, 7701, 8.0 Beta OS: Linux, Win2k3, Win2k, Win2k8, WinXP


 
Posts: 203 | Registered: November 19, 2007Reply With QuoteReport This Post
Guru
posted Hide Post
quote:
jlink.jar


This Jar FILE will be missing in your classpath, or the classpath ref for this JAR file will be wrong or missing.

Or might be, the properties has to be changed somewhere in server configurations.


Thanks,

Ramkumar.
WebFOCUS/Tableau
Webfocus 8 / 7.7.02
Unix, Windows
HTML/PDF/EXCEL/AHTML/XML/HTML5
 
Posts: 394 | Location: Chennai | Registered: December 02, 2009Reply With QuoteReport This Post
Member
posted Hide Post
^^Thanks guys, it worked...

Sorry for updating it this late...tied in too many things thesedays Frowner


Developer Studio 7.6.11
Windows
Output Format: HTML, Excel, PDF
 
Posts: 5 | Registered: May 02, 2008Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SOLVED] Problems with Report Caster API after migration from 7.1.x to 7.6.11

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.