Focal Point
[SOLVED] DSTRUN gives Servlet Execution Error

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/9381026691

November 15, 2006, 09:23 AM
Anatess
[SOLVED] DSTRUN gives Servlet Execution Error
Hello all -
I am trying to run a ReportCaster job from a fex using DSTRUN (version 7.1.3). I follow all the instructions in the manual http://documentation.informationbuilders.com/masterinde...capiweb8.htm#1034899 but I am getting error code 11 which translates to Servlet Execution Error. The job runs just fine if run from ReportCaster. The execution ID and password have been verified to work. Can anybody tell me what would cause a Servlet Execution Error?

-Anatess

This message has been edited. Last edited by: Kerry,
November 15, 2006, 01:35 PM
N.Selph
I found that it has to be run under an id that is both a valid Unix id AND a report caster id. This makes no sense, but it needs to be that way.


(Prod: WebFOCUS 7.7.03: Win 2008 & AIX hub/Servlet Mode; sub: AS/400 JDE; mostly Self Serve; DBs: Oracle, JDE, SQLServer; various output formats)
November 21, 2006, 06:17 PM
Anatess
That was it! We're using Win2003 but, you're right, the execution ID has to be an MRE ID in addition to being a Win2003 logon. We use active directory for logon authentication, so our Admin was scratching his head wondering how to get that ID/password synched with MRE. But, what we found out is that as long as the id is defined to MRE, the password doesn't have to be valid (doesn't really log on to MRE). So, now it is working. Thank you very much for your help!


WF 8.1.05 Windows
October 15, 2010, 10:56 AM
BalaMurugan
My unix id,report caster id and MRE id are all same, but still i am getting Servlet Execution Error on executing DSTRUN. Can any body plz help on this.

WebFOCUS 7.6.4


WebFOCUS 7.6
Windows, All Outputs
October 22, 2010, 08:56 PM
Brian Suter
Since this marked SOLVED in 2006, people are not looking at this thread. You should open a new one - or better yet - a case with techsupport!


Brian Suter
VP WebFOCUS Product Development