Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]Output filename is not populating, when report executes from HTML Ad Hoc page
Go
New
Search
Notify
Tools
Reply
  
[CLOSED]Output filename is not populating, when report executes from HTML Ad Hoc page
 Login/Join
 
Member
posted
Hi All,

I am facing a weird issue with output filename for EXL2K format report. By default, EXL2K report generates with a temporary filename (like: abcdef.xls). I have to change this temporary filename with another string (like: car_sale.xls).

To achieve this, I have used below line in my code.
 ON TABLE PCHOLD AS 'car_sale' FORMAT EXL2K  


The above code is working fine, when I execute report via App Studio tool (WebFocus ver 8.105M), but it does not work, when I execute report from a HTML Ad Hoc web page.

Please suggests, what changes should i made in my code.

Thanks in advance.


Regards,
Sandy

This message has been edited. Last edited by: FP Mod Chuck,


WebFOCUS 7.6
Windows, All Outputs
 
Posts: 25 | Registered: September 15, 2014Reply With QuoteReport This Post
Virtuoso
posted Hide Post
I don't have 8.1 anymore but in 8.201 this generates CAR_SALE_20171027_071327.xls.

Have you tried format EXL07?


WebFOCUS 8206, Unix, Windows
 
Posts: 1818 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Same with 8.1.05 (Gen 939):
car_sales_20171027_020007.xls

TABLE FILE CAR
PRINT *
ON TABLE PCHOLD AS 'car_sales' FORMAT EXL2K
END


Regards. Mikel.


WebFOCUS 8.1.05, 8.2.01
 
Posts: 173 | Location: Madrid, Spain | Registered: May 09, 2003Reply With QuoteReport This Post
Virtuoso
posted Hide Post
quote:
code is working fine, when I execute report via App Studio tool (WebFocus ver 8.105M), but it does not work, when I execute report from a HTML Ad Hoc web page.



Could you describe what isn't working?


WebFOCUS 8206, Unix, Windows
 
Posts: 1818 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Master
posted Hide Post
Sandy,

This may have to do with your redirection settings in your configuration console. Can let us know how excel files are configured?


Eric Woerle
8.1.05M Gen 913- Reporting Server Unix
8.1.05 Client Unix
Oracle 11.2.0.2
 
Posts: 750 | Location: Warrenville, IL | Registered: January 08, 2013Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]Output filename is not populating, when report executes from HTML Ad Hoc page

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.