Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]Any setting to prevent E01 etc fields from being created in MS SQL tables
Go
New
Search
Notify
Tools
Reply
  
[CLOSED]Any setting to prevent E01 etc fields from being created in MS SQL tables
 Login/Join
 
Silver Member
posted
Hello Everybody!!

I apologize for my ignornance on this. but..

Is there a setting which, when creating a MS SQL table thru on ON TABLE HOLD request, causes the field so be the PRINTd fieldname..vs E01, E02 etc.

For example..

TABLE FILE HOLDLW
PRINT
WEEK
RPTORG

creates..
FIELDNAME=WEEK, ALIAS=E03, USAGE=A2V, ACTUAL=A2V, MISSING=ON, TITLE='WEEK', $
FIELDNAME=RPTORG, ALIAS=E04, USAGE=I7, ACTUAL=I4, MISSING=ON, TITLE='RPTORG', $



PRINT
WEEK AS 'WEEK'
RPTORG AS 'RPTORG'

creates..
FIELDNAME=WEEK, ALIAS=WEEK, USAGE=A2V, ACTUAL=A2V, MISSING=ON, TITLE='WEEK', $
FIELDNAME=RPTORG, ALIAS=RPTORG, USAGE=I7, ACTUAL=I4, MISSING=ON, TITLE='RPTORG', $


Please notice the difference between E03/E04 AND WEEK/RPTORG.

I tried SET ASNAMES = ON..but that did not help.


Thanks in advance for any insights.

Wm

This message has been edited. Last edited by: <Emily McAllister>,


WebFOCUS 8
Windows, All Outputs
 
Posts: 30 | Location: Living in Charlotte, working all over | Registered: July 13, 2015Reply With QuoteReport This Post
Virtuoso
posted Hide Post
I think your HOLDLW.MAS has E01, E02 as ALIAS and that's causing ALIAS= E0xxx. ON TABLE HOLD FORMAT MSSQL uses the ALIAS in the original table to create your SQL table.

Try adding this to your TABLE request:

ON TABLE SET EXTRACT ON

I saw something in doc about this but I couldn't figure out how it should behave.

This message has been edited. Last edited by: BabakNYC,


WebFOCUS 8206, Unix, Windows
 
Posts: 1677 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Silver Member
posted Hide Post
Babak..You are correct.

FOCLIST E01
YEAR E02
WEEK E03
RPTORG E04


Is there a setting to create the ALIAS as the real field name?

wm


WebFOCUS 8
Windows, All Outputs
 
Posts: 30 | Location: Living in Charlotte, working all over | Registered: July 13, 2015Reply With QuoteReport This Post
Virtuoso
posted Hide Post
I don't know of any setting but something I posted above seems promising. Try adding ON TABLE SET EXTRACT ON to the TABLE request that creates the HOLDLW file. I tried it and though I'm not sure it's what we really want, the side effect was that it created the hold file without the E01. Search Doc for EXTRACT ON and see if the example helps explain it.

The alternative is for you to create the master file for the sql server table and then MODIFY FILE SQLSERVER_TABLENAME FIXFORM FROM HOLD but that could be a lot more coding.


WebFOCUS 8206, Unix, Windows
 
Posts: 1677 | Location: New York City | Registered: December 30, 2015Reply With QuoteReport This Post
Master
posted Hide Post
Can you explain why the auto-generated aliases Exx is a problem for you?


WebFOCUS 7.7.05 Windows, Linux, DB2, IBM Lotus Notes, Firebird, Lotus Symphony/OpenOffice. Outputs PDF, Excel 2007 (for OpenOffice integration), WP
 
Posts: 674 | Location: Guelph, Ontario, Canada ... In Focus since 1985 | Registered: September 28, 2010Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]Any setting to prevent E01 etc fields from being created in MS SQL tables

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.