Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Trouble opening Maintain Forms

Read-Only Read-Only Topic
Go
Search
Notify
Tools
Trouble opening Maintain Forms
 Login/Join
 
Platinum Member
posted
Hi,

I'm having trouble opening up Maintain forms in a 5.3.6 MDE. They were originally developed on a 5.3.3 Dev Studio, but 5.3.6 was the closest I could find.

I recieved a set of maintain files (.mas, .mnt, .wfm, .fcm, etc.) and need to modify and extend the code and forms. I setup a new project, copied the files into the new ibi/apps/xxx directory, and added the files to the project. The application runs locally, and I can open the maintain code.

But the problem is that when I attempt to open a form, or display it's object tree, I get a dialog box saying:

" There is a reference to winform "formname" in the "Mntname". Would you like to create a new winform "formname". Press "No" to go to the reference"

If I click "No" MDE crashes !

I have looked at the formname.wfm file in notepad and it looks OK compared to another form that I created. I can open and edit the form I created in this project, but not the ones that came from outside.

Anyone have a clue as to what is wrong or how I can fix it ?

TIA,
Dave Ayers

Dev Studio 5.3.6
Report Server 5.3.6
OS Win 2000 Server
 
Posts: 165 | Location: Detroit Metro | Registered: September 17, 2003Report This Post
Expert
posted Hide Post
Hi Dave,

The MNT file that you are trying to open in the MDE is a file that has already been deployed. When you are developing a Maintain application, the MNT file contains both the MAINTAIN code and the Winforms. The Winforms are stored as XML after the END statement. When an MNT file is deployed, the XML is striped out and create the Winforms file. The issue is, you cannot bring that deployed MNT file back into the MDE to edit the forms. You need to have the originally developed MNT file in order to edit the forms.

Hope this helps. Smiler

Cheers,

Kerry


Kerry Zhan
Focal Point Moderator
Information Builders, Inc.
 
Posts: 1948 | Location: New York | Registered: November 16, 2004Report This Post
Platinum Member
posted Hide Post
Kerry,

Thanks. I went back and found another set of files that hadn't been remotely deployed, and was able to access the Forms.

Too bad the code isn't more portable, but at least I am working now.

Thanks to you and IBI tech support,


Regards,
Dave

http://www.daveayers.com

WebFocus/Maintain 7.6.4-8
on Win2000 and 2003 Server
 
Posts: 165 | Location: Detroit Metro | Registered: September 17, 2003Report This Post
Platinum Member
posted Hide Post
I ran into another problem with the second set of Maintain files.

After the original problem of not being able to open the Forms Editor, with maintain files that were source, rather then deployed, I could open Forms, make changes, and save them, but when I complied and ran them, none of my form changes showed up ! Very frustrating...

After much grief I discovered that there was one set of .mnt and .wfm file but without a .fcm. After I removed it from the project I was able to compile and run and see the form changes - back to normal !

The compile step ran a lot longer, because it was actully compiling for a change Smiler

The problematic maintain file was named 'MasterForm' - two WebFocus keywords in the filename !!

"Danger, danger Will Robinson"
A word to the wise - look out for Focus and Maintain keywords in your maintain file names.


Regards,
Dave

http://www.daveayers.com

WebFocus/Maintain 7.6.4-8
on Win2000 and 2003 Server
 
Posts: 165 | Location: Detroit Metro | Registered: September 17, 2003Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Trouble opening Maintain Forms

Copyright © 1996-2020 Information Builders