Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Annoying Dev Studio behaviour, numbers 27 and 28...
Go
New
Search
Notify
Tools
Reply
  
Annoying Dev Studio behaviour, numbers 27 and 28...
 Login/Join
 
Expert
posted
Number 27:

Why, when looking at fexes in an MRE domain APP folder, the "Type" column is my favourite text editor (EditPlus), but I can't open a fex in EditPlus?

Number 28:

Why do blank lines in an MRE fex always get deleted when the file is closed and reopened? I learnt to give programming code breathing room by entering blank lines - obviously to make a program easier to read. This only happens in an MRE fex.

Annoying. It would be wonderful if these two issues have been corrected in newer releases.

Don't get me going about the first 26 issues...


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
oh now you have us intrigued. What are the first marathon's worth?




In Focus since 1979///7706m/5 ;wintel 2008/64;OAM security; Oracle db, ///MRE/BID
 
Posts: 3811 | Location: Manhattan | Registered: October 28, 2003Reply With QuoteReport This Post
Master
posted Hide Post
Fran

The blank line problem in MRE is caused by the Analytical reporter writing out its internal representation of the code in a standard format.

If you edit the MRE fexes from dev studio the blank lines will be retained until you do an edit in the Analytical Reporter and then save.

John

Susannah

I'm guessing Francis' "26th complaint about MRE" is a bit figurative like Mick Jagger's "19th Nervous Breakdown"

John



Server: WF 7.6.2 ( BID/Rcaster) Platform: W2003Server/IIS6/Tomcat/SQL Server repository Adapters: SQL Server 2000/Oracle 9.2
Desktop: Dev Studio 765/XP/Office 2003 Applications: IFS/Jobscope/Maximo
 
Posts: 888 | Location: Airstrip One | Registered: October 06, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
John, I don't open the fex in Analytical Reporter.

If I open the MRE fex in a text editor, the fex has blank lines:



When I open the MRE fex in Dev Studio text editor - no blank lines:



Once I make changes to the fex in Dev Studio text editor and save it, the blank lines disappear.

And you're right about my 26 other complaints - they're figurative. But I could come up with them, if pressed Smiler


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Platinum Member
posted Hide Post
quote:
Originally posted by Francis Mariani:
Number 28:

Why do blank lines in an MRE fex always get deleted when the file is closed and reopened? I learnt to give programming code breathing room by entering blank lines - obviously to make a program easier to read. This only happens in an MRE fex.


I know what you mean about this one. It's rather irritating because I do the same thing in order to provide visual separation.
Best thing I've found is to use a blank comment line.

-*

It ends up leaving a blank line and they won't get removed...



Production: 7.6.6 WF Server  <=>  7.6.6 WF Client  <=>  7.6.6 Dev Studio
Testing: <none>
Using MRE & BID.  Connected to MS SQL Server 2005
Output Types: HTML, Excel, PDF
 
Posts: 230 | Location: Wichita, KS | Registered: May 27, 2005Reply With QuoteReport This Post
Master
posted Hide Post
Lordy!

He's right. Just edited a file in dev studio in the application area, copied it to and saved it under a Domain after making a small change, and, yes, it does nosh the blank lines!


John



Server: WF 7.6.2 ( BID/Rcaster) Platform: W2003Server/IIS6/Tomcat/SQL Server repository Adapters: SQL Server 2000/Oracle 9.2
Desktop: Dev Studio 765/XP/Office 2003 Applications: IFS/Jobscope/Maximo
 
Posts: 888 | Location: Airstrip One | Registered: October 06, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
I never understood why there should be a difference between editing a fex in the app folders and editing one in the MRE folders.

I've also never bought any of the explanations I may have been given.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Platinum Member
posted Hide Post
I too have this habit of having good delineation between various sections of code for easier read-thru later.
Used to do this with spaces a while back, but we had run into some bug in the older versions of the MRE, where in blank lines started causing random crashes of the execution agent. Since then we have made it our standard to use various flavors of -* for demarking various sections instead of spaces.

-*-*-*-*-*-*-*-*-
-*--------------
-*>>>>>>>>>>>>>>>>>>
and so on, based on my creative instincts on that given day....

Smiler
Sandeep Mamidenna


-------------------------------------------------------------------------------------------------
Blue Cross & Blue Shield of MS
WF.76-10 on (WS2003 + WebSphere) / EDA on z/OS + DB2 + MS-SQL
MRE, BID, Dev. Studio, Self-Service apps & a dash of fun !! Music
 
Posts: 218 | Location: Jackson, MS | Registered: October 31, 2006Reply With QuoteReport This Post
Platinum Member
posted Hide Post
I want to know what 1-26 are. Smiler

Share the love, we are an EAO (equal annoyment opportunity) community. Big Grin



Production: 7.6.6 WF Server  <=>  7.6.6 WF Client  <=>  7.6.6 Dev Studio
Testing: <none>
Using MRE & BID.  Connected to MS SQL Server 2005
Output Types: HTML, Excel, PDF
 
Posts: 230 | Location: Wichita, KS | Registered: May 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
Number 1 has to be Dev Studio crashing seemingly without just cause.

Blood temp is raised when this happens. Mad



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.06 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5610 | Location: United Kingdom | Registered: April 08, 2004Reply With QuoteReport This Post
Platinum Member
posted Hide Post
Shutdowns are fairly annoying...

I find two things in particular bother me about dev studio..

1. Backspace not working when holding down the shift key...
2. When opening an fex it doesnt check to see if the fex is already open....just opens another copy...making all sorts of problems later!! Lost more then my share of work as a WebFocus rookie...


WebFOCUS 8201M/Windows Platform
 
Posts: 109 | Registered: October 31, 2006Reply With QuoteReport This Post
Virtuoso
posted Hide Post
gweller's #2 is high up there on my list also. At least it could pop up a warning saying that that procedure is already open for editing, continue?
Also on my list:
not being able to multi-select fields from field tree/list
inability to edit (or do anything) with objects in "Other" folder on Data Server application folder
Can't rename files (change extension) on Data Servers
Intermittent problem where DS loses the ability to edit a procedure - especially when several are open. When you right click the only thing available is copy/delete/rename,etc. GRRR! basically have to shut it down and restart it.

Is the list getting long enough?


Regards,

Darin



In FOCUS since 1991
WF Server: 7.7.04 on Linux and Z/OS, ReportCaster, Self-Service, MRE, Java, Flex
Data: DB2/UDB, Adabas, SQL Server Output: HTML,PDF,EXL2K/07, PS, AHTML, Flex
WF Client: 77 on Linux w/Tomcat
 
Posts: 2298 | Location: Salt Lake City, Utah | Registered: February 02, 2007Reply With QuoteReport This Post
Expert
posted Hide Post
gweller,

If you open your fex under a project folder DS behaves as you have suggested, e.g. it will focus on the already open version.

T



In FOCUS
since 1986
WebFOCUS Server 8.2.01M, thru 8.2.06 on Windows Svr 2008 R2  
WebFOCUS App Studio 8.2.06 standalone on Windows 10 
 
Posts: 5610 | Location: United Kingdom | Registered: April 08, 2004Reply With QuoteReport This Post
Expert
posted Hide Post
Open a fex in Dev Studio via "Edit in Text Editor"

Make a change.

Press Ctrl-S to save the file.

Press Ctrl-Z to undo the change.

Press Ctrl-S to save the file with the undone change - nothing happens, the latest change doesn't save. Closing the files doesn't save the latest change either.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Expert
posted Hide Post
The scariest one. This has happened to me on two different installations where the server is AS400. Open several different fexes via the Windows Registered Tool as set up in the Dev Studio Options "Default file editor". In my case it's EditPlus. The action of choosing to open in EditPlus makes Dev Studio copy the fexes into the Windows Temp Directory and then open them in EditPlus. After making changes in all the fexes, I pressed the Save All button in EditPlus. One would assume that each of the files in the Temp Directory get saved on the Windows machine and then get copied back to the AS400. What happened to me several times is that they do get saved in the Temp Directory correctly, but when copied back to the AS400, all the files have the same code in them - either from the first or the last fex!!! Needless to say, this is alarming!

My gripes are with DevStudio v5.3.2. I'm sure the new versions are a lot better.


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Platinum Member
posted Hide Post
quote:
Originally posted by gweller:
Shutdowns are fairly annoying...

I find two things in particular bother me about dev studio..

1. Backspace not working when holding down the shift key...
2. When opening an fex it doesnt check to see if the fex is already open....just opens another copy...making all sorts of problems later!! Lost more then my share of work as a WebFocus rookie...


haha, I actually logged #1 as a case. Glad to see I wasn't the only one annoyed by that. If you haven't logged it, I would encourage you to do so. Smiler

Believe it or not, I've actually been saved by #2 on a couple of occasions. i.e. I've had a bunch of changes made but wasn't ready to save and needed to see what the original looked like -- so I open another copy. But I agree that it causes more grief than it saves. At the very least, a prompt telling you that you already have it open and asking for confirmation to open another copy would be nice.


Also, for what it's worth, stability seems to be improving. I get a lot less crashes in 7.1.4 than I did in previous versions. In fact, I often go several days w/o one. Smiler



Production: 7.6.6 WF Server  <=>  7.6.6 WF Client  <=>  7.6.6 Dev Studio
Testing: <none>
Using MRE & BID.  Connected to MS SQL Server 2005
Output Types: HTML, Excel, PDF
 
Posts: 230 | Location: Wichita, KS | Registered: May 27, 2005Reply With QuoteReport This Post
Guru
posted Hide Post
I lost a huge javascript today so I'm looking for an annoyment opportunity outlet and remembered Francis posting 28 of them...
so, I'm going to add my gripe on this thread even if it isn't on Dev Studio but on Maintain Dev Environment.
Okay, so on MDE, I copy a form (right click the form on Project Explorer and opt copy form), so it created form_copy1. So, I rename form_copy1 to an appropriate name, then deleted the embedded javascript because I didn't need it on that form. Nothing happens, so I delete it again... now it's gone. So, I save everything and test it and the original form is not working right. So, I open the form on MDE and find out... THE JS IS GONE! I was going crazy looking for it, finally I did an experiment and found out that when you copy a form and delete the js from the copy, it deletes it off of the original instead of the copy! What else I found out, if you open a js from project explorer without opening the form, it opens some other random component. (So, that's why I thought I changed a js just to find out I made the change in a completely different js - I don't always look at the name of the component on the title bar). Okay, I'm going to take some Midol now...

WF 714.


WF 8.1.05 Windows
 
Posts: 332 | Location: Orlando, FL | Registered: October 17, 2006Reply With QuoteReport This Post
Expert
posted Hide Post
Y!I!K!E!S!


Francis


Give me code, or give me retirement. In FOCUS since 1991

Production: WF 7.7.05M, Dev Studio, BID, MRE, WebSphere, DB2 / Test: WF 8.1.05M, App Studio, BI Portal, Report Caster, jQuery, HighCharts, Apache Tomcat, MS SQL Server
 
Posts: 10577 | Location: Toronto, Ontario, Canada | Registered: April 27, 2005Reply With QuoteReport This Post
Master
posted Hide Post
Anatess
There have been times when developing in the MDE that I thought I was deleting one object and wound up deleting code or triggers or even once a form. I certainly don't mean to blame the victim, but you do have to be careful of what object has control before you hit delete.

Mark
 
Posts: 660 | Location: New York | Registered: May 08, 2003Reply With QuoteReport This Post
Gold member
posted Hide Post
Here's another one on DS that happened to us at least three times I know of. We have a large Focexec, in the area of 4000+ lines. When we were developing it, saving the Focexec would only save part of the the Focexec, and just wipe out the rest! Quickly got into the habit of doing daily backups (other than system backups - since that recover involves getting Infrastructure involved).

Hopefully someone at IBI will take this entire list and send them to Programming


Diptesh
WF 7.1.7 - AIX, MVS
 
Posts: 79 | Location: Warren, NJ, USA | Registered: October 25, 2006Reply With QuoteReport This Post
Master
posted Hide Post
Diptesh

We had sim with large focexec and had to divide it into many includes. (This again is a pain because logic to control the execution of the includes with error checking requires a re-write).

An inherent problem for Dev Studio is that it is written in C++. With its pointers and null terminated strings, C++ is one of the most error prone languages ever invented.

One step forward would be for IB to turn some of the debug code on at expense of speed so that some of these problems can be tracked down, since I think the cost of a re-write in a decent programming language is probably prohibitive!



Server: WF 7.6.2 ( BID/Rcaster) Platform: W2003Server/IIS6/Tomcat/SQL Server repository Adapters: SQL Server 2000/Oracle 9.2
Desktop: Dev Studio 765/XP/Office 2003 Applications: IFS/Jobscope/Maximo
 
Posts: 888 | Location: Airstrip One | Registered: October 06, 2006Reply With QuoteReport This Post
Master
posted Hide Post
I'll be glad to add 2 of my pet peves.

I have a problem report open on this this first one.

Sometime in the 5. releases, someone at IBI thought it would be an good idea to ALWAYS open a fex with the Physical View, Logical View and Text View, no matter what was selected (Edit in Text Editor, Edit in Developer Studio Tool, etc.). Well if you have a fex of any size, it takes forever to open, while it builds those graphical views. I have asked for them to change it back to at least when one selects Text Editor, to only open the text editor view. Until then I use UltraEdit to edit any fex larger than a 1000 lines.

My second pet peve is the External Tools tab under Window/Options. I've listed UltraEdit there. Now on the General tab, I select the default editor as Windows Registered Tool, which is UltraEdit and it totally ignores that and uses the WF default editor anyway.


In FOCUS since 1985. Prod WF 8.0.08 (z90/Suse Linux) DB (Oracle 11g), Self Serv, Report Caster, WebServer Intel/Linux.
 
Posts: 934 | Location: Oklahoma City | Registered: October 27, 2006Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Annoying Dev Studio behaviour, numbers 27 and 28...

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.