Focal Point Banner
Community Center Education Summit Technical Support User Groups
Let's Get Social!

Facebook Twitter LinkedIn YouTube
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CASE_OPENED] Dynamic Prompt behavior different in WF8 from WF7.7.03
Go
New
Search
Notify
Tools
Reply
  
[CASE_OPENED] Dynamic Prompt behavior different in WF8 from WF7.7.03
 Login/Join
 
Master
posted
I have moved over a series of reports from my WF7703 environment that were made by my users using infoassist to WF8.0.08. I've noticed that the prompting works differently between the two versions. The syntax is the same
 '&variable.(FIND return_fieldname [,display_fieldname] IN datasource).[description.]' 


But in WF7, the prompt will return the distinct records where in WF8 it is returning all of the records as if its doing a Print instead of a SUM/BY. Is there a setting or parameter that needs to be adjusted in the WF8 to have the same functionality as in WF7?

Thanks!

This message has been edited. Last edited by: eric.woerle,


Eric Woerle
8.1.05M Gen 913- Reporting Server Unix
8.1.05 Client Unix
Oracle 11.2.0.2
 
Posts: 750 | Location: Warrenville, IL | Registered: January 08, 2013Reply With QuoteReport This Post
Master
posted Hide Post
I've done some more digging on this. It appears that in WF 8, the change has been made that if you only supply the [return_fieldname] it will issue a print verb, but when you add the [display_fieldname] WF will issue the SUM verb. In WF7 it was always the SUM verb that was issued. Now as a developer I can handle this because I know how to code it, and I use HTML pages and reference procedures for all of my reporting. Unfortunately, my users that utilize InfoAssist can't do this. InfoAssist does not provide the ability to select both the return_fieldname and the display_fieldname. What makes it worse, when you update the code with the display_fieldname, IA no longer recognizes the code and errors out when trying to open the fex for editing.

Is anyone aware of any SET command or configuration that would allow for me to revert that functionality back to WF7? So the prompt command always issues a SUM verb?


Eric Woerle
8.1.05M Gen 913- Reporting Server Unix
8.1.05 Client Unix
Oracle 11.2.0.2
 
Posts: 750 | Location: Warrenville, IL | Registered: January 08, 2013Reply With QuoteReport This Post
  Powered by Social Strata  
 

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CASE_OPENED] Dynamic Prompt behavior different in WF8 from WF7.7.03

Copyright © 1996-2018 Information Builders, leaders in enterprise business intelligence.