Focal Point
[SHARING] Any upgrade issues to WF7.7.05

This topic can be found at:
http://forums.informationbuilders.com/eve/forums/a/tpc/f/7971057331/m/9927044766

February 21, 2014, 03:02 PM
BobSh
[SHARING] Any upgrade issues to WF7.7.05
We are upgrading from WF 7.7.03 to 7.7.05. I was wondering if anyone discovered any issues caused by the upgrade or changes required in programs. Thanks for your feedback!

This message has been edited. Last edited by: <Kathryn Henning>,


WebFOCUS 7.7.05M, gen 144, Windows 2008 Server R2 64-bit, Tomcat 6.0.33, IIS 7.0, SQL Server, Excel 2013, PDF, HTML, FOCUS files.
February 24, 2014, 05:07 AM
Ian Dalton
Hi BobSh,
Yes we had a few issues with EMPTYREPORTs.
Now the following code causes the agent to crash in 7.7.05 whereas it was OK in 7.7.03. The error we get is ....
This report is invalid because the data retrieval has been canceled or the job has been stopped.
-* this is the code......
SET EMPTYREPORT=OFF (this is the default anyway)
TABLE FILE CAR
PRINT COUNTRY CAR MODEL
IF CAR EQ 'XXX'
ON TABLE PCHOLD FORMAT HTML
END
HOLD AS FRED FORMAT HTML
-*
Therefore you may need to explicitly
SET EMPTYREPORT=ON
-*
Regards,
Ian


_______________________
*** WebFOCUS 8.1.05M ***
February 24, 2014, 09:42 AM
BobSh
Thanks Ian, that's good to know in advance. If a program does not explicitly have SET EMPTYREPORT = OFF does it give the error or just when it is actually specified in the program?


WebFOCUS 7.7.05M, gen 144, Windows 2008 Server R2 64-bit, Tomcat 6.0.33, IIS 7.0, SQL Server, Excel 2013, PDF, HTML, FOCUS files.
February 24, 2014, 11:30 AM
Ian Dalton
Errors in both scenarios - they have definitely tightened up things relating to Empty Reports.
Ian


_______________________
*** WebFOCUS 8.1.05M ***
February 24, 2014, 11:57 AM
BobSh
OK, thanks Ian.


WebFOCUS 7.7.05M, gen 144, Windows 2008 Server R2 64-bit, Tomcat 6.0.33, IIS 7.0, SQL Server, Excel 2013, PDF, HTML, FOCUS files.