Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SHARING] Any upgrade issues to WF7.7.05

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[SHARING] Any upgrade issues to WF7.7.05
 Login/Join
 
Gold member
posted
We are upgrading from WF 7.7.03 to 7.7.05. I was wondering if anyone discovered any issues caused by the upgrade or changes required in programs. Thanks for your feedback!

This message has been edited. Last edited by: <Kathryn Henning>,


WebFOCUS 7.7.05M, gen 144, Windows 2008 Server R2 64-bit, Tomcat 6.0.33, IIS 7.0, SQL Server, Excel 2013, PDF, HTML, FOCUS files.
 
Posts: 88 | Location: Seattle | Registered: March 29, 2007Report This Post
Platinum Member
posted Hide Post
Hi BobSh,
Yes we had a few issues with EMPTYREPORTs.
Now the following code causes the agent to crash in 7.7.05 whereas it was OK in 7.7.03. The error we get is ....
This report is invalid because the data retrieval has been canceled or the job has been stopped.
-* this is the code......
SET EMPTYREPORT=OFF (this is the default anyway)
TABLE FILE CAR
PRINT COUNTRY CAR MODEL
IF CAR EQ 'XXX'
ON TABLE PCHOLD FORMAT HTML
END
HOLD AS FRED FORMAT HTML
-*
Therefore you may need to explicitly
SET EMPTYREPORT=ON
-*
Regards,
Ian


_______________________
*** WebFOCUS 8.1.05M ***
 
Posts: 196 | Location: London, UK | Registered: December 06, 2005Report This Post
Gold member
posted Hide Post
Thanks Ian, that's good to know in advance. If a program does not explicitly have SET EMPTYREPORT = OFF does it give the error or just when it is actually specified in the program?


WebFOCUS 7.7.05M, gen 144, Windows 2008 Server R2 64-bit, Tomcat 6.0.33, IIS 7.0, SQL Server, Excel 2013, PDF, HTML, FOCUS files.
 
Posts: 88 | Location: Seattle | Registered: March 29, 2007Report This Post
Platinum Member
posted Hide Post
Errors in both scenarios - they have definitely tightened up things relating to Empty Reports.
Ian


_______________________
*** WebFOCUS 8.1.05M ***
 
Posts: 196 | Location: London, UK | Registered: December 06, 2005Report This Post
Gold member
posted Hide Post
OK, thanks Ian.


WebFOCUS 7.7.05M, gen 144, Windows 2008 Server R2 64-bit, Tomcat 6.0.33, IIS 7.0, SQL Server, Excel 2013, PDF, HTML, FOCUS files.
 
Posts: 88 | Location: Seattle | Registered: March 29, 2007Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [SHARING] Any upgrade issues to WF7.7.05

Copyright © 1996-2020 Information Builders