Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Report Caster & (MORE FILE)

Read-Only Read-Only Topic
Go
Search
Notify
Tools
Report Caster & (MORE FILE)
 Login/Join
 
Platinum Member
posted
Hello All,
Please see if you could shed some light on this one.

I have a fex on the mainframe that is launched from the MRE and its been working fine from a while. On a user's request, I tried to deploy it in caster and it is giving me an error message saying it does not recognize the MORE file command.
(Task error: UNRECOGNIZED COMMAND FILE HTOTLINE).

The report runs fine when run thru the MRE launch screen and the Caster job runs fine if the MORE command is commented out. And yes, the additional hold file does exist and is created prior to the MORE command.
Here is the code in question -

TABLE FILE HOLDE5
PRINT
TOTWOCNT/P5.1%
TOTUTCNT/P5.1%
BY AGEGRP
ON TABLE PCHOLD FORMAT EXL2K
MORE
FILE HTOTLINE
END

Really appreciate your time and input on this.
S.


-------------------------------------------------------------------------------------------------
Blue Cross & Blue Shield of MS
WF.76-10 on (WS2003 + WebSphere) / EDA on z/OS + DB2 + MS-SQL
MRE, BID, Dev. Studio, Self-Service apps & a dash of fun !! Music
 
Posts: 218 | Location: Jackson, MS | Registered: October 31, 2006Report This Post
Gold member
posted Hide Post
Whenever I have problems like this through Report Caster only, I find the best starting point is to change the PCHOLD to HOLD and run it interactively and see if you have any hidden error messages that you aren't normally aware of.

Report Caster treats ALL error messages (except a few known warnings) as critical errors.

It's POSSIBLE that the error is actually always occuring, but you're still getting EXL output, and just not realizing it.
 
Posts: 21 | Location: Texas | Registered: October 24, 2006Report This Post
Platinum Member
posted Hide Post
Thx so much for your response Bernie.
But I did try that test too by using the XRETRIEVAL=OFF command, where in the code is just checked for syntax errors without the data being actually retrieved.

No errors for the direct run. RC however gives that error code shown above. I did even stop execution before this final step, did a table file on HTOTLINE to make sure that it is good and all that. Be it EXL2K or HTML or whatever format, the error occurs only thru RC.

S.


-------------------------------------------------------------------------------------------------
Blue Cross & Blue Shield of MS
WF.76-10 on (WS2003 + WebSphere) / EDA on z/OS + DB2 + MS-SQL
MRE, BID, Dev. Studio, Self-Service apps & a dash of fun !! Music
 
Posts: 218 | Location: Jackson, MS | Registered: October 31, 2006Report This Post
Expert
posted Hide Post
quote:
TABLE FILE HOLDE5
PRINT
TOTWOCNT/P5.1%
TOTUTCNT/P5.1%
BY AGEGRP
ON TABLE PCHOLD FORMAT EXL2K
MORE
FILE HTOTLINE
END



BlueZone,

Have you tried with a MATCH, HOLD, then EXL2K that out???

MATCH FILE HOLDE5
PRINT
TOTWOCNT/P5.1%
TOTUTCNT/P5.1%
BY AGEGRP
MORE
FILE HTOTLINE
AFTER MATCH HOLD AS HOLDE6 OLD-OR-NEW
END


TABLE FILE HOLDE6
ETC.
ON TABLE PCHOLD FORMAT EXL2K

Just a thought, don't get many....

Tom


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Gold member
posted Hide Post
I work with a customer doing 100,000's EXL2K reports though Report Caster email each month without issue.

Try holding the data in the MORE step, and then doing the final EXL2K output in a separate step.

If that doesn't work, then definetly open a case with IBI NY.
 
Posts: 21 | Location: Texas | Registered: October 24, 2006Report This Post
Expert
posted Hide Post
I like Bernie's idea...


Tom Flynn
WebFOCUS 8.1.05 - PROD/QA
DB2 - AS400 - Mainframe
 
Posts: 1972 | Location: Centennial, CO | Registered: January 31, 2006Report This Post
Guru
posted Hide Post
We have a home grown report caster where I work. We have had the same problem you described. We did exactly as Bernie said and everything runs smoothly.


Glenda

In FOCUS Since 1990
Production 8.2 Windows
 
Posts: 301 | Location: Galveston, Texas | Registered: July 07, 2004Report This Post
Platinum Member
posted Hide Post
Bluezone,
The MORE command was not supported in ReportCaster for WebFOCUS 52x. You will need to use Tom or Bernies suggestions.

Rich


WebFOCUS 8202 Win 2012
Test - WebFOCUS 8203 on Win 2012
 
Posts: 173 | Registered: November 16, 2005Report This Post
Platinum Member
posted Hide Post
Thank you so much for your responses Bernie, Tom, Glenda & Rich.
The HOLD first and then another step to Excel was an idea I was thinking about myself too. But wanted to see if I was the only one going nuts trying to figure out if this was a limitation in RC. Now, I know. Now, I have peace for a nice weekend.

Have a great weekend y'all.
S.


-------------------------------------------------------------------------------------------------
Blue Cross & Blue Shield of MS
WF.76-10 on (WS2003 + WebSphere) / EDA on z/OS + DB2 + MS-SQL
MRE, BID, Dev. Studio, Self-Service apps & a dash of fun !! Music
 
Posts: 218 | Location: Jackson, MS | Registered: October 31, 2006Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     Report Caster & (MORE FILE)

Copyright © 1996-2020 Information Builders