Focal Point Banner

As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

Join the TIBCO Community
TIBCO Community is a collaborative space for users to share knowledge and support one another in making the best use of TIBCO products and services. There are several TIBCO WebFOCUS resources in the community.

  • From the Home page, select Predict: WebFOCUS to view articles, questions, and trending articles.
  • Select Products from the top navigation bar, scroll, and then select the TIBCO WebFOCUS product page to view product overview, articles, and discussions.
  • Request access to the private WebFOCUS User Group (login required) to network with fellow members.

Former myibi community members should have received an email on 8/3/22 to activate their user accounts to join the community. Check your Spam folder for the email. Please get in touch with us at for further assistance. Reference the community FAQ to learn more about the community.

Focal Point    Focal Point Forums  Hop To Forum Categories  iWay Software Product Forum on Focal Point    [CLOSED] SCHED_DEFAULT queuing

Read-Only Read-Only Topic
Was recently instructed via case management to change the scheduler to use SCHED_DEFAULT and turn queuing on for DEFAULT. Before the change to SCHED_DEFAULT, I was using DEFAULT with a max of 40 and queuing off. I was told to do this because I'm running a lot of flows simultaneously. Parameters for the SCHED_DEFAULT service are set by default to...


Obviously upping the max will effect machine memory. If I up the max_q to, say 40, will that have adverse affects? I'm already limiting the number of flows in my parallel groups, just wanting to have a little more wiggle room.

This message has been edited. Last edited by: FP Mod Chuck,

WebFOCUS 7.7.06
Windows, All Outputs
Posts: 6 | Location: Des Moines, IA | Registered: April 10, 2014Report This Post
posted Hide Post
Hi DeeJay

Since there have been no repsonses on Focal Point I would suggest you update your case with techsupport and get additional guidance from them on these settings.


Thank you for using Focal Point!

Chuck Wolff - Focal Point Moderator
WebFOCUS 7x and 8x, Windows, Linux All output Formats
Posts: 2127 | Location: Customer Support | Registered: April 12, 2005Report This Post
posted Hide Post

First, upping the max will not affect the memory until you are using the agents. If you have a number ready of 2 and a max or 40, only 2 agents are running and therefore using system resources. This is just a potential to use 38 more agents if needed.

The max q just affects the queue manager. The queue manager uses minimal resources, so you can punch it up and you will probably not witness any noticeable system resource usage.

"There is no limit to what you can achieve ... if you don’t care who gets the credit." Roger Abbott
Posts: 1102 | Location: Toronto, Ontario | Registered: May 26, 2004Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  iWay Software Product Forum on Focal Point    [CLOSED] SCHED_DEFAULT queuing

Copyright © 1996-2020 Information Builders