Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at myibi@ibi.com and provide your corporate email address, company, and name.


Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CASE-OPENED] ERROR CONNECTING TO SQL DATABASE

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[CASE-OPENED] ERROR CONNECTING TO SQL DATABASE
 Login/Join
 
Gold member
posted
Hi all,

I saw below,but It's not work for me ..

http://forums.informationbuild...391010782#9391010782

below is my error:

(FOC1261) PHYSICAL INTERFACE NOT FOUND FOR SUFFIX SQLMSS. MODULE NAME : OLEFOC
(FOC1262) THE FOLLOWING NATIVE ERROR MESSAGE(S) CAPTURED :
(FOC1260) Loading D:\ibi\64bit\srv76\home\bin\olefoc.dll: RebindStatus: failed
to bind C:\Windows\system32\KERNEL32.dll
(FOC1263) THE CURRENT ENVIRONMENT VARIABLES FOR SUFFIX SQLMSS ARE :
(FOC1260) PATH : D:\ibi\64bit\srv76\home\bin
(FOC1260) C:\Windows\system32
(FOC1260) C:\Windows
(FOC1260) C:\Windows\System32\Wbem
(FOC1260) C:\Windows\System32\WindowsPowerShell\v1.0\
(FOC1260) C:\Program Files\Microsoft SQL Server\80\Tools\binn
(FOC1260) C:\Program Files (x86)\Microsoft SQL Server\80\Tools\Binn\
(FOC1260) C:\Program Files\Microsoft SQL Server\90\Tools\binn\
(FOC1260) C:\Program Files (x86)\Microsoft SQL Server\90\Tools\binn\
(FOC1260) C:\Microsoft SQL Server 2005 JDBC Driver\sqljdbc_1.2\enu\
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1488) SQL INTERFACE HAS NOT BEEN INSTALLED OR COULD NOT BE INITIALIZED
: Physical interface not found for SUFFIX=SQLMSS . Module name: OLEFOC
(FOC1400) SQLCODE IS -1 (HEX: FFFFFFFF)
(FOC1488) SQL INTERFACE HAS NOT BEEN INSTALLED OR COULD NOT BE INITIALIZED
: Physical interface not found for SUFFIX=SQLMSS . Module name: OLEFOC
(FOC1479) ERROR CONNECTING TO SQL DATABASE

I got this error...


Thanks,
James

This message has been edited. Last edited by: Kerry,


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
 
Posts: 97 | Registered: August 18, 2009Report This Post
Guru
posted Hide Post
Hi Yang,

Have you created the Data adapter for MS Sql Server? If so are you able to get the results while Testing the adapter ?

Thanks,
Ram


Thanks,

Ramkumar.
WebFOCUS/Tableau
Webfocus 8 / 7.7.02
Unix, Windows
HTML/PDF/EXCEL/AHTML/XML/HTML5
 
Posts: 394 | Location: Chennai | Registered: December 02, 2009Report This Post
Virtuoso
posted Hide Post
You're running on a 64 bit machine. I think the sql server installation is also a 64 bit system.
The bind however is to the 32 bit windows kernel ... so that will never work. You should check the path settings of your system environment to be sure that only 64 bit stuff is being referenced. I see several directories with '(x86)' specified. That is the 32 bit version...


GamP

- Using AS 8.2.01 on Windows 10 - IE11.
in Focus since 1988
 
Posts: 1961 | Location: Netherlands | Registered: September 25, 2007Report This Post
Gold member
posted Hide Post
Hi Ramkumar,

Thanks for you reply.I'm created the Data adapter for MS Sql Server. It's work before I reboot the Webfocus Server machine..
When I reboot the machine, and click I found the "Testing the adapter" got the top error.

Hi GamP,
It's work for me before(32bit SQL2005),when I reboot the machine,the error happend.

Thanks,
James


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
 
Posts: 97 | Registered: August 18, 2009Report This Post
Guru
posted Hide Post
May be you can try deleting and recreating the adapter one more time, and try testing that...

The adapter might have got corrupted on the restart...

Please get on to Techsupport, I this doesnt help out...


Thanks,

Ramkumar.
WebFOCUS/Tableau
Webfocus 8 / 7.7.02
Unix, Windows
HTML/PDF/EXCEL/AHTML/XML/HTML5
 
Posts: 394 | Location: Chennai | Registered: December 02, 2009Report This Post
Gold member
posted Hide Post
Hi Ramkumar,

I'm open a case in Techsupport. Thanks.

Thanks,
James


WebFOCUS 7.6.8
WebFOCUS 7.6.10
BI
FLEX
.NET
 
Posts: 97 | Registered: August 18, 2009Report This Post
Guru
posted Hide Post
quote:
try deleting and recreating the adapter one more time, and try testing that


Hi Yang,

Did you try that ??


Thanks,

Ramkumar.
WebFOCUS/Tableau
Webfocus 8 / 7.7.02
Unix, Windows
HTML/PDF/EXCEL/AHTML/XML/HTML5
 
Posts: 394 | Location: Chennai | Registered: December 02, 2009Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CASE-OPENED] ERROR CONNECTING TO SQL DATABASE

Copyright © 1996-2020 Information Builders