Focal Point Banner

As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only. Moving forward, myibi is our community platform to learn, share, and collaborate. We have the same Focal Point forum categories in myibi, so you can continue to have all new conversations there. If you need access to myibi, contact us at and provide your corporate email address, company, and name.

Connect to myibi
Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]Data Migrator Won't Update SQL Server Table

Read-Only Read-Only Topic
[CLOSED]Data Migrator Won't Update SQL Server Table
Silver Member
I very much doubt anyone will be able to help me with this issue, but it's worth a shot.

I have a table, we will call it Rebate table, in SQL Server that doesn't want to get updated. I have a process flow in Data Migrator that takes a few staging tables and combines them to create the Rebate table. The staging tables have the correct data. When I run the query that builds the Rebate table in a SQL Server instance, it provides the correct results, but when you look at the Rebate table in its current state it shows incomplete data. The process flow to build this Rebate table is in a flow that truncates the table before it inserts records from memory. I am not sure why table can't get updated. It does have an index, but I disabled it and tried to then update it, but that didn't work also. The log files don't say much either

I'm am stumped as of right now and any help would be appreciate. Has anyone ever run into something similar to this?

This message has been edited. Last edited by: <Emily McAllister>,

Windows, All Outputs
Posts: 47 | Registered: February 02, 2016Report This Post
Silver Member
posted Hide Post
Have you tried a different load method, such as 'insert/update' for example, to test your results?
There might be a few reasons why the Rebate table is not updated. Please open a hottrack case for your problem, and upload your flow (.fex file) and the related synonyms (.acx and .mas files) to the case. Our Customer Support team will be able then to perform a better analysis and to provide a solution to your problem.

Posts: 37 | Registered: February 13, 2007Report This Post
posted Hide Post
There's not much to go on here without the log. The log for the flow should contain an error message from SQL Server.

Without the log we can only guess. However when you use insert record from memory if there are any constraint violations, not just unique index but also not null or any user constraints, then the entire block is rejected.

As Marina suggests testing with load type insert/update may be helpful since then processing is a row-at-a-time.

Posts: 397 | Location: New York City | Registered: May 03, 2007Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [CLOSED]Data Migrator Won't Update SQL Server Table

Copyright © 1996-2020 Information Builders