Focal Point Banner


As of December 1, 2020, Focal Point is retired and repurposed as a reference repository. We value the wealth of knowledge that's been shared here over the years. You'll continue to have access to this treasure trove of knowledge, for search purposes only.

New TIBCO Community Coming Soon
In early summer, TIBCO plans to launch a new community—with a new user experience, enhanced search, and expanded capabilities for member engagement with answers and discussions! In advance of that, the current myibi community will be retired on April 30. We will continue to provide updates here on both the retirement of myibi and the new community launch.

What You Need to Know about Our New Community
We value the wealth of knowledge and engagement shared by community members and hope the new community will continue cultivating networking, knowledge sharing, and discussion.

During the transition period, from April 20th until the new community is launched this summer, myibi users should access the TIBCO WebFOCUS page to engage.


Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [closed]Opening a Compound PDF or PPT error

Read-Only Read-Only Topic
Go
Search
Notify
Tools
[closed]Opening a Compound PDF or PPT error
 Login/Join
 
Platinum Member
posted
I have a compound report which outputs as a Powerpoint document. When the user opens the document, an error pops up

"Powerpoint found a problem with the content in Report1.pptx. Powerpoint can attempt to repair the presentation. If you trust the source of this presentation, click to Repair"

The above error occurs only when i use our DNS Server name in the WebFOCUS link
https://mytestsite.com/ibi_apps/

Downloading and opening the same Powerpoint report using the actual server name in the WebFOCUS link does not throw any error, and i can see the reports inside
https://abcd001p:8121/ibi_apps/

The issue occurs for PDF version too.

Did i forget to set something?

Thanks in advance

This message has been edited. Last edited by: WF1326,


WebFOCUS
7703/7705/8105m/8201m/8202m

 
Posts: 99 | Registered: September 10, 2013Report This Post
Gold member
posted Hide Post
There are a number of things that could be causing this. Try commenting out everything but one page. See if that runs and then add the next page. Once you determine which page it is you can narrow it down to which report on the page is causing the problem. Painful process but the only way we've been able to work through it.


WebFOCUS 7.6
Windows, All Outputs
 
Posts: 74 | Registered: December 23, 2013Report This Post
Platinum Member
posted Hide Post
Does not work with the car file too

ENGINE INT CACHE SET ON
-DEFAULTH &WF_STYLE_UNITS='PIXELS';
-DEFAULTH &WF_STYLE_HEIGHT='405.0';
-DEFAULTH &WF_STYLE_WIDTH='770.0';
-DEFAULTH &WF_TITLE='WebFOCUS Report';
GRAPH FILE car
-* Created by Info Assist for Graph
SUM CAR.BODY.DEALER_COST
BY CAR.COMP.CAR
ON GRAPH PCHOLD FORMAT PPTX
ON GRAPH SET VZERO OFF
ON GRAPH SET HTMLENCODE ON
ON GRAPH SET GRAPHDEFAULT OFF
ON GRAPH SET UNITS &WF_STYLE_UNITS
ON GRAPH SET HAXIS &WF_STYLE_WIDTH
ON GRAPH SET VAXIS &WF_STYLE_HEIGHT
ON GRAPH SET GRMERGE ADVANCED
ON GRAPH SET GRMULTIGRAPH 0
ON GRAPH SET GRLEGEND 0
ON GRAPH SET GRXAXIS 1
ON GRAPH SET LOOKGRAPH VBAR
ON GRAPH SET STYLE *
*GRAPH_SCRIPT
setPieDepth(0);
setPieTilt(0);
setDepthRadius(0);
setCurveFitEquationDisplay(false);
setPlace(true);
*END
INCLUDE=IBFS:/FILE/IBI_HTML_DIR/javaassist/intl/EN/ENIADefault_combine.sty,$
TYPE=REPORT, TITLETEXT=&WF_TITLE.QUOTEDSTRING, $
*GRAPH_SCRIPT
setReportParsingErrors(false);
setSelectionEnableMove(false);
*END
ENDSTYLE
END


WebFOCUS
7703/7705/8105m/8201m/8202m

 
Posts: 99 | Registered: September 10, 2013Report This Post
Expert
posted Hide Post
The Car file example worked for me on 8.1.04.

No errors in the fex run ?


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Platinum Member
posted Hide Post
Waz,

Thank you for trying. We are using WF8105.

My issue is the query downloads and opens the PPT without any issue when i use the servername in my webfocus link
https://abcd001p:8121/ibi_apps/


When i use the DNS name in the link, https://mytestsite.com/ibi_apps/, the file downloads ok. But opening the file, throws an error as mentioned in my original post


WebFOCUS
7703/7705/8105m/8201m/8202m

 
Posts: 99 | Registered: September 10, 2013Report This Post
Expert
posted Hide Post
Its a long shot, but

Could that have something to do with windows firewall ?

I've seen files to be considered not save because of download from the web.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Platinum Member
posted Hide Post
It may not be. When the output is PDF i get the following error

(FOC3231) CANNOT OPEN AN HTTP CONNECTION (GRAPHSERVURL)
(FOC3251) IMAGE FILE UNREADABLE OR INVALID: IBIIGRPH.SVG (RC=1)

Our application server and reporting server are on two separate machines


WebFOCUS
7703/7705/8105m/8201m/8202m

 
Posts: 99 | Registered: September 10, 2013Report This Post
Expert
posted Hide Post
That looks like you are returning an SVG file.

Some browsers can read them, but usually you will embeb them in something else like PDF.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Platinum Member
posted Hide Post
All i did is replace below line in my car query previously posted

ON GRAPH PCHOLD FORMAT PPTX
with
ON GRAPH PCHOLD FORMAT PDF

And i get the following error
(FOC3231) CANNOT OPEN AN HTTP CONNECTION (GRAPHSERVURL)
(FOC3251) IMAGE FILE UNREADABLE OR INVALID: IBIIGRPH.SVG (RC=1)

It only happens if any report contains graphs. Tabular/Grid reports have no issue.


WebFOCUS
7703/7705/8105m/8201m/8202m

 
Posts: 99 | Registered: September 10, 2013Report This Post
Expert
posted Hide Post
Does the chart return by its self ?

We had to set GRAPHSERVURL to "" to get charts to work, may help with you (8.1.04).


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Platinum Member
posted Hide Post
Waz,

With GRAPHSERVURL set to '', I was able to get the graph in PDF

PPTX output gives me blank page. Any redirect setting that i have to look into?


WebFOCUS
7703/7705/8105m/8201m/8202m

 
Posts: 99 | Registered: September 10, 2013Report This Post
Platinum Member
posted Hide Post
I figured it out. I should also have set EXCELSERVURL to '' for the PPTX to work.

Thank you for you help Waz.


WebFOCUS
7703/7705/8105m/8201m/8202m

 
Posts: 99 | Registered: September 10, 2013Report This Post
Expert
posted Hide Post
This may need silly, but I have "SET EXCELSERVURL = ''" in the fex that produces the PPTX.


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
Expert
posted Hide Post
Should have refreshed.......


Waz...

Prod:WebFOCUS 7.6.10/8.1.04Upgrade:WebFOCUS 8.2.07OS:LinuxOutputs:HTML, PDF, Excel, PPT
In Focus since 1984
Pity the lost knowledge of an old programmer!

 
Posts: 6349 | Location: 33°49'23.0"S, 151°11'41.0"E | Registered: October 31, 2006Report This Post
  Powered by Social Strata  

Read-Only Read-Only Topic

Focal Point    Focal Point Forums  Hop To Forum Categories  WebFOCUS/FOCUS Forum on Focal Point     [closed]Opening a Compound PDF or PPT error

Copyright © 1996-2020 Information Builders